1. Download our Official Android App: Forums for Android!

Support Gmail won't push to my Droid

Discussion in 'Android Devices' started by MusketeerX, Aug 16, 2010.

  1. MusketeerX

    MusketeerX Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 16, 2010

    Aug 16, 2010
    1
    0
    5
    I have a regular Motorola Droid. Last Friday it stopped pushing emails to my phone. Then it wouldn't allow me to download new apps. I forced the new FroYo update, which has once again allowed me to re-download apps, but it still won't push email to my phone.

    I have the autosynch on. I have cleared the data and cache of the gmail app. I have even signed in and out of googletalk a bunch. I'm all out of ideas. Anyone know what to do?
     

    Advertisement

  2. ggriff3712

    ggriff3712 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Oct 10, 2010

    Oct 10, 2010
    2
    0
    5
    In Settings / Accounts / {Particular GMail Account}, I once had buttons to individually set the auto-synch for each. The buttons have disappeared. I can do a manual Refresh but no longer have auto-synch.

    I'm thinking that it may be related to installing new apps but I've installed several recently and uninstalled only a few. I really don't know what triggered the buttons to disappear.
     
  3. ggriff3712

    ggriff3712 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Oct 10, 2010

    Oct 10, 2010
    2
    0
    5
    FTI, my phone is the Droid X on Verizon Wireless.
     
  4. pung

    pung Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 28, 2010

    Dec 28, 2010
    1
    0
    5
    Resurrecting this thread to see if anyone has had a solution? I have this issue on the original Droid, and so does my friend who has the Droid 2. I
     
  5. johnlgalt

    johnlgalt Antidisestablishmentarian
    Rank:
    None
    Points:
    453
    Posts:
    9,415
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    9,415
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Are you sure the email is coming to your inbox? I have server side filters running, and anything that GMail filters to a separate folder (called label on GMail) I don't get a notification of - anything coming into my inbox does.
     
  6. Gekko

    Gekko Android Expert
    Rank:
    None
    Points:
    113
    Posts:
    893
    Joined:
    Mar 20, 2010

    Mar 20, 2010
    893
    320
    113
    USA
    i was having the same problem - Gmail stopped automatically PUSHING post-Froyo-update on BOTH of my Gmail accounts. the solution that worked for me is a HARD RESET. ERASE/WIPE your Android phone clean and then manually reinstall everything one by one. this is the only thing that permanently fixed the post-Froyo lack of Gmail PUSH for me. the Gmail clear cache data works but ONLY TEMPORARILY (~24 hours). it's now been 2+ weeks after my hard reset and both of my Gmail accounts now PUSH sync flawlessly. my guess is that when you update the OS version you need to start clean on the Gmail sync and the only way to do this is a HARD RESET.
     
  7. AngryHatter

    AngryHatter Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    973
    Joined:
    Jan 21, 2011

    Jan 21, 2011
    973
    92
    78
    QA Admin
    SoCal
    MailDroid - no need to hard reset and wipe the phone.
     
  8. Eyezup

    Eyezup Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 9, 2011

    May 9, 2011
    1
    0
    5
    Hey. I don't know if you found the help you were looking for, but if you are having repeated trouble with your phone and don't seem to be getting anywhere, contact me. I may have something that would help.
     
  9. buckyweet

    buckyweet Member
    Rank:
    None
    Points:
    36
    Posts:
    30
    Joined:
    Jan 21, 2010

    Jan 21, 2010
    30
    4
    36
    Virginia
    I've run into this as well on D1 and D2. I was able to resolve it by going to Settings->Applications->Manage Applications->Running(or All)->Gmail and then Force Stop and then Clear data.
     

Share This Page

Loading...