1. Are you ready for the Galaxy S20? Here is everything we know so far!

Google Calendar constantly syncing

Discussion in 'Android Devices' started by shearclass, Dec 20, 2011.

  1. shearclass

    shearclass Newbie
    Thread Starter


    I have an Xperia X10. Not rooted, and I am not particularly phone savy.

    My phone has recently started to almost constantly try and synchronise something. It keeps showing the synch icon at the top of the screen. It is always flicking on and off. Sometimes it stays on for a while, other it flicks off and doesn't come back for a few minutes.

    This has coincided with a massive drop in battery life, which wasn't that good anyway (though one this issue is resolved i will look at the posts on here about increasing battery life, seems there is a few things i can do to help this). I assume the calendar constantly syncing is running the battery down

    I am sure it is my calendar that is constantly synching. I use my calendar, but i will do what it takes to get my phone back, as i only get a few hours use out of it now.

    My settings:

    General sync settings - Background data is unticked

    Under running applications, the calendar comes under Google Services. Clicking into Google services, there is a Services section, and a Processes section.

    The Services section contains Google Messaging Service, and every time the sync icon appears, then 'CalendarSyncAdapterSe...' appears here as well. Although there is an option to stop google messaging service, there is no option to stop the CalendarsyncAdapterSe, just a setting option instead. This settings option just takes me to the general sync settings mentioned above.

    In the Processes section, it lists Google Services, and Calendar storage.

    Sorry for the long post. Is anyone able to help? It would be much appreciated.

    Many thanks


    1. Download the Forums for Android™ app!


  2. beau420

    beau420 Android Expert

    Have you tried to open Accounts and Sync and delete the account? Is there only the one account?

    Are you running Android 2.1 or 2.3?

    There are two place your phone will sync. One is on that Accounts and Sync page. Uncheck both options in there temporarily. Second place, is in the Power Control Widget. On your home screen, if you don't have a Power Control Widget, long hold on a blank part of the screen and add the widget called Power Control.

    Uncheck the Sync button on that too.

    Hopefully some of that helps.
  3. shearclass

    shearclass Newbie
    Thread Starter

    Thanks for your response. When I try to delete the account, I get the message:

    This account is required by some applications. You can only remove it by resetting the phone to factory defaults (which deletes all your personal data). You do this in the Settings application, under Privacy

    The sync is turned off in both the power control widget and in the Accounts & Sync section. Even if syncing was turned on, I don't think it should synch this often! It is destroying my battery life.

    I'm using android 2.3.3.

    Do you think I should back up phone, reset to factory defaults as the message tells me, then reapply contacts, messages, etc? Then try and re-add this account? I've had it linked to my calendar for about a year now, and only recently has this problem occurred.

    Or should I back my phone up and re install the software using the Sony Ericsson support thing on my PC?

    Really appreciate your reply, any more help would be great
  4. beau420

    beau420 Android Expert

    Both your ideas are good suggestions. I guess the quickest way is to backup your contacts and any files and do a factory reset. Then re add an account and see if it does 1 sync and that's it.

    If that fails, then go the other longer route.

    Haven not seen or heard of that before.....so it might have something to do with the 2.3.3 update.....but also, when upgrading from 2.1 to 2.3, you are suppose to do a factory reset to remove any old setting/configurations from 2.1. So it could just be some old things form 2.1 that are causing a problem.

    Factory reset would be my first quick test. (don't have to unmount the SDCard and format the entire SDCard)
  5. shearclass

    shearclass Newbie
    Thread Starter

    I have inadvertently (fingers crossed) fixed this.

    I went to the Accounts and Sync settings, and turned Background Data ON, then turned Auto-sync ON, then clicked into the google mail account and then unticked the automatic sync for Picasa Web Albums (whatever that is), Contacts, Gmail, and Calendar. Seems to be working fine now!

    i don't know why this suddenly became an issue. Doubt it's related to the upgrade as i did that ages ago, but this problem is much more recent.

    I've got my phone back! I'll now follow the advice on other threads about prolonging battery life
  6. beau420

    beau420 Android Expert

    If you want to actually sync any of that stuff, I highly suggest syncing them one by one and figure out which one is causing the problem.
  7. shearclass

    shearclass Newbie
    Thread Starter

    The only one i would particularly like to sync on any sort of regular basis is the calendar, which I am pretty sure is the one that was causing the problem.

    Never mind, I've got my phone back and can use it for more than a few hours now. Surprising just how much that constant syncing caned the battery.

Sony Ericsson Xperia X10 Forum

Features and specs are not yet known.

Release Date

Share This Page