1. Are you ready for the Galaxy S20? Here is everything we know so far!
Thread Status:
Not open for further replies.

[HELP] Apps2SD and extSD2internalSD

Discussion in 'Archived Threads' started by JerryScript, Jul 6, 2013.

  1. JerryScript

    JerryScript Android Expert
    Thread Starter

    I'm working on incorporating true a2sd support for the Galaxy Victory. I had a scary but seemingly successful build last nite, but the scary issues make me want to do considerable testing before releasing it.

    What happened: I added support for a2sd, which is actually built into the system just not activated in the ramdisk. I added the a2sd service and triggers in init.rc since the a2sd is part of the stock bin. I kept the extSD2internalSD mod (in init.d), since the external SD is the only one you can partition.

    I used the SDcard I had used on my Optimus V since it was already partitioned and formatted to ext4. As soon as I booted, every app started crashing, but the system kept running fine. I looked in the app drawer, and saw a listing of the apps I had installed on the Optimus V. I then realized I had not re-formatted the SDcard from my Optimus V, so the Victory was attempting to load the apps I had installed on the OV.

    This makes me believe I have it working, for the most part, since it did actually try to load the apps from the ext4 partition on the external sdcard (swapped for internal). Unfortunately, I decided to upgrade my Ubuntu install (Wubi flavor) to 12.04, which is not a stable release for building Android (still experimental). I've been able to load Ubuntu, update everything, run apt-get install to download the build requirements for Android, and actually use many of the sdk tools. I was even able to do a couple of test builds of Victorious. However, after the third or fourth boot into Ubuntu, it doesn't boot up anymore, stupid experimental branch (actually, stupid me for using an experimental branch). This has happened to me three days in a row now, wasting 4 hours each day to install and update everything, get a build done, then have Ubuntu not boot and give up for the night.

    Long story short, I'm going to install Ubuntu 11 via Wubi, and see if I can get a stable build environment going. I was wondering if anyone here might have experience getting a2sd to work, especially experience on phones with internal SDcards. I'm flying blind with google as my guide, and feeling a bit nervous, could use some help! ;)
     


  2. Mobstergunz

    Mobstergunz Android Expert

    Unfortunately I've never had a phone with internal storage to mess with. G60madman has both the Sprint and Virgin Victory so he might be able to help. As for Ubuntu have you given Dual-Booting a chance? Its more stable then using wubi and running it as a Windows add-on. You will have to make space on your hard drive for it but it might solve your issue.
     
    JerryScript likes this.
  3. JerryScript

    JerryScript Android Expert
    Thread Starter

    Thanks! I've already partitioned and prepared for a full Ubuntu install last nite. I've been using Wubi for three years and it never failed me till this 12.04 upgrade! It so easy using Wubi to uninstall/re-install as you please based on your needs, which is why I stuck with it so long.
     
  4. dsmryder

    dsmryder Android Expert

    As far as checking if the a2sd worked, you could open up a terminal on the phone and use the 'df' command. It will show what systems are mounted.

    And as far as the OS failing, I had an issue where I ran out of space. I have found that Ubuntu doesn't treat low space like I would expect, with errors. It has crashed on me many a times. I did find a script to expand the Wubi disks. It was wonderful as I was learning a "whole" ton of stuff and kept hosing things I just copied the disk and expanded the copy. Goof up and copy the disk and expand the copy, with known good changes.

    Hope I didn't say anything useless:rolleyes:
     
  5. JerryScript

    JerryScript Android Expert
    Thread Starter

    Thanks, I was a little worried when everything was FCing, wasn't sure the effect of having my old phone's apps attempting to load on this phone (mind was racing, old phone was BACKside-IHO-CM7.2[kang back in the day] with a lot of my customizations and scripts, didn't know what might happen). I immediately rebooted and restored an old backup, didn't even think about df or any other terminal commands at that moment. ;)

    I've decided to go ahead and install Ubuntu as a proper dual boot on my Win7 machine, not enough space on the old hdd on my ancient XP box. I'm thinking of putting Ubuntu on my tablet just for shits and giggles, and see if it can produce anything.
     

Share This Page

Loading...