1. Are you ready for the Galaxy S20? Here is everything we know so far!

Help Needed Rooting!!

Discussion in 'Android Devices' started by Shay729, Aug 19, 2010.

  1. Shay729

    Shay729 Lurker
    Thread Starter

    So for the last cuple of days I have been trying root my moment using the sw update and system tool but have run into problem with the phone connecting during downloading. So I was wondering if there is a way to root/flash the phone using terminal emulator and telnet?
     


  2. pastafarian

    pastafarian Pâtes avec votre foie

    If you get to the point where you're at the download page and it hangs without transfering the rom, try unplugging and reinserting the usb cable. I know it says don't do it, but it's worked for me. What you don't want to do is unplug the cable while the transfer is occurring.
     
  3. SteveVHT

    SteveVHT Member

    If it is that your update software does not see the phone, then you will have to do this.....
    (copied my own solution from an earlier thread)
    You need to uninstall all Samsung software and drivers completely. Do this the normal way through Control Panel.
    After that, you need to go into your registry and delete all Samsung folders.
    You open up Regedit in Windows
    Then go to HKEY CURRENT USER, Expand that (+), expand Software
    and delete the Samsung folder
    Do the same for HKEY LOCAL MACHINE
    When you simply uninstall Samsung stuff, it leaves a bunch of junk in the registry of the computer even after uninstall.
    Reboot the computer with no phone attached.
    Download the Samsung update from Sprint

    http://www6.sprint.com/downloads/samsung/executables/SamsungMoment_Update.exe

    Install the updater. After its installed, right click the SWUpgrade and run as administrator....Follow all on screen instructions, and you should be good.

    If you do not need the updater, then you can skip the software install and just download the drivers for the phone from the SDX forum. Just do a search.
    But I suggest you do it this way, it was the only thing that worked for me...
    Running Windows 7 Ultimate 64

    Hope this helps
    Steve
     
    myddraal666 likes this.
  4. Shay729

    Shay729 Lurker
    Thread Starter

    Thanks for the replys....Steve I tryed what you said but Im getting "Unknown uninstall Error. Contact to Distributor" when I go in Control Panel to remove the USB Driver. Im using windows xp do you have any ideas what may be causing that?
     
  5. SteveVHT

    SteveVHT Member

    You need to go into the registry.....
    In XP, just type into the command prompt (run)( you can hit Ctrl+r, or Start and click Run)
    regedit
    A screen will pop up with about 6 folders on the left, then follow those instructions for deleting...
     
  6. Shay729

    Shay729 Lurker
    Thread Starter

    Ok I had to do what you where saying Steve on a lab top with windows 7 because it was not working on my windows xp so big thanks for that. Oh I also found some other options for people who still having this problem from SDX:

    Try leaving Device Manager open and all fields expanded, then have your phone boot up into Android mode while plugged in, see what appears in dev-man, right-click anything related to the phone, select Uninstall, then check the box for Delete driver software. Repeat this in download mode and recovery mode, then check Programs and Features for anything samsung/android/sprint/phone related and uninstall it, then reboot with the phone unplugged. That should get you about as clean as you can get.
     

Samsung Moment Forum

The Samsung Moment release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1440mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...