1. Download our Official Android App: Forums for Android!

Apps Install_failed_older_sdk

Discussion in 'Android Development' started by Alteria, Jun 18, 2011.

  1. Alteria

    Alteria Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    2
    0
    5
    Hello all,

    I am new to development on Android, but have been developing applications and software for years. I have been working on an application for 2.2 with API version 8 using Eclipse. I have been debugging and installing on both the AVD and my HTC Incredible for a week now. I ran into a problem just a few hours ago and I am not able to figure out what I may have changed that caused the problem. When I try to install the .apk on my phone or the AVD I get the following message: INSTALL_FAILED_OLDER_SDK. I am not sure what the error is on my HTC as all it says is parse error. I am assuming it would be the same error. When I look at the properties the 2.2 is still checked as the target.

    Any assistance is appreciated.
     

    Advertisement

  2. Alteria

    Alteria Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jun 18, 2011

    Jun 18, 2011
    2
    0
    5
    I figured out my mistake. Somehow I deleted the value of the android:targetSdkVersion in the manifest file. Not sure how I did that, but adding the value back in resolved the issue.
     

Share This Page

Loading...