1. Download our Official Android App: Forums for Android!

Root [International] Unable To Root!

Discussion in 'Android Devices' started by Mykltron, Dec 28, 2013.

  1. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    I can't root my galaxy s3 because Odin won't connect to the phone, I think this is because it just doesn't work on a Mac running VMware Fusion.

    I can't root it through my Mac because according to this article:
    How to Root Galaxy S3 on Mac OSX!
    I need Android File Transfer, which I've never got to work on my s3 or my friend's s3mini.

    Do I need to use Android FT or, as the article says to copy the file to anywhere on the s3, can I do it through Airdroid?
     

    Advertisement

  2. GTWalling

    GTWalling Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,277
    Joined:
    Sep 9, 2012

    Sep 9, 2012
    1,277
    412
    163
    Alabama USA
    The only way to root is via USB connected. If you can not connect with the Mac, you would need to find a friend with a PC.
     
  3. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
    Would Mobile Odin be able to do it if he cant get use of a PC mate?
     
  4. davoid

    davoid Android Expert
    Rank:
     #83
    Points:
    223
    Posts:
    1,801
    Joined:
    Aug 3, 2011

    Aug 3, 2011
    1,801
    710
    223
    London
    Mobile Odin requires root. I just tried opening it and superuser popped up asking for permission.
     
    funkylogik likes this.
  5. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    Can I do it through Kies then?

    In step 10 that tutorial says 'connect as disk drive and copy the file CWM-SuperSU-v0.87.zip from GalaxyS3RootMac folder to anywhere on your Galaxy S3' and then has a link to an article about doing this through AFT. I can transfer a file to 'somewhere' on my s3 through Kies (but I have no control where!) and with Airdroid I can chose any folder so surely either of these methods would work.

    I've never rooted so forgive my ignorance (that's why I'm asking for help!) but surely I can do all the other steps through USB and then do that one file transfer through any method (except AFT) and it will still work.
     
  6. davoid

    davoid Android Expert
    Rank:
     #83
    Points:
    223
    Posts:
    1,801
    Joined:
    Aug 3, 2011

    Aug 3, 2011
    1,801
    710
    223
    London
    How far through the process did you get? Did you flash the recovery?

    Did Heimdall work, and if not did you try the terminal instructions?

    Having Kies installed should provide you with the drivers that Heimdall needs to flash the phone.
     
  7. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    I haven't done anything yet! I'm too scared of bricking my phone! After Odin's inability to connect to my phone I wanted to see if this Mac method will work without AFT.

    So, can I do step 10 through another file transfer method like Kies or Airdroid?
     
  8. davoid

    davoid Android Expert
    Rank:
     #83
    Points:
    223
    Posts:
    1,801
    Joined:
    Aug 3, 2011

    Aug 3, 2011
    1,801
    710
    223
    London
    I would try the method described using Heimdall. Personally I've never heard of Odin working on a Mac, so I wouldn't let that put you off.

    No, just copying the Superuser zip file over to the phone will not be enough because you are then instructed to use your custom recovery to flash the zip file.

    You need to flash the recovery .img first.

    Then you could simply email the zip file to yourself to get it on the phone. Then boot into recovery and flash it.
     
  9. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    Sorry Davoid, that's a complex answer and I need to clarify. I shall use Heimdall as described in the tutorial. That doesn't look like a problem. I also understand that I need to do all 18odd steps to root.

    Please just answer with a 'yes' or 'no' to keep things simple in my poor noob brain! Can I do step 10 (copy the file CWM-SuperSU-v0.87.zip from GalaxyS3RootMac folder to anywhere on your Galaxy S3) via Kies/Airdroid?

    (and just to clarify, in case this message seems to contain bad attitude, it's unintentional. I really appreciate all the help.)
     
  10. davoid

    davoid Android Expert
    Rank:
     #83
    Points:
    223
    Posts:
    1,801
    Joined:
    Aug 3, 2011

    Aug 3, 2011
    1,801
    710
    223
    London
    Yes, you can use either of these methods if they work for you. As long as you understand this doesn't give you root. It is just a way of getting the zip file onto your phone. But I think kies or airdroid would be fine.

    Then from within your custom recovery you can browse to wherever the zip file has been stored, in order to flash it.
     
  11. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    Thank you. That's clear. I know it's just one step out of a loooong list!

    Okay, slightly off topic: what are the risks of this? How likely is a bricking here? I only want to root so I can give Tasker back its ability to control Airplane mode since the stupid update to stupid 4.3. I'm not interested in flashing other ROMs.
     
  12. davoid

    davoid Android Expert
    Rank:
     #83
    Points:
    223
    Posts:
    1,801
    Joined:
    Aug 3, 2011

    Aug 3, 2011
    1,801
    710
    223
    London
    I would say there is very little risk of bricking your phone by rooting. That's not to say there is no risk, and it would be irresponsible to say so, but rooting isn't one of the processes that usually causes permanent damage to a phone. It is far more dangerous to flash a modem to your phone, for example.

    Any problems you are likely to have can (usually) be recovered from.

    I would, however, recommend using a laptop to flash your phone, because the laptop's battery affords you built in protection against power outages during the flash, which could otherwise cause you problems.

    If you have any problems, the people on this forum will do our best to help you.

    Good luck :)
     
    Mykltron and funkylogik like this.
  13. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    Ah, thank you. Yes, good point about the laptop.

    Very well, I shall try a root later.
     
  14. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    This is unbelievable. I just went through the whole thing and nothing changed.

    At Step 12 (Once in ClockworkMod Recovery, choose &#8220;install zip from sdcard&#8221;. ) I didn't get the screen it mentions or shows in the pic. It's in Android system recovery <3e> and the available options are:
    -reboot system now
    -apply update from ADB
    -apply update from external storage
    -wipe data/factory reset
    -wipe cache partition
    -apply update from cache

    Feeling daring I went to 'apply update from external storage' and selected the SuperSU zip. It then rebooted but nothing has changed except that Odin mode now says CUSTOM BINARY DOWNLOAD: Yes (1 counts)

    So what do I do? Do I need to install ClockworkMod Recovery? Or is that what installing recovery.img with Heimdall is doing? Cos it said it did that.
     
  15. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
    Ive only ever used very simple methods to root in the past but id try flashing the recovery (clockworkmod) again because you dont have it yet.
    I dont think many people here use Macs so i dont know much about it tbh. On a pc its a very simple process using odin. It does it all in one step
     
  16. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    No. It just will not open in Clockworkmod. Heimdall says it's done its thing but apparently it hasn't. Could it be because the OTA update to 4.3 has screwed up my phone? It's no longer registered to the network. I'm going to a service centre tomorrow to get it fixed.
     
  17. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
    Did you lose your IMEI mate?
    Ive never took the 4.3 update but i know its giving some people rooting problems.
    Are you gona try n get it fixed under warranty? If so you could have problems because the flash counter has been tripped.
    What id do, once you have your imei back is use someones windows pc to root :thumbup:
     
  18. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    I sent my phone off for repairs on Dec 30th and have only just got my phone back today (OMFG!). It got repaired under warranty, even though I'd try rooting. Anyway, today I spent four hours trying to root it with even less success than before.

    I tried:
    - Heimdall on my Mac with and without Kies installed;
    - Heimdall on someone else's Mac with and without Kies installed;
    - Odin v1.85 and v3.09 on my Mac's virtual Windows 7 with and without Kies and after installing what I think was the latest set of drivers;
    - Odin v3.09 on someone else's Windows 7 with and without Kies and after installing what I think was the latest set of drivers.

    Odin didn't find my s3, although the PC made the connection noise with two different cables that work for Kies.

    Heimdall did various things from nothing to error messages.

    So my question is: WTF? I have the lack of control I have with 4.3 and desperately want to root. Could they have put some sort of security lock on so I can't?
     
  19. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
    Theres now a way to use odin files on mac mate. Ill try find the link.
    Dont know why it didnt work on PC. Was it the latest odin? (V3 i think[?])
    Installing kies should have installed the drivers but kies has to be closed while you use odin :thumbup:
     
  20. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
  21. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
  22. Mykltron

    Mykltron Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    91
    Joined:
    Dec 20, 2011

    Dec 20, 2011
    91
    11
    18
    You'll never guess what... I'VE ONLY GONE AND ROOTED MY PHONE! I don't know why but I had another go with Heimdall and after installing Kies it worked. Of course, SuperSU is not working so I've got to go and start a thread about that because I can't find a solution anywhere.
     
    funkylogik likes this.

Share This Page

Loading...