1. Download our Official Android App: Forums for Android!

Root Issuing Rooting Brand New Droid Bionic

Discussion in 'Android Devices' started by griznuts, Jan 2, 2012.

  1. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    I purchased a brand new Droid Bionic today and am having issues rooting my phone. I am attempting to use the one touch root, "Pete's Motorola Root Tools" v1.06. The first two steps, setting up the Symlink and modifying the local.prop steps were successful. When adding su, busybox, and superuser.apk, I receive an error stating, "error: adb could not be granted root access via local.prop method. Try again from the start, but if the problem continues, check your version of Gingerbread -- hopefully you don't have a version where this exploit was fixed." I have no clue where to go from here. Any insight on how to get this device rooted would be greatly appreciated.
     

    Advertisement

  2. stepduck

    stepduck Lurker
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Nov 13, 2009

    Nov 13, 2009
    9
    0
    5
    I am experiencing the same issue and have been trying to root my Bionic for the past 3 hours. I have tried other methods like the Pete's Motorola Root and then tried a manual method using a command prompt. Nothing is working. I am a fairly inexperienced person when it comes to rooting but I just rooted my cousin's phone last week, it took all of about 30 minutes. PLEASE HELP!!!!
     
  3. trophynuts

    trophynuts Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    5,630
    Joined:
    Jul 6, 2010

    Jul 6, 2010
    5,630
    1,792
    313
    I work in a Tech related field. Have been in a tec
    SouthEastern US
    Welcome to AF.

    If you guys don't mind i would like to move this thread to the "All things Root" section of the Bionic. You will get more help in there. Thanks.
     
  4. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    What operating version are you using ? .886 or .893
     
    trophynuts likes this.
  5. PalsAndroid

    PalsAndroid Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    19
    1
    16
  6. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    If you are on .893 there is a one click for windows by p3 droid. When i get to my laptop i will post a link

    Here is a link to the thread. the one click method is at the bottom of post #2

    1 Click for .893


    Then use releashed to forever root option 4. Releashed
     
    trophynuts likes this.
  7. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    The 1 click for .893 failed from the start. I was getting a message of "The compressed (zipped) folder is empty when trying to extract the files. I attempted to download the file again and the same thing. I also tried the 43V3R root and got the following:

    *sending 185 zerglings
    -bad luck, our rush did not succeed [​IMG]

    when I hit a key to continue, I received the following:
    *Installing busybox, su, and SuperUser apk...
    remount failed: Operation not permitted
    failed to copy 'busybox' to /system/xbin/busybox' : Read-only file system
    failed to copy 'su' to /system/xbin/su' : Read-only file system

    then it appears the Superuser.apk unpackages
    Success

    Unable to chmod /system/xbin/su: No such file or directory
    Unable to chmod /system/xbin/busybox: No such file or directory
    /system/xbin/busybox: not found
    link failed Read-only file system
    Unable to chmod /data: Operation not permitted

    *Installing 43V3R Root...
    failed to copy 'mount_ext3.sh' to '/system/bin/mount_ext3.sh: Read-only file system
    Unable to chmod /system/bin/mount_ext3.sh: Read-only file system
    *All done! Your phone should now be 43V3R rooted!

    I am still having fits here and can't find anything that works. Anything else for me to try?
     
  8. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    did you unzip the 1 click before running the runme file? If so what program did you use? If you still can't get it pm me and I will send you the 1 click I used. You can also do the manual method described in the thread.
     
  9. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    I followed the link to the post stating

    Windows Version For the lazy I made you a 1-click ---> 1-click_exploit.zip

    I downloaded the zip file and attempted to extract the contents. I received the following:

    Cannot Complete the Compressed (zipped) Folders Extraction Wizard
    The compressed (zipped) folder is empty
    Before you can extract files, you must copy
    files to this compressed (zipped) folder.

    The close this wizard, click finish.

    When attempting to open the zipped folder, I get a message stating:

    Windows cannot open the folder.
    The compressed (zipped) folder 'c:\.......1-click_exploit.zip is invalid

    I attempted this on multiple computers with the same result.
     
  10. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    I just downloaded the same file and was able to extract it.

    Try using 7-zip or jzip. you can get them here.

    7zip

    jzip

    once you install one of these, go to where you downloaded the 1 click file and right click it. Select 7zip or jzip and extract here option. Find the file that was extracted. Then you can go to the runme file and run it.
     
  11. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    OK, am I a moron or what? I am now able to extract the file, however; I see no file extension whatsoever and when I select the file, I am being prompted for a program to open it with.
     
  12. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    click on the file called runme. under file type it will say windows batch.

    it is right below busybox.
     
  13. PalsAndroid

    PalsAndroid Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    19
    1
    16
    While I cannot help with the method that dfib gave, to use the method that worked for me start it by using the R3L3AS3DRoot file. I also used 7zip to unzip the original downloaded file. Make sure the phone is in USB Debugging Mode, your computer recognizes your phone (my PC installed more drivers when booting into recovery mode too), and that your phone is set to Charge Only when connected. Also, use option 1. This reverts the phone back to the previous system version and then installs the 43v3r root hack. When I used the other option, it did not work for me either...so if you did not use option 1, try it out. After you are certain that the 43v3r root took, you can then update back to .893 keeping root.
     
  14. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    dfib - I don't have such a file. Attached you will find what was extraced via 7zip.

    Palsandroid - the content I provided when running the R3L3AS3DRoot file was when I was in charge only and debugging modes... and when selecting option 1.
     

    Attached Files:

  15. PalsAndroid

    PalsAndroid Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    19
    1
    16
    Hmm, that's odd. I can only say what worked for me as I am still learning the ropes with all this tech stuff. I hope you can get the issues resolved and someone with a little more knowledge can point you in the right direction.

    Good luck, this phone is even more awesome when rooted!
     
  16. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    I appreciate your help. I had a Droid X that I had rooted with Z4 root and can't wait to get Titanium Backup on the device to get my apps restored. This phone is wicked fast, but I am itching to get it rooted.
     
  17. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    It does not look like the file unzipped right. When you unzip the file it should look like this.

    1 click file unzipped

    and then inside that file it should look like this

    runme.png


    try unzipping it with one of the programs I posted.
     
  18. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    The files in your Dropbox are not set to public so I can't access them. I swear, I am beginning to feel this is not meant to be! I really appreciate your help.
     
  19. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    sorry about that. now try them
     
  20. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    First one is good, second is a url. Please re-share because that is the one that I need to see.
     
  21. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    should work now.
     
  22. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    dfib - thank you for going through all of that. I followed the link (1 Click for .893) and saved the zipped folder "1-click_exploit" to my desktop. I extract the contents using 7zip and jZip separately with the same result. Only one file is extracted named 1-click_exploit. There is no file extension, the file type is simply "file". I have never seen anything like this. I sure don't know why the contents are not extracting properly. I'm at a loss...
     
  23. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    just sent you a pm with a link.
     
    griznuts likes this.
  24. griznuts

    griznuts Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Jan 2, 2012

    Jan 2, 2012
    10
    0
    15
    dfib - you're awesome!! For some reason the previous zip folders were not properly extracting the contents. The files you provided worked and I ran the permanent root and everything was successful. Thank you for being patient.
     
  25. OutOfPhase

    OutOfPhase Premium Member
    Rank:
    None
    Points:
    523
    Posts:
    4,024
    Joined:
    Dec 7, 2010

    Dec 7, 2010
    4,024
    2,149
    523
    Retired Lineman
    Tampa, FL
    no problem I am glad it worked.
     

Share This Page

Loading...