1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support mytouch 4g and a Mac...can't connect via usb

Discussion in 'Android Devices' started by Anges, Feb 14, 2011.

  1. Anges

    Anges Member
    Thread Starter

    hi, all
    I am new here and so if this has been covered before please cut me some slack. I figured I would post this in case anyone else runs into this.

    I upgraded to the myTouch 4g this weekend and I have a Apple Mac computer. After setting it all up, I was ready to move over some music using doubleTwist. I could not connect the phone to the Mac as a external drive via the USB cable. Even thought the app, was set to connect, the notification to mount the drive never appeared.

    The *idiot* at T-Mobile customer care kept telling me I needed to install a driver (which of course ended in .exe an was for a PC, not a Mac). I finally was transfered over to the real tech support and he said that - yes, I was correct, there was no driver to do this, at the moment, with a Mac. He did stay I could get the doubleTwist Air program for the Mac ($35) and I could sync my music via wi-fi. Then the tech said he had a better program for me - it was the same cost and did much more.

    What is this application - it is called SyncMate. I installed the app on my phone, installed the program on my Mac and in 5 minutes, via wifi not only was i syncing my music but I was able to directly sync my contacts, calendar, bookmarks, pictures and mount the sd card.

    For the contacts and calendar you can bypass Google completely! Which is great for me, since I don't want to use Google to do a three way sync!
     

    Advertisement

  2. Anges

    Anges Member
    Thread Starter

    Here is an update to issue of connecting the MT-4G to a Mac. I found that if you have the following settings:
    1) Connect To PC set to Disk Drive (Settings-Applications-Connect To PC-Default Connection Type-Disk Drive)
    2) USB Debugging mode is on (Settings-Applications-Development-USB Debugging Mode)
    3) Fast Boot is off (Settings-Applications-Development-Fast Boot)...

    When I plugged in the phone to my computer, the SD card mounted !!!!

    Hopes this helps others...
    Cause "It's so fluffy"
     
    davenicolette likes this.
  3. davenicolette

    davenicolette Lurker

    I use Ubuntu Linux and experienced the same problem connecting a My Touch 4G. The exact same steps Anges outlines worked for me to connect to Ubuntu, as well.
     
    Anges likes this.
  4. Anges

    Anges Member
    Thread Starter

    Isn't that odd that, that one flag makes all the difference. Thanks for the THANKS :D It's my first one.

    Now I am trying to perma root - with no luck (with 3 days of trying) - I need a life.

    Anges
    'cause "It's sooooo fluffy!"
     
  5. Living Silver

    Living Silver Lurker

    Have you tried this will only doing 1)? I just set the Connection type to Disk Drive and my SD card pops up on my desktop. I'm not sure the Debugging mode and Fast Boot are necessary.
     
  6. Anges

    Anges Member
    Thread Starter

    Are you using a Mac or a PC - from what I have experienced [I am using a Mac] - just doing item one will not work, I even spoke to T-Mobile customer service. It is when you do items 1-3 [ON A Mac] that you can get the computer to mount the sd card

    IF you are using a PC, just doing item 1, will work.

    Agnes
    'cause It's so fluffy!
     
Loading...

Share This Page

Loading...