Help S5 - Auto rotating Delay


I noticed recently my S5 takes 2 secs to auto screen rotate. Usually it is quite responsive and rotates instantaneously. I have cleared the cache and it doesn't seem to make any difference. Any ideas how to improve this?

I am on "one 2 free" network in Hong Kong.

Thanks in advance.


Well-Known Member
Did you enable "Smart Rotation"? (Settings, Display, Click on "Screen Rotation" and the option will appear)
If so, that function uses the front camera to determine the position of your head, so if you're laying on your side it will prevent the screen from rotating. I had it on for a day and disables it because it caused a lag in the normal screen rotation.
Something to check if you haven't already.



Thread starter
Thanks Anthony! Unchecked the box for "rotation based on orientation of face" and it worked! Appreciate the help!