1. Are you ready for the Galaxy S20? Here is everything we know so far!

S5570 - Non-functional camera, audio, gps, time/date - frequent auto-rebooting

Discussion in 'Android Devices' started by ftherese, Sep 10, 2011.

  1. ftherese

    ftherese Lurker
    Thread Starter

    Tried to unlock my phone with xda guide, boot-loop. Took it to be repaired by some guy in a cellphone shop, he was only able to flash it to gingerbread, the USB was non-functional (sound, gps, camera, as well) so he was unable to unlock it.

    Did my own flashing - cannot return to froyo (always gives a boot-loop). I am able to get USB and debugging now with latest version of gingerbread, but camera, audio, time/date (always resets to four and a half years ago when it auto-reboots), don't work and there is no samsung service center that will deal with foreign bought phones (purchased in France) here in Salvador, Brazil.

    If anyone has any ideas, they would be greatly appreciated!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. yagya

    yagya Android Enthusiast

    Try to flash the france version of rom inn your mini. Do you know the original data about the phone i.e.PDA version, baseband ?? It might help you in finding a good rom especially for your region.
     
  3. ftherese

    ftherese Lurker
    Thread Starter

    I've tried all the roms I could get my hands on. I am tempted to think now it is a problem with this elusive efs partition - stl5 - which I mounted once to grab unlock code once, and remounted etc. I think that mounting this block vfat must write something to the block device that makes it "look dirty" to the OS. Reading around, there are other posts that state that the stl5 block is contained within a bml block - that dd-ing the stl5 block back ontop of itself should clear it, etc. I've tried dd if=/dev/block/stl5 of=/sdcard/efs.rfs; then /sdcard/efs.rfs -> /dev/block/stl5, and nothing changed. I also tried flashing the efs.rfs back using ODIN and TASS.ops (for the GT-S5570) but i don't think the script makes mention of the right bin for flashing efs (I get an error every time about wrong binary something or other, and the TASS script file makes no mention of an efs image for flashing).

    Unless someone has another idea, I am trying to figure out what the efs image file should be named in order to flash it with odin and TASS script... maybe I should look at other ops scripts to see if there are any clues. I also tried grabbing the pit with heimdall, but either my libusb doesn't work under both linux and windows, or heimdall is incompatible with the galaxy mini.
     
  4. yokese

    yokese Lurker

    Did you find any solution? I have the same problems, I've tried the same things without success.....
     
  5. ftherese

    ftherese Lurker
    Thread Starter

    I went too far and tried scraping my /dev/block/stl5 partition. I gave it to a friend to see if he could take it to someone who could fix it. I suppose JTAG is the only thing left for it, but I don't know if he'll find anyone who can deal with it.

    My other idea was to add something about efs.rfs to the TASS file... otherwise I'm stumped.
     
  6. suicidallooney

    suicidallooney Well-Known Member

    Did you delete the cache and memory to refresh it?
     

Samsung Galaxy Mini Forum

The Samsung Galaxy Mini release date was February 2011. Features and Specs include a 3.14" inch screen, 3MP camera, 384GB RAM, Snapdragon S1 processor, and 1200mAh battery.

February 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...