1. Download our Official Android App: Forums for Android!

SGS2 and home router hate each other

Discussion in 'Android Lounge' started by starchest, Oct 12, 2011.

  1. starchest

    starchest Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    9
    0
    5
    I'm trying to find a solution without spending $$ on a new router.

    My SGS2 does not work with my home router, it asks for password, accept it, connects and shows a (good) signal. But nothing works until I turn the wi-fi off, then everything comes through.

    I once restarted the galaxy and it worked for a while, although it was slow as :D..

    The wierd thing is 3 laptops and an iPad work PERFECTLY without hiccups with that same router.

    I already reseted the router and configured it all over again. Still nothing. :(

    Thank you all in advance!
     

    Advertisement

  2. landovr

    landovr Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    723
    Joined:
    Feb 2, 2011

    Feb 2, 2011
    723
    75
    78
    Firefighter
    Alberta Canada
    What kind of security are you using on your router?
     
  3. starchest

    starchest Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    9
    0
    5
    WEP. Does that affect?
     
  4. T.M.M.L

    T.M.M.L Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    463
    Joined:
    Sep 20, 2010

    Sep 20, 2010
    463
    93
    53
    Ohio
    Greetings starchest,

    I know that this might sound crazy, but have you tried a higher form of encryption. I'm just grasping at straws, but maybe the SGS doesn't like that setting. Can't hurt to try.

    Sidenote: Wep is the lowest setting you can have and still say that you have a "secure" Wi-fi spot. For your own security, you might just want to step up a few notches.

    Good luck
     
    starchest likes this.
  5. jerofld

    jerofld Fixing stuff is not easy
    Rank:
    None
    Points:
    313
    Posts:
    7,687
    Joined:
    May 10, 2011

    May 10, 2011
    7,687
    4,270
    313
    Male
    I fix stuff
    Over there <points>
    If your home router hates your SGS2, then tell your SGS2 to buy your router some chocolates and take it out to a nice dinner. That should help.

    Oh, and that plastic case definitely does not make the router look fat.
     
  6. starchest

    starchest Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    9
    0
    5
    I'll try that but I don't know how much will it help, when I reseted it and tried it without a password (open connection with default settings) it still didn't work, but in the university it does work with an open signal, all my devices worked with the reseted open network.
     
  7. starchest

    starchest Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    9
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    9
    0
    5
    Lol. T___T
     
  8. Guamguy

    Guamguy Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    875
    Joined:
    Apr 12, 2010

    Apr 12, 2010
    875
    209
    93
    Have you tried doing a software update on your router?
     
  9. mrkennie

    mrkennie Lurker
    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Oct 12, 2011

    Oct 12, 2011
    9
    2
    6
    As suggested above, see if there's a firmware update for your router.

    If it doesn't have anything better than WEP such as WPA/WPA2 then bin it and buy a new router.
     
  10. T.M.M.L

    T.M.M.L Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    463
    Joined:
    Sep 20, 2010

    Sep 20, 2010
    463
    93
    53
    Ohio
    Sorry, didn't even think about a firmware upgrade.

    Like mrkennie said, If your router only has wep security, a new router should be in your future.
     

Share This Page

Loading...