1. Are you ready for the Galaxy S20? Here is everything we know so far!

Slow to receive new Gmails?

Discussion in 'Android Devices' started by karman, Feb 25, 2011.

  1. karman

    karman Newbie
    Thread Starter

    I have noticed that when I receive a new Gmail message on my computer; it doesn't show up on my HTC Inspire for some time. I can go to menu/refresh manually to get the new mails. What is the timing of the phone checking for new Gmails? Thanks
     

    Advertisement

  2. ZXMustang

    ZXMustang Android Enthusiast

    Same here. Not sure why, but I am interested to know.
     
  3. blazeplacid

    blazeplacid Well-Known Member

    have you tried to adjust your push/fetch settings?
     
  4. Chew

    Chew Android Enthusiast

    In addition to what blazeplacid said, I hope you don't have a task killer installed? Those are usually to blame when stuff doesn't happen when you expect them to.
     
  5. snilloconator

    snilloconator Well-Known Member

    My gmails come through instantly.
     
  6. gtalum

    gtalum Well-Known Member

    Which app are you using? I could never get gmail to work properly with the stock mail app or the k9 mail app, so I broke down and placed the gmail app back on my home screen and it works great. Messages show up there at the same time as my gmail notifications show up in Chrome browser on my PC, more or less instantly.
     
  7. ramyhin

    ramyhin Lurker

    From HTC home screen -> go to settings -> accounts & sync -> gmail -> auto sync google
     
  8. karman

    karman Newbie
    Thread Starter

    Thanks, when I go to accounts&Sync, I see auto-sync which is checked. Then under manage accounts, I see Google which has my gmail account under it. There is no "gmail" by itself listed. Am I missing something here?
    I am using the Gmail app on home screen.
     
  9. gtalum

    gtalum Well-Known Member

    That's how mine is. there's no separate gmail setting except for under Google.
     
  10. ramyhin

    ramyhin Lurker

    Sorry - I meant make sure "Google" is set to sync automatically. When I turned this on, I began receiving my gmails instantaneously through the gmail app. Make sure to turn on "Auto-Sync" as well.
     
  11. ramyhin

    ramyhin Lurker

    I just looked at my phone. Ok do this...

    From HTC Home screen -> settings -> accounts and sych -> Click Google -> check mark "sync gmail". This will sync your Gmail Application that came with the Insight. At least it did for me!
     
  12. karman

    karman Newbie
    Thread Starter

    That is what I have. Then on next page I see the sync books, sync contacts, and sync Gmail. All these are checked. What was the push/fetch mentioned in previous post? Will have to test here a bit. Thanks Ken
    Did test mail and it came in shortly. Phone Gmail app shows 1 new inbox. But only way I can view it is to click on all mail box. Is that normal? Little inbox (1) at top of screen shows up. When I click on it the screen shows "no conversations" Large inbox on main screen says "sync 4 days" under it.
     
  13. ramyhin

    ramyhin Lurker

    Is Auto-sync check marked under settings->accounts & sync?

    If so, try restarting your phone (hold down power button). Then open gmail and send yourself a gmail.

    Don't use applications like task killer, I think gmail needs to run in the background for this to work.
     
  14. ramyhin

    ramyhin Lurker

    if that doesn't work, the last thing I would try is from your gmail application's inbox, click Menu -> Accounts -> Menu -> Account Settings -> Check mark background data and auto sync -> then click "Google" -> and make sure Sync Gmail is check marked.

    I'm assuming this is for an Inspire.
     
    JiveMiguel likes this.
  15. karman

    karman Newbie
    Thread Starter

    yes to your last post, Inspire and all items are checked. Think it is just nature of beast.
     
  16. JiveMiguel

    JiveMiguel Lurker

    I was having this problem and this fixed it for me. Thank yoU!
     
  17. slappzilla

    slappzilla Newbie

    I did what ramyhin said as well, and it still takes over 10min for my phone to receive an email....

    Usually I don't care if I get my emails right away or not, but fantasy baseball season is coming up, and I like to get instant notifications if someone in my big money league dropped a guy so I can have the earliest opportunity to pick said player up.

    I am going to try the gmail app and go form there....

    Edit: ok, the gmail app is the same one that comes with the phone, so that's obviously not going to work either...
     
  18. TXGrunt

    TXGrunt Newbie

    I have done all mentioned above and I am still not getting gmail notifications without having to refresh it.
     
  19. slappzilla

    slappzilla Newbie

    ^ same here
     
Loading...

Share This Page

Loading...