1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Sprint] Encrypted Phone, can't reset

Discussion in 'Android Devices' started by ManlyParasite, Dec 18, 2012.

  1. ManlyParasite

    ManlyParasite Android Enthusiast
    Thread Starter

    I encrypted my phone some time ago, because I have many friends at work who like screwing with other people's phones, but now I'm trying to switch roms. I downloaded the files, wiped dalvik and cache, but when I tried to wipe data, I got a message saying /data could not be mounted. I figured I'd just ignore it, leave the data on and worry about it later. Went to flash the zip, but my sd card came up empty. I went back to the mounts section and tried to mount the sd card, got an error with that too.

    I had TWRP, now just flashed the latest CWM from Rom Manager hoping that it was something with TWRP, but getting the same problem. How can I fix this? As far as I can tell, the only way to remove encryption is to do a factory reset, but it seems that because of the encryption, recovery cannot access the /data or /sd card directories.

    My Nexus is still usable for now, can anybody figure out how to fix this?

    EDIT: I haven't tried doing a factory reset from the phone settings, as I've learned that with a custom rom/recovery, it's usually not a good idea to attempt a reset that way.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Apache Thunder

    Apache Thunder Android Enthusiast

    Did you try using Odin to flash a stock rom back to the phone? That should completely wipe it and remove the encryption. But that would also mean losing what ever you had stored in SD storage, so be sure to back that up first.

    Another thing to try, does your phone give you the option to "un-encrypt" it? It's not something I have played with on my phone, so I can't say for sure.
     
  3. ManlyParasite

    ManlyParasite Android Enthusiast
    Thread Starter

    I haven't tried Odin, I'm not very familiar with it, and haven't used it outside of the root process.
    And there is no way to un-encrypt the phone, the only way is to do a factory reset. At least, as far as I know, this is what the phone stated when I did the encryption.

    EDIT: I'll try Odin, I can easily get my sd files back, thank you for the help.
     
  4. An UrgeTo Dance

    An UrgeTo Dance The Hero of the Winds

    Mine will sometimes say that it can't wipe /data. Although if I do the Factory reset option in the recovery than it always works. You may want to try this before doing Odin.
     
  5. ManlyParasite

    ManlyParasite Android Enthusiast
    Thread Starter

    It's in recovery that I'm having this problem.

    EDIT: I think I bricked my phone. Don't know if it's fixable. The Odin program failed while it was flashing, and now my phone only shows up with a picture, a phone, an explanation, and a computer. Pictures below. As if it wants me to connect it to my computer. I did, but nothing happens. It tried to install some drivers but they weren't found.
    I tried booting into bootloader and Odin. Both of them resulted in the picture below.

    I think this is fastboot (haven't seen it on the Nexus before, so not sure)
    If so, I'm supposed to push something through using ADB right? If so, where can I get the necessary files for this? If not, what can I do?

    I was following this walkthrough.

    http://forum.xda-developers.com/showthread.php?t=1827685

    IMG063.jpg IMG064.jpg
     
  6. Apache Thunder

    Apache Thunder Android Enthusiast

    I do hope the PIT file you used matches the model number of the phone you have. If not, you might have screwed up the partition mounts which in turn can seriously f*** up the phone and could result in a hard brick. At which point you would need a JTAG to fix or send the phone to a specialist to have it fixed.


    EDIT:

    http://forum.xda-developers.com/showpost.php?p=30128140&postcount=24

    Yep, you should not have used the PIT file.....You're probably screwed as I believe that PIT file you used is for a version of the phone that is a GSM version or the Verizon version and there's a good chance the mount points for that particular model that PIT file was made for are different then the Sprint phone.

    From the info I've read, PIT files are generally not needed unless you're specifically trying to alter the partition table and mount points for them and such. Something which requires a PIT that matches the exact model phone you are using. Judging from the file name of the PIT file in your screenshot, you used the incorrect model. The Sprint phone is the SPHL700. What ever that PIT file is for is for a different version of the phone.

    I don't think encrypting the phone would change the partition mount points and info in a way that would require having a PIT file when using Odin, so I don't know why you chose to use one....

    EDIT:

    It appears the PIT file you used is for the I9250 which is the unlocked version of this phone. The searches I brought up indicate that model phone has a 16GB internal SD storage. The Sprint phone has 32GB storage. Logically this means all the mount positions of the partitions will be different because of this. So definitely sure you hard-bricked it at this point. I think a J-tag device will work with this phone. But that's an additional piece of hardware you need to buy. I haven't read up on it and never used one, so I can't say for sure if it will work or not with this model phone.
     
  7. ManlyParasite

    ManlyParasite Android Enthusiast
    Thread Starter

    Crap, is there anybody here that is capable of fixing this phone? I'm on a real short budget right now and can't afford to buy a J-tag (actually never even heard of it till now)
    And the reason I used that is I had used google and put in "galaxy nexus odin" and that was the first result, and as far as I can tell, it doesn't specify that it's for a specific version of the Nexus. I'm not really familiar with ODIN, it's files, or anything outside of MetroPCS's low-mid grade, easy to root phones. I was trying to be careful with this, since everything seems much more complicated and easier to mess up, but it looks like I lost this 1
     
  8. Sascha Paris

    Sascha Paris Lurker

    Had same issue here with GNexus / Magiro. Running rooted CM11 with TWRP recovery. Couldn't factory reset my encrypted phone anymore. Did a simple workaround:

    Used the Rom Manager in CM to reinstall CWM recovery
    Did factory reset afterwards et voila...took me 5mins from entering ROM Manager until factory resettet phone was booted again

    Reinstalling TWRP after successful factory reset (I use it to update my nightlies on encrypted phone) is a piece of cake...
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...