1. Check out our companion app, Forums for Android! Download from Google Play

Root [Sprint] [ROM][5/17]viperROM One v1.1.0 | 1.29.651.10http://forum.xda-developers.com/showthread.php?t=2241016

Discussion in 'Android Devices' started by gonowhere, May 20, 2013.

  1. gonowhere

    gonowhere Well-Known Member
    Thread Starter

    Jan 8, 2012
    Norfolk, VA
    Not mine but, just wanted to share what looks to be my first rom to flash.


    [ROM][5/17]viperROM One v1.1.0 | 1.29.651.10 | Fast, Stable, viperControl, and more!


    Based on 1.29.651.10 system dump (deodexed)
    Modified kernel (insecure, adb debugging enabled, init.d support)
    viperControl (read below)
    Implemented cron to keep system running at optimal performance
    GooManager OTA support
    5x6 app drawer
    Horizontal Quick Settings
    1% Battery
    Homescreen is default instead of feed
    Modified from 2 homescreens to 4
    Semi-transparent Notification Pulldown
    Modified social network sync from 24 hours to 4 hours
    Disable forced camera sound
    Disable app signature checking
    Added missing apps from HTCdev unlock (Calculator, SoundHound, PDF Viewer, TuneIn, and Flashlight)
    Added adblock hosts file
    Added sysro, sysrw, sqlite3, mountcheck, other useful tools
    Added Terminal Emulator, aLogcat (with full perms to read all app logs), NextApp Root File Explorer, Latest Play Store and GMS, Titanium Backup,
    Reduced long-press times and animation times
    Removed GPS Icon
    Removed open wifi notification
    Removed boot sound
    Removed bloat (useless files, Sprint ID, HTC OTA, logging apps, transfer app, mobile guide app, useless videos, demoflo, PCTOOL.iso)
    Removed extra keyboard languages (available as a flashable, see Downloads section)

    - Updated to 1.29.651.10 base
    - Added Roam Only option
    - Added semi-transparent notification background to match statusbar pulldown background transparency
    - Added copy/paste to Google Talk
    - Added latest WiFi Tether
    - Added latest Google Wallet
    - Added viperMOD Voltage Reset flashable to /sdcard/viperROM
    - Fixed bottom 3 APM icons
    - Moved Sprint Worldwide to /sdcard/viperROM/removed_apps
    - Remove HtcResetNotify.apk
    - Remove WiFi Hotspot and Data Roaming toggles from statusbar toggles
    - Updated viperControl -> Added capacitive button brightness code, fix app restoring not working, and some general code improvements
    - Fixed cron not running
    - Fixed streaming music/video skipping (revert to stock hosts file)
    - Added systcl.conf file for improved performance and battery life
    - Added new EQS style with long press in SystemUI
    - Updated viperControl
    * Improved hosts file code
    * Fixed an error when making a directory on startup
    - Updated viperMOD (Voltage Control)
    * Allow raising and lowering all voltages at once by a custom amount
    * Show voltages before and after lowering or raising all voltages at once
    * Improve code when setting custom voltages
    - Enable Stay Awake in Settings > Display, Gestures, and Buttons
    - Adjust autobrightness for lower brightness and more steps
    - Add MMS over wifi and disable MMS compression
    - Fixed incorrect APM icons
    - Updated SprintZone
    - Enabled more EPST commands
    - Increase screen sensitivity
    - FULL ROM ONLY: 500kb, 2MB, and 5MB MMS sizes (only on a full /data wipe)
    - Fixed paid app install issue
    - Added APM
    - Added back button as menu (in Settings > Display, Gestures, and Buttons > Back button)
    v1.0.0 - Initial Release

    Do the HTCdev Unlock
    Move viperROM to your phone
    Flash a custom recovery - I recommend TWRP (see 2nd post of TWRP thread for instructions)
    Once you get into TWRP, you can stop reading those directions and flash viperROM. DO A NANDROID BEFORE FLASHING viperROM! - Here is a really neat video by wwjoshdew that will walk you through the install if you're worried about flashing viperROM! Thanks wwjoshdew!
    In TWRP, select Wipe > Advanced Wipe and check Dalvik cache, Cache, Data, and System and swipe to wipe.
    Go back to Install and choose the viperROM .zip, reboot when finished

    DEVS - Please don't use this base for your ROM, please use the stock base found here.
    Full ROM
    - v1.1.0 - Download - Mirror
    - v1.0.4 - Download - Mirror
    - v1.0.3 - Download - Mirror
    - v1.0.2 - Download - Mirror
    - v1.0.1 - Download - Mirror
    - v1.0.0 - Download - Mirror
    - Available via GooManager as well!
    - v1.0.4 - Download - Mirror
    - v1.0.3 - Download - Mirror
    - v1.0.2 - Download - Mirror
    - v1.0.1 - Download - Mirror
    - Available via GooManager as well!
    - Flashable HtcSpeak.apk - Updated 5.16.13
    - Flashable IME Language Packs - Updated 5.16.13
    - Flashable Default Homescreen Feed - Mirror
    - Flashable Default Homescreen Non-Feed - Mirror
    - Flashable Enable Boot Sound - Mirror
    - Flashable Simple Statusbar Toggle - Mirror
    - Flashable Kernel Only Zip 1.29.651.7 - Mirror
    - Flashable Kernel Only Zip 1.29.651.10 (LATEST) - Mirror
    - Flashable viperMOD Voltage Reset - Mirror (already included with ROM flash in /sdcard/viperROM)
    - Flashable 1.0.4 viperControl Fix - Mirror

    Twitter doesn't show up in the apps list until you update it
    Please report any to the Google Code page

    HTC for sending me an HTC One!
    Chainfire for SuperSU
    Dees_Troy for making TWRP recovery for Sprint One
    flar2 for the original wp_mod.ko
    kylepont for his boot and down animations
    LiquidSolstice for the killer thread graphics
    Torxx for EQS
    he_stheone for 5x6 prism.apk
    18th.abn for pointing me toward a paid app fix
    NIN for APM that was ported from the EVO 4G LTE Sense 5 port
    O.M.J for his mod pack
    Please let me know if I forgot someone!

    [ Website ] [ Twitter ]

    Sprint HTC One: [ROM] viperROM One v1.0.3
    EVO 4G LTE: [ROM] Viper4G 3.1.3 | [MOD] Dual Core Mod


    Granite1 and scotty85 like this.
  2. Recoil1

    Recoil1 Well-Known Member

    Jun 21, 2010
    Just an update I noticed when I started flying around the country. I have rooted, gained s-off and put Viper on the One. I started noticing that I was showing 4g but no connectivity. I finally figured out that the phone was set to basically roam on any network including Verizon 4g. I was in areas that sprint usually didn't get a 4G signal but I was pleasantly surprised that I was getting one until I couldn't pull any data from it. I since have gone back to "home" only and I lost verizon 4G signal, picked up sprints 3G signal and was back in the data game. This is just a warning as Verizon has launched a ton of 4G towers that the One can pick up if you have the phone set to LTE/CDMA and automatic on the roaming setting.
    Granite1 likes this.
  3. AndroidSerpent

    AndroidSerpent Well-Known Member

    Jun 6, 2011
    You should have roam guard on. It will advise you when you're roaming and will let you disable it.
  4. Recoil1

    Recoil1 Well-Known Member

    Jun 21, 2010
    Ran into another problem today. I couldn't get YouTube to play anything on the phone while it was on 3g/4g. Worked fine with WiFi but not on the sprint network. I tried removing the app and putting it back on, I wiped the cache and data. Nothing seemed to work. Until I wiped the cache and data and did a full restart then all of a sudden I could watch the video again on YouTube.
  5. that one dude

    that one dude Well-Known Member

    Sep 12, 2011
    mobile electronics tech
    detroit, mi
    It's says that with a full wipe u can ser your mms to 5mb I did 2 times wiping everything and still only lets me go to 2 anybody tell me why? Thanks
  6. scudder

    scudder Well-Known Member

    May 21, 2010
    Ex-attorney ("retired" at 27)...
    State of Confusion (FL too)
    Hi Everyone...

    Not sure how "alive" this thread is but I'll post an issue here...

    I got an HTC ONE a couple days ago and rooted the phone. I tried to flash ViperROM but experienced a situation that others have found where the swiping on the screen does NOT WORK. ROM flash appears fine, phone boots but you can do NOTHING with the phone. Only thing I was able to do luckily was boot into recovery and flash my nandroid backup back to rooted stock.

    There are reports of this inability to swipe that I found in comments to a youtube video showing how to install the ViperROM on a Mac. There was a suggestion that the issue had something to do with 4.3 and the TWRP recovery as well. Some posted and received a reply a couple weeks ago:

    Why can't i swipe to unlock after i install this very cool looking ViperRom? Please advise.

    Did you update the recovery? that recovery hes using on the video doesnt work on a 4.3 now

    Not exactly sure what that means?? Anyone have an idea??



Share This Page