1. Are you ready for the Galaxy S20? Here is everything we know so far!

Strange browser crashing

Discussion in 'Android Devices' started by gibbs1984, Oct 20, 2010.

  1. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    I have Flashed the LeeDrOiD v2.2b ROM and when accessing the Stock browser it will randomly crash, it's a strange crash because normally a crash will mean that you will exit from the browser and next time it will load to the homepage, on mine though it will sort of crash but then load the page I was on, even if it wasn't my homepage, if I had any tabs open I would also lose all of those, which is how I know it's crashing.

    This isn't specific to this version of the ROM though as I've had this since v1.4, when I asked in the XDA forums they said it might be to do with re-installing my backed up data, basically I went from Android 2.1 to 2.2 when I Flashed the ROM and they said that backing up data when crossing over Android versions could cause problems.

    What I have done this time though is not backup anything, no SMS, no system settings, nothing! I deleted everything off my SD Card, cleared the cache, then cleared the Dalvik cache, did a factory reset, Flashed the ROM and then Flashed the radio but still this problem exists, I haven't backed up anything this time, although when I logged into the Market with my Google account it synced my contacts back onto my phone, as they're linked to my Google account somehow.

    This is really starting to annoy me now but I can't figure out for the life of me why it happens, I've tried replicating it to narrow down the cause but I can make it happen one time doing it a certain way but then doing it that way again it'll be fine.

    Has anyone got any ideas of how I can overcome this problem or how to Flash the ROM so that my browser will work correctly, this browser problem is the only problem I have with the ROM, apart from that it is superb.

    Any help very much appreciated!

    EDIT: Also, the browser can crash whether I'm connected to a data plan/Wi-Fi or not!

    1. Download the Forums for Android™ app!


  2. Rastaman-FB

    Rastaman-FB Extreme Android User

    is it a particular site thats doing it?
    have you tried a completely different rom to rule it out (do nandroid to return)
  3. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    There's no particular website that does it, I've got the Flash "On Demand" so that's not crashing it.

    Haven't tried another ROM yet but I will try that tomorrow when I get time.

    Any ideas on what might be causing it?
  4. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    Well, it's no ROM specific because I've just been running this ROM and within an hour and a half it's happened again.

    I have started to install apps, synced my Exchange e-mail and Calendar, logged into Facebook and Googlemail etc.

    What is causing this problem?
  5. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    Right, I'm really mythed as to what the problem is now as I've tried 3 different ROM's (2 Sense and 1 Stock) and it happened in all of them.

    I just Flashed LeeDrOiD v2.2d and didn't re-install anything from a backup, even created a new Google Mail account so that it didn't re-install all my contacts and still it happened.

    I've Flashed from the Recovery mode and I've also Flashed from the ROM Manager so there must be an underlying problem with something on the phone.

    I've used the ROM Manager to partition the SD Card correctly and still it happens.

    I have one thing left to do and that is Flash LeeDrOiD v2.2d without the A2SD and see if that makes a difference.

    Any help seriously appreciated because I'm at my wits end now!
  6. Rastaman-FB

    Rastaman-FB Extreme Android User

    well if its doing it on all roms and its not site specific then im lost mate.
    this type of behaviour tends to be because of a problem rendering particular sites
  7. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    Thanks for the reply Rastman-FB.

    Am I Flashing correctly.

    I go into the Recovery mode, wipe the Dalvik cache, then wipe the cache, do a Factory Reset and then Flash the Radio and then the ROM.

    Isn't that supposed to completely wipe the phone and then anything Flashed from there is brand new, which is confusing if it is happening in different ROM's.
  8. Rastaman-FB

    Rastaman-FB Extreme Android User

    seem right to me mate
    how long does it take before it crashes
    i dont use my browser that much so i havent replicated it
    ill see if i can try to replicate it as im on a custom rom aswell
  9. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    It can be any time, from minutes to hours, which is more frustrating because I think that it's sorted and then it'll crash, normally just before I go to bed :D

    I haven't fixed the problem but I've Flashed the LeeDrOiD v2.2d with No A2SD and I haven't had a crash in nearly two days of use, seems to be working perfectly again.

    This leads me to think that it's something to do with the A2SD part, maybe something went wrong on my partitioned SD Card, although I used ROM Manager to partition it...

    Although it hasn't fixed the problem in the sense that I still can't use the A2SD version properly at least I have a working phone now, which is a relief.

    Thanks for your help though Rastaman-FB.
  10. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    It's still happening :( Albeit not as often as with the A2SD on.

    Can anyone have a guess at this?
  11. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    Right, this is ****ing me off!

    Completely new phone (HTC Desire S), turned on for the first time, and I still have the same problem as my original Desire, as per the original post in this thread, now as this is a completely new phone with a different SD card but same SIM card (taken from my original Desire that I still have), so my thinking is it's linked somehow to either my Google account or my SIM card, can't be the Google account surely as all that does is sync my contacts and I've tried it before when using a different Google account and I still have this problem.

    So, I'm left with it being my SIM card, now is it possible to break your SIM card when rooting your phone in such a way that it breaks your browser?
  12. SUroot

    SUroot Extreme Android User

    SIMs can go faulty sat in a dark cupboard doing nothing. Try it. get a new one. Then you rule it out or resolve your issue.
    gibbs1984 likes this.
  13. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    I've been trying for the last half an hour with an old O2 SIM card rather than my T-Mobile one and the only time it has done it is when changing skins but then it has to reload Sense so I can understand that, I'm yet to have it happen when doing anything else.

    I'll get a new SIM card me thinks :)
  14. SUroot

    SUroot Extreme Android User

    Cool. dunno with tmobile, but with O2, I went into the shop, asked for a new sim, they registered it. 2 hours of no connectivity, then my new sim was working.
  15. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    Cheers SUroot, hopefully I don't have to revisit this thread and hopefully T-Mobile are quick at doing something for a change ;)
  16. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    I had the misfortune to try this on a day when none of the Orange shops locally had any replacement SIMs (I tried 4), and none of them could say when they would get them.

    Then I got on the phone to customer services, who'd previously told me they couldn't do it but a shop could, and they agreed that OK in that case they could do it after all.
  17. gibbs1984

    gibbs1984 Android Expert
    Thread Starter

    Well, got the new SIM card and put it in and still the problem happens, last resort is to send the phone back, get a new SIM card and then create a new Google account!

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page