1. Check out our companion app, Forums for Android! Download from Google Play

Root Stuck in a boot loop? Fix it here

Discussion in 'Android Devices' started by rnlcomp, Nov 9, 2013.

  1. rnlcomp

    rnlcomp Well-Known Member
    Thread Starter

    Aug 2, 2011
    Ok don't know how much traffic this forum gets but figured I would throw this info out there incase anyone gets stuck in a boot loop after OTA.

    Having rooted my Ultra I let the OTA come thru and hit install before I realized that I forgot to unroot and got stuck in the loop, after several articles, downloads, hair removing frustration, none of the files posted online for the Ultra worked for either house of moto program or RSD.

    So I finally decided to try the obake_maxx_xml file located here Droid-Developers SBF and followed instructions located here http://www.andromods.com/unroot-loc...k-xt1080-stock-factory-firmware-rsd-lite.html to open the zip, find the xml file, open it in notepad and remove the line with "getvar" and save it. Neither of the other two files worked for me.

    Fired up RSD pointed it to the folder where the obake_maxx file is and plugged my phone in to usb.

    Just incase anyone forgot like I did, you need to get into settings of your phone while it's looping and make sure usb debug is OFF.

    After you do that you need to shut the phone off during it's loop and before it turns itself off so the phone doesn't turn back on.

    Now with it turned off press and hold the power and volume down buttons for 3 seconds and release both, that should put you into fastboot mode.

    RSD screen should now show fastboot in the phone section, now just click start and sit back, when it's done the phone will shut off and RSD will state to manually turn phone on. At that point your done and now your looking at the setup screen you first saw when you got the phone.

    Just to put minds to rest I am including two screen shots of my phone info so you can see that it does NOT think it's a maxx, I believe that part is burned into rom.


    These pics are after the OTA because that maxx xml file is apparently the original software the phone ships with.

    Once the phone started downloading all the saved apps and contacts etc from google backup I noticed I was getting an OTA and let it run.

    Life is good. :D


    doogald and cos54 like this.
  2. pcdude2143

    pcdude2143 New Member

    Jan 22, 2014
    My mother got into this unfortunate position when she tried to update her phone, and she really needed her pictures and stuff off the internal storage, so I wrote a script to pull files off the device incrementally. You'll need to put it in a loop like so:

    while [ 1 ] ; do sudo ~/script/adb-pull-failsafe.sh ; sleep 5 ; done


    Also you'll need to change the vars $ANDROIDMPATH and $LOCALMPATH at the top of the file if you want to modify where it looks on the device and backs up to on the computer. Make sure you also download busybox-android and ConnectBot-git-master-2013-11-01_20-34-19.apk, since it'll automatically load them on the device if it's necessary.

    I provide no guarantees with this script. You really should know what you're doing if you try to use it. I'm just putting it out there just in case it might be helpful to someone else.
  3. udaasali53

    udaasali53 Member

    Sep 7, 2014
    Also known as LG Optimus G E973, LG Optimus G E971, LG Optimus G E975
    how to fix any solution
    fastboot mode started
    -- reset --
    --portchange --

Share This Page