1. Are you ready for the Galaxy S20? Here is everything we know so far!

Superuser stopped working with new SD card

Discussion in 'Android Devices' started by katycat, Dec 30, 2012.

  1. katycat

    katycat Lurker
    Thread Starter

    A few weeks ago I rooted my Optimus V (2.2.2). Everything was working fine (Superuser, root uninstaller, and terminal emulator all able to access root). I don't have a custom rom or recovery; I basically just wanted root so I could delete bloatware.

    I got a new 32 G microSD for Christmas and wanted to try installing it tonight. I was following the instructions here: (on the android central forum) optimus-v-rooting-roms-hacks/73753-howto-using-larger-sd-cards-no-more-storage-woes dot html - the only different being that since I don't have a custom recovery, I used the partition tool suggests here rather than doing it directly on the droid: (on this forum) optimus-v-all-things-root/364833-link2sd-you-tutorial dot html. But once I rebooted the new card, with all the files on it and partitioned, Superuser no longer works - so I can't run Titanium Backup to restore my apps and settings. I haven't even got to the point of Link2SD yet.

    So I put the old (factory 2G) card back in - and now superuser isn't working with the old card either.

    Titanium Backup gets stuck on the Asking for root permission screen. Superuser itself will sometimes open successfully (with no info in it, since I've reinstalled and cleared cache so many times) and sometimes crash. Root Uninstaller just gives me a blank screen. Typing su in terminal emulator gives me this error: "Activity Superuser Request (in application Superuser) is not responding"

    I've spent the last four hours on google trying to find an answer to this. I've rebooted, uninstalled the root apps, reinstalled, tried reverting back to the previous version of SU, cleared all the caches, cleared the data on the apps, gone into the stock recovery and wiped the cache partition there.

    At this point I don't even care about getting Link2SD up and running. I just want to get my 32G card installed and all my apps to work, preferably without re-rooting or reverting to factory or anything else that would take a lot of time. (At least I do have a recent backup. I guess. So I'll try it if all else fails.)

    The only thing I can think of is that I realized I'd stupidly moved Titanium Backup to the original SD card after I installed it. So I did uninstall and reinstall the app to internal memory after I put in the new card the first time I tried to use it. Which led to a overful internal memory, so I uninstalled the 8tracks app. And then Silent Boot updated itself. And that's it.

    Oh, come to think of it, while I was creating the backups I was getting some texts from a friend and eventually got the "message memory full" error. A reboot fixed that. The other thing that happened while I was backing up was that superuser (internally, not through Play) requested to update its binary from whatever it used to be to 3.1.1. So I let it do that. Then rebooted, and then I ran another backup before I copied everything to my laptop and started the SD card upgrade/partition process.

    Essentially, I have the same problem as this person (I started a new thread because they have an Esteem and mine's an Optimus): (on this forum) esteem-all-things-root/590823-help-sd-card-nightmare dot html. Looks like it was never solved over there.

    I do have the entire contents of my original 2G card sitting on my desktop. I haven't tried the suggestion of copying them over one at a time, because my original SD card is having the issue, which implies that the problem is not the file structure.

    Any suggestions? I'm at a loss.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus

    Try the Superuser update fixer found in the PlayStore it has a version of Busybox that should get the update to work.Once update is fixed install full version of Busybox to /system/xbin location.
    Busybox is absolutely necessary if your rooted. A lot of custom ROMs have this included (usually in the /system/xbin)
    It's been my experience when using large SD cards that it's better to create the partition on the SD card using a custom recovery, then change the format back to FAT32 with MiniTool Partitioning Wizard (the custom recovery formats it to ext.3 ).
    Without a custom recovery you can have no backup of your system/OS/ROM. No backup, possible brick when something goes wrong.
    It would be to your advantage to install a custom recovery.
    You will make mistakes (we all do). Making a mistake (something you delete or install messing up things) could lead to totally system failure. With a custom recovery you just have to restore a backup that was made, or, install a fresh ROM.
    Note: If worse comes to worse, install the ZV9 update. This will give you a clean system to make a backup of from a custom recovery. You will have to use the Gordita root exploit to root after updating.
    Then partition the SD card using the custom recovery. Remember to change format back to FAT32 if your going to keep the stock ROM/OS/system.
    Read info in the All Things Root Guide sticky at the top of this All Things Root sub-forum.
    Note #2: Remember to merge the partitions on the SD card before using recovery to create partition. The free version of Mini Tool can't do this, but EaseUS can.
    Note #3: Once rooted after ZV9 update make sure you install Busybox (use a Busybox installer from the PlayStore) to the /system/xbin location. It will fail to install on the Optimus V if you choose the /system/ bin location.
     
  3. katycat

    katycat Lurker
    Thread Starter

    SU update fixer didn't fix it - it, also, can't get SU access.

    I'd consider a custom ROM but I think I'm stuck until I get root back. Hey, at least I can't mess it up any further without root! sigh

    Anyway, everything on my phone seems to be working except for the apps that need root, so I'll probably backburner this until I have more time to mess with it.

    In the meantime, if there are any other suggestions I would welcome them!

    Thanks for your help.
     
  4. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus

    You need to flash the ZV9 update. You got something major wrong with your stock ROM now.
    You have no custom recovery, and thus, no backup of your stock ROM.
    The ZV9 update will give you a clean, totally functional ROM, and stock recovery, as well as the ZV9 radios. Then if you Root use the EManU3LXX root.zip. This will install a very good custom recovery as well.
    In the recovery go to the "backup and restore" option. Select the backup option. Don't do anything to the phone until you make the backup.
    Afterward, when you mess up the ROM (we all do from time to time), just restore the backup after wiping and formatting everything neccasary.

    Note: Read thru the All things Root Guide sticky and one of my tutorials I have hidden in another members thread here: http://androidforums.com/optimus-v-...tory-reset-your-rooted-phone.html#post3263770
     

LG Optimus V Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...