1. Are you ready for the Galaxy S20? Here is everything we know so far!

Wifi-Calling Issues

Discussion in 'Android Lounge' started by MaximB, Apr 4, 2021.

  1. MaximB

    MaximB Lurker
    Thread Starter

    Hi,
    I have Galaxy A51 phone with latest Samsung updates.
    I have enabled wifi-calling and VoLTE calls at my mobile provider and in the phone,
    It kinda works but with issues.

    When I'm in my yard or the living room, and I disable mobile-data(for testing) and enable wifi-calling - I can call with no issue.
    But when I'm in my bedroom which is like 1 wall away, it no longer works.
    The reason I need the wifi-calling is because I have a bad reception in my bedroom, but the wifi connection is strong there, and I even tested with speed-test and got good download/upload speed in my bedroom.

    I've looked at my router configurations and even disabled 5G as walls can cause issues with it, so I'm using 3G now.
    Also near the wifi icon I do not see the letters VoLTE (even trough it is enabled in the mobile networks and network mode is LTE/3F/2G auto connect).

    In theory I can but a device which makes the wifi signal stronger, but I don't see that this is a problem as the signal is already strong in my bedroom.

    Any ideas?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Is your router dual band? The further you are from the antenna the more likely you are to connect using 2.4 Ghz. When you are close it might switch to 5 Ghz, which tends to be faster, but less reliable data connections.
     
    Dannydet and ocnbrze like this.
  3. MaximB

    MaximB Lurker
    Thread Starter

    As I wrote, I turned off 5G in the router.
     
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what about rebooting the router?
     
  5. MaximB

    MaximB Lurker
    Thread Starter

    Did it many times.
     
  6. svim

    svim Extreme Android User

    You might find it a lot easier to troubleshoot your problem using less convoluted terminology to actually determine the problem. Keep in mind that there are very distinct differences involving WiFi connectivity and cellular connectivity.
    -- 5G is a term that applied to 5th Generation of cellular services. It does not have any reference to WiFi and the 'Generation' just being a fabricated identifier made up by the cellular carriers (i.e. 2G, 3G, 4G)
    -- 5 GHz is a term that is a reference to WiFi, with 5 being a numeric designation to the frequency length of a wireless, WiFi signal. So a 2.4 GHz band signal is just under half the size of a 5 GHz signal. A 'hertz' being a long-established, electronic unit measuring frequency signals, or one cycle per second, and 'giga' simply being a metric system unit of measure (i.e. giga = billion, mega = million, kilo = thousand)
    -- So 5G is more of a marketing term (for cellular) while 5 GHz refers to actual units of measure for WiFi signals. Both have '5' and 'G' in their names, and both are wireless signals, but that's just coincidental as they're both very different from each other and come from different sources (one is a wireless signal that has miles of coverage range and supplied by your carrier's cellular network, the other has a much more limited range typically measured in feet and is generated by a nearby router appliance or similar access point).
    -- WiFi Calling is also a marketing term and as its name implies refers to WiFi (sometimes referred to as VoIP, or Voice over IP). VoLTE is short for Voice over LTE, with LTE being a designation for Long Term Evolution. (ties in with 5G, 4G, etc.) so it's a cellular service, not to be confused with VoIP.

    So when you mentioned using '3G' from your router, that's a bit misleading. 3G is a cellular signal, and your router will support 2.4GHz and 5GHz WiFi but not 3G, not 4G, not LTE. When you're troubleshooting your connectivity issues, it's important to determine if your phone is indeed connecting to a cellular or to a WiFi signal, and then address the problem from that point of reference. So just to clarify, when you are doing something like a bandwidth speed test be sure to have only mobile data enabled and WiFi disabled, and then with WiFi enabled but mobile data disabled. Also keep in mind even when mobile data is disabled, as long as your SIM card is installed your phone still has its base cellular connection, that's a part of your basic cellular service account with your carrier (you need to enable Airplane Mode to disable all networking access).
     
    ocnbrze likes this.
  7. MaximB

    MaximB Lurker
    Thread Starter

    Svim, thank you.
    The problem is when I use Airplane made and then re-enable wifi and connect to my wifi router,
    Then make sure I have wifi-calling enabled and try to make a call, I get message: "turn off airplane mode to make this call".
     
Loading...

Share This Page

Loading...