1. Download our Official Android App: Forums for Android!

WiFi keeps getting stuck at "turning off..."

Discussion in 'Android Devices' started by VeryApe, Nov 25, 2009.

  1. VeryApe

    VeryApe Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    118
    Joined:
    Nov 24, 2009

    Nov 24, 2009
    118
    3
    36
    Systems Administrator
    Lancaster, PA
    Anyone else having an issue where the phone will disconnect from an access point then not be able to reconnect?
    This happens on my home AP(as well as at work,) and I know it isn't the AP because my laptops stay connected.
    If I then disable the WiFi on the Droid, it shows as "turning off..." until I reboot the phone.

    Suggestions? Other than this the phone has been tip-top. Should I wait until 12/11 before I try and exchange it?
     

    Advertisement

  2. kg6epf

    kg6epf Well-Known Member
    Rank:
    None
    Points:
    53
    Posts:
    199
    Joined:
    Nov 7, 2009

    Nov 7, 2009
    199
    99
    53
    So Cal
    Happened to me for the first time today. Had to power off and back on again to get it going again. Just for reference, I have had no other issues and love my Droid. I'm sure it'll be fixed eventually with an update.
     
  3. VeryApe

    VeryApe Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    118
    Joined:
    Nov 24, 2009

    Nov 24, 2009
    118
    3
    36
    Systems Administrator
    Lancaster, PA
    Wanted to bump this back up and see if anyone is experiencing a similar problem.
    After the 2.0.1 update I'm still having this issue. Wifi is good, then drops. If I try to power the wifi off/on, it gets stuck at "turning off..." then won't come back until after a reboot. Should I just get it exchanged?
     
  4. kyle.maddens

    kyle.maddens Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Dec 14, 2009

    Dec 14, 2009
    2
    0
    5
    Student (and tech intern)
    I'm having this exact same problem. I'd love to hear if anybody knows why it's happening.
     
  5. mitcha

    mitcha Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 14, 2009

    Dec 14, 2009
    1
    0
    5
    I got this problem with the Power Widget !
    I can turn off the wireless, but when I try to turn it on, the icon lights on but no signal.
    I gotta go inside settings/wifi settings and REALLY turn it on.
     
  6. VeryApe

    VeryApe Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    118
    Joined:
    Nov 24, 2009

    Nov 24, 2009
    118
    3
    36
    Systems Administrator
    Lancaster, PA
    Kyle, what router and encryption are you using? I have a Netgear(forget what model) and I've tried every encryption and tons of settings on the router, always with the same results. I spoke to VZW support on the phone, told them what I did to troubleshoot, and they agreed to swap it as defective, i was within 30 days.

    Low and behold, same issue with new phone, made week 45(original was 42 or 41 i think.)

    So, I figure it's some incompatibility with the netgear router and droid. Oh well, works everywhere else.
     
  7. OZFive

    OZFive Well-Known Member
    Rank:
     #1,564
    Points:
    15
    Posts:
    75
    Joined:
    Nov 16, 2009

    Nov 16, 2009
    75
    0
    15
    I have been having the same issue. I thought about maybe it was an app/widget that might be getting it stuck. I removed 2

    Weather Widget Donate
    K-9

    So far so good. No issues. It has been about 8 hours and no stuck WiFi. Anyone else running those apps? Maybe we should do a list of apps that use internet connection and see what ones we all have in common and se if those might be causing the issue.

    If one of those two I listed turn out not to be the issue.
     
  8. nateo200

    nateo200 Android Enthusiast
    Rank:
    None
    Points:
    36
    Posts:
    385
    Joined:
    Nov 27, 2009

    Nov 27, 2009
    385
    3
    36
    cashier
    I've got this same issue. Really frusrtating because I have stuff to do and I don't wantt to reboot now. Oh well ill just suck it up with 3G...(I'm in a basement though and it keeps switching to 1xRTT).
     
  9. OZFive

    OZFive Well-Known Member
    Rank:
     #1,564
    Points:
    15
    Posts:
    75
    Joined:
    Nov 16, 2009

    Nov 16, 2009
    75
    0
    15
    UPDATE....

    I went 1 day without issue at all of disconnecting WiFi and being stuck turning it off. Leaving home and coming back it switched over just fine. Before it would be a matter of a half hour before it would go bad. I reinstalled Weather Widget Donate and it has yet to have issues. I will probably try reinstalling K-9 seeing if that is the issue later on.
     
  10. OZFive

    OZFive Well-Known Member
    Rank:
     #1,564
    Points:
    15
    Posts:
    75
    Joined:
    Nov 16, 2009

    Nov 16, 2009
    75
    0
    15
    Just an last update...

    I have had zero issues losing my Wifi and getting stuck reconnecting to it again. I think it might have been K9. Maybe it was giving the Droid heck because of it's Push service?
     
  11. R4p70r

    R4p70r Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 25, 2010

    Sep 25, 2010
    1
    0
    5
    been having this problem as well

    wifi says "shutting down...", but it never shuts down unless i reboot the phone and disable wifi.

    when running with "shutting down" the battery goes low FAST

    battery on a normal day from 6am to 9am:
    With wifi deactivating about 20-30% of battery used
    wifi totally off is about 2%

    i really hate this problem, seems like i can keep wifi off untill i recharge the phone, then it turn back on and cant be diabled unless i reboot

    oh, and btw...got a samsung galaxy phone, so not a motorola problem
     

Share This Page

Loading...