1. Download our Official Android App: Forums for Android!

Support wrong time zone (sort of)

Discussion in 'Android Devices' started by truelove79, Jan 12, 2012.

  1. truelove79

    truelove79 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    133
    Posts:
    728
    Joined:
    Feb 12, 2010

    Feb 12, 2010
    728
    295
    133
    Electrical Engineer
    Peoria, IL
    So my Nexus shows the wrong time zone, sort of. I'm using the automatic time zone set by the network. The actual time and offset from GMT is correct, but the label of the time zone is wrong. My time zone is Central time which is GMT - 6. My phone says it's using mountain time, but it still says GMT - 6 (Mountain time is actually GMT - 7). I've included a screenshot to show you what I mean. It's really strange. Even all my appointments says in parenthesis (Mountain Standard Time) but the times are still all correct (since it's using the Central time offset of -6 rather than the mountain time offset of -7), so I guess it's not a huge issue other than being really weird. Setting it manually obviously works, but that is a janky solution.

    Anyone see anything like this. My wife has a Nexus too and hers is correct. It says Central time GMT - 6. But mine says Mountain time GMT - 6.

    [​IMG]
     

    Advertisement

  2. truelove79

    truelove79 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    133
    Posts:
    728
    Joined:
    Feb 12, 2010

    Feb 12, 2010
    728
    295
    133
    Electrical Engineer
    Peoria, IL
    Not that anyone cares but I talked to tech support about this tonight. They're sending me a new phone. This will be my third Nexus in less than a month.
     
  3. Crashumbc

    Crashumbc Android Expert
    Rank:
    None
    Points:
    223
    Posts:
    1,810
    Joined:
    Apr 7, 2010

    Apr 7, 2010
    1,810
    550
    223
    IT god
    B'more
    Weird, and a factory reset didn't fix it?
     
  4. truelove79

    truelove79 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    133
    Posts:
    728
    Joined:
    Feb 12, 2010

    Feb 12, 2010
    728
    295
    133
    Electrical Engineer
    Peoria, IL
    Nothing fixed it. I tried reset, airplane mode, toggle 4G, new SIM Card, etc. etc.
     
  5. aseiter

    aseiter Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 14, 2010

    Nov 14, 2010
    4
    0
    5
    My nexus is also set to use the network time zone. I am on Eastern Standard Time, which is GMT -5:00.
    However the calendar general preferences home time zone reads "GMT-4:00 Eastern Standard Time".
    My calendar events display the correct time UNTIL selected for edit. If I edit an event displaying 6:00pm, the edit screen shows 10:00pm, with a small grayed out "6:00pm EST" below and "GMT+0:00 Greenwich Mean Time"

    A bit confusing and definitely something wrong here.
     
  6. colchiro

    colchiro Android Expert
    Rank:
    None
    Points:
    323
    Posts:
    8,886
    Joined:
    Jun 4, 2010

    Jun 4, 2010
    8,886
    1,784
    323
    Male
    Web developer/IT
    Why can't you do this:

    Uncheck both "auto" check boxes. (auto date/time, auto time zone)
    Set the date, time, time zone manually.
    Check the "auto check boxes.

    I've had to do that in the past with wifi-only devices.
     
  7. TheyCallMeBT

    TheyCallMeBT Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    580
    Joined:
    Feb 29, 2012

    Feb 29, 2012
    580
    61
    78
    Male
    EST is GMT - 5. But Eastern Daylight Time (right now) is GMT - 4. I just checked my settings and calendar settings, and both are correct. It says Eastern Daylight Time GMT - 4:00.
     
  8. aseiter

    aseiter Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Nov 14, 2010

    Nov 14, 2010
    4
    0
    5
    The time and zone for events entered on the phone appear correctly. However, events synced to the phone have the problem.
    The time and zone appear correctly when viewing the calendar. The problem occurs when an event is selected for edit. The edit screen displays the time as GMT-0:00.

    Checking/unchecking time zone settings, in the calendars preferences and in the phone settings, give the same result.
     
  9. kdhkeit

    kdhkeit Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 14, 2012

    Sep 14, 2012
    1
    0
    5
    I was having problems with the appointment time changing to Atlantic time zone when it showed on my S Calendar. I have Galaxy S3. Because of restrictions for work IT, I can't sync my work Outlook calendar with personal email or personal cell phone. So I've been inviting myself to work appointments, by including personal email in appointment invite. When downloaded appointment or synced phone with gmail calendar, the appointment would show in the calendar on Atlantic time. When I opened the appointment,sometimes it would still show the Atlantic time, and sometimes it would show local time. Read, and read and read lots of posts about this.

    My solution that has worked is to go into phone calendar app (S Calendar), select the calendars button or Settings>Calendars. Then I uncheck "My calendar". Now it works! The appointment time set up in Outlook or Google calendar match the time on my phone.

    Whew...
     
Tags:

Share This Page

Loading...