1. Are you ready for the Galaxy S20? Here is everything we know so far!

X10 cant send emails after upgrade to 2.3.3

Discussion in 'Android Devices' started by raven_ramon, Sep 15, 2011.

  1. raven_ramon

    raven_ramon Lurker
    Thread Starter

    Hello,

    I hope someone can help.

    A couple of days ago i upgraded the software on my X10 to 2.3.3 (i think before it was 2.2 if i recall). BIG MISTAKE.

    Besides the new software being terrible looking, my outgoing emails stopped working (stuck in the outbox with sometimes error: connection error).

    I can receive emails ok - just cant send. Not with the email app that cam with X10 and not with K9 that i tried.

    All other internet seems ok. twiiter works ok. i can send email from within yahoo mail app, but not if a yahoo email is on the X10 email app.
    I tried rooting the phone, but was not able to downgrade it back.

    HELPPPPPPPP PLEASEEEEEE.....
    anyone has idea what if anything i need to change in settings to be able to send emails?

    i am using various emails (gmail, work, private ones on doamin i have) - nothing seems to work to send it :(
    all incoming/outgoing settings i entered as they were before and they were ok as they let me finish setting up the email.
    Thank you.
     

    Advertisement

  2. arkangeluk

    arkangeluk Android Enthusiast

    first things first lol
    it was 2.1 that the x10i had not 2.2 (officially anyway, i had a custom 2.2 on my phone) i have wolfbreaks 2.3 v5 rom on my phone and i use gmail. i havnt had any problems with sending emails even when i was on the stock 2.3. if you dont like the look of the new homescreen then why not try another launcher (i use adw ex). the 2.3 was not backward downgradable to 2.1 but if you are rooted then why dont you use flashtool and flash a 2.1 rom

    ric
     
  3. raven_ramon

    raven_ramon Lurker
    Thread Starter

    Hi,
    i could live with the new screen if only the email would work.... :mad:
    i am not sure what you are saying (new to rooting).
    i tried following steps listed on xda-developers to root my x10 with a flash tool etc but it did not work - still have 2.3.3 on my x10.
    So any other thoughts what if any settings needs to be changed to make the out going email work?
    Thank you.
     
  4. beau420

    beau420 Android Expert

    Not sure why you think rooting will fix email.

    OK.

    I would work on 1 email address at a time.

    What most people don't know is 2.1 to 2.3 isn't just a simple update. What you should have done is backup everything on 2.1. Goto Settings->Privacy->Erase SDCard then install 2.3 fresh. Then go through restoring any data you want.

    What happens when you open the email app and try and send an email address from your gmail account to your gmail account?

    Does it work?

    Are you connecting to the internet over wifi or data? Try over wifi first.

    Does it give any error message at all?
     
  5. raven_ramon

    raven_ramon Lurker
    Thread Starter

    Hi.
    Gmail does not send out emails either.
    interent wifi working ok. twitter ok, can send via my yahoo email through the yahoo mail app.
    K9 email app also can not send out email.
    Again, everything looks to we working fine. i can down load apps from Market, just sending email does not work.... :mad:
     
  6. beau420

    beau420 Android Expert

    In the app email....how many accounts do you have listed?

    Remove your domain address and any other address in the Email app except for the Gmail.

    Get the gmail one working first, then we will tackle the rest.

    So, when I went through setting up the gmail account, did you specify all the proper settings?

    [SIZE=-1]It is using port 465 [/SIZE]and SSL for outgoing. It also uses your entire email address as the username when sending emails...not just the name before the @ symbol.

    When you type up an email...and send it to yourself.....does it just sit there and the circle in the top right just spinning?

    What happens if you hit the left button and chose folders and go to Outbox....are the messages just sitting there?

    What I think is happening, is it is trying to send emails under an account that has the wrong settings or doesn't have the ability to send out.

    One of my clients has there own domain, and we have to use their ISPs outgoing mail server to send their domain emails.

    What error message or where are the emails? Send one from your gmail address to your gmail address with no other email addresses in there.
     
    raven_ramon likes this.
  7. raven_ramon

    raven_ramon Lurker
    Thread Starter

    Thank you thank you. that seems to have worked.

    Here is the process i used:
    deleted all email accounts from the x10 android client
    cleared the cache from the Applications/running services
    created my gmail account - using the automatic process
    sent a test email out - port was set to 465 and ssl
    that seems to have worked.
    then started to add my other emails - this time also at 465 and ssl.
    that seems to have worked.

    My prior settings before the upgrade was 80 and no authentication required.

    So that helped a lot - send settings on 2.3.3 should be 465 and ssl.

    Thank you soooooooo much again.:) have a great day.
     
  8. beau420

    beau420 Android Expert

    Just saw this -

    Android - Gmail Help

    Guess you could go IMAP instead of POP3 too.

    I think google talked about changing security about 3-4 months ago. Guess it is just like that in 2.3. Not being secure would mean that passwords were sent in plain text....not secure at all.
     
  9. 916x10

    916x10 Android Enthusiast

    Being the flash demon that I am, I encountered a problem yesterday that I hadn't had before, I was unable to upload a pic to photobucket....I could upload to facebook though. I simply uninstalled the app, rebooted the phone and reinstalled the app and all was well. Next time, that would be my suggestion, seems like a much more productive use of time.
     
  10. arkangeluk

    arkangeluk Android Enthusiast

    glad you got your email problem sorted but you said in your first post that you tried rooting but couldn't downgrade to 2.1 I take it you weren't successful rooting then

    ric
     
  11. raven_ramon

    raven_ramon Lurker
    Thread Starter

    Hi. No was not able to root. however, once i got the sent email working, i dropped the idea of rooting. all is well with the world... for now anyhow..... :)
     
Loading...

Share This Page

Loading...