Anyone root the Samsung Exhibit II 4g T679


  1. rcmark

    rcmark Member

    I would like to root mine, to much bloat ware!
    Thanks for any help!

    Advertisement
    :
    akashvani likes this.
  2. clay21

    clay21 New Member

    ZergRush zip file attached.Install the phone drivers on your pc, in your phone turn usb debugging on, plug your phone into your pc and let the drivers install.Unzip the zergRush file to a new folder on your desktop,open the folder and click on the .bat file and let it run ;). To check if you rooted...you should see apps called superuser and terminal emulator in your app draw. You can also download root checker from the market to verify...enjoy.

    This WORKS for the Exhibit 4g ll and Exhibit 4g.

    Attached Files:

  3. rcmark

    rcmark Member

    It WORKED !!!!!
    Thanks!!

    Slayer72 and FumbleFingers like this.
  4. rraicu

    rraicu New Member

    Confirmed, works great.
  5. Rono1953

    Rono1953 New Member

    found your post about rooting Exhibit 4g ll, success! Thanks for the info
  6. menusmns831

    menusmns831 New Member

    Which bloatware can u saftely remove from exhibit 2 4g from tmobile.
  7. rcmark

    rcmark Member

    I don't have the time or inclination to make a list but LOTS of apps can be removed.
    What I did was to use Titanium Backup and 'freeze' the suspected bloatware before removing it that way you can 'unfreeze' it if you make a mistake.
    Hope that helps.
    totage and streetp like this.
  8. nitefire77

    nitefire77 Member

    I rooted mine earlier this evening. I go rid off all the tmobile apps and the crap like social hub, media hub, the ebook app LOL. Basically anything that had weird apparently name, or had tmobile on it LOL. I did make sure though that everything I uninstalled was in the apparently drawer. If it wasn't an apparently I don't delete it. Rebooted the phone after and its working great and is now twice as fast. Getting rid of the bloatware cleared about 100mb of ram
  9. tatabox

    tatabox New Member

    Hi. Sorry...New to android...
    Trying to root my Exhibit II

    I downloaded the Zerg rush root

    Above it mentioned to install the phone drivers on the PC, how do I do that?

    And how do I enable USB debugging?
  10. carmine92207

    carmine92207 Member

    please help when i plug up my phone it makes the noise like its connected but the pop up message does not appear that say driver installing please help
  11. daposaspo

    daposaspo Active Member

    Noob myself and i too would like to know.
  12. tatabox

    tatabox New Member

    I think I figured it out. This is what I did in simple terms:

    1) went to samsung, downloaded the drivers for my phone the exhibit II and ran the install file

    2) downloaded the zerg zip and unzipped it (there is an application to RUN after you unzip it)

    3) Turned on USB debugging on my phone (settings>applications>development)

    4) Hooked the phone up to the PC with USB

    5) PC searched and installed phone

    6) RUN the zerg application (takes a few minutes, "went to sleep mode" a couple of times but give it a few minutes and you should be good).

    Now I have it rooted, im trying to figure out how to delete the useless apps that were preloaded on. Anyone?
    Slayer72, idomoryosef7 and korfus like this.
  13. carmine92207

    carmine92207 Member


    when i open the bat plug my phone and run command prompt then runs and and other command prompt opens but this whole time nothing happens please help i have Samsung exhibit does the have to be in download mode?
    thanks
  14. carmine92207

    carmine92207 Member






    when u unzip the zerg rush file u said theirs a app to run which is it please help
  15. Quincyjb1

    Quincyjb1 New Member

    hi i got the super user and emulator app on my phone now how do i use them to get the apps i dont want off my phone?
  16. surgerush

    surgerush Well-Known Member

    I so want to root my phone because this phone comes with so much extra junk and it's killing my ram... I just don't trust myself enough to root and then I'm always worried about screwing something up after it's rooted.
  17. computerwhiz21

    computerwhiz21 New Member

    Hey guys I am new to rooting and was afraid to. I am so happy I did this!
    Guys I have a question though: On another forum it said to use the ZergRushRoot for the first exhibit and I did, and it worked.
    Is that bad? What is this new one about???


    ALSO, I removed the bogus bloatware too, using Titanium Backup. Here is what I removed safely:

    -WiFi Calling
    -Slacker
    -Books (Google Books)
    -T-Mobile Mall
    -411 & Assistance
    -Visual Voicemail
    -More for me
    -Telenav GPS
    -Backup (T-Mobile Backup, disable sync in settings first!)
    -T-Mobile TV

    **You may get a com.android._____ failed or something. Just restart the phone and you're good to go.
    Slayer72 likes this.
  18. AirForceTim

    AirForceTim New Member

    I downloaded the ZergRush rar to root my Samsung Exhibit II 4G. Installed the USB drivers, enabled USB debug, and ran the ZergRush.bat file, each line of the command prompt had the same error message ('adb' is not recognized as an internal or external command, operable program or batch file).

    The last command line pauses and then ask to press any key to continue. I assume I've done something wrong or this .bat file won't work on my Exhibit II 4G.

    Any help would be greatly appreciated.
  19. jimmysandroid

    jimmysandroid New Member

    Thank you so much for the utility to root my phone. As an FYI - Samsung does not yet have drivers listed under the Exhibit II (T679) but you can just download the drivers for the Exhibit (T659) and it will work with the Exhibit II as well (that is what I did when rooting the phone).
  20. nbeairsto

    nbeairsto Member

    I did everything right... Rooted the phone. Superuser icon popped up and did rootcheck... but when i went to go download titanium backup it say my phone wasn't rooted :/
  21. undork

    undork New Member

    clay21,thank you. i also was able to get root on my exhibit II using the exhibit I drivers from the samsung site. i also was told by titanium backup that i did not have root. pushing the 'problems?' button, i was offered a button to update superuser. i closed ti backup and downloaded and installed the update for superuser and installed it. opened ti backup and it reported that i had root on the phone. now i will use ti backup to freeze or delete the bloatware. thanks again.
  22. ApolloTwo

    ApolloTwo New Member

    Alright, I bought an Exhibit 2 last week, followed every step, downloaded the drivers from the first Exhibit, the latest version of zergRush, ran zergRush about ten times, & my Exhibit 2 is still not rooted. Can any person help me?
  23. docktor

    docktor New Member

    Worked great, downloaded the zergrush.zip before plugging in i simply checked 3rd party apps accepted+debugging ran the file from my desktop after plugging in the cable and it rooted my phone.

    be aware if you're unable to install the drivers do this, simply turn debugging mode on and plug in your phone to your computer and it will auto update your drivers. simply put.

    after i rooted i downloaded Ti *titanium backup* from the app store and installed, power cycled my phone and was able to get into Ti program and uninstall several if not all the factory default applications.

    i was able to watch brd quality movies but during some scenes it may stutter for a second, now does not.

    great advice and thanks for everyone to share a bit of info to make a full guide here on this site.

    thanks so much
  24. Blacsnake

    Blacsnake New Member

    I have done everthing that all post say, it says that it worked then when I check it says it is not Rooted the phone has restarted and still nothing. What am I doing wrong please explain in dummy terms.
  25. jimmysandroid

    jimmysandroid New Member

    Please Help! I rooted my phone (Samsung Exhibit II) using Zerg. Everything worked great, but a couple of days ago I got a notification that a newer version of Superuser was available, I went ahead and updated the application via the marketplace — but today I got a notification that the “su binary outdated” (tap to update su binary) — so I went ahead and taped to updated and get the following error:

    Downloadingmanifest…Okay!
    Parsing manifest…Okay!
    Latest version = 3.0.3
    checking installed version = 2.3.2 – efgh
    Fixing database..okay!
    Checking for busybox…okay!
    checking for current installed path…/system/bin/su
    downloading new binary…okay!
    Checking md5sum…fail!

    I don’t even know what md5sum is…….but is there anyway I can fix it so that su binary is updated propertly? any help would be very much appreciated!!! Thank you – Jimmy
Loading...

Share This Page