[AT&T] Status 7 error with Rogers SGH-I747M

Last Updated:

  1. skorpien

    skorpien Active Member

    Got fed up of waiting on Rogers to release the JB update for the GS3 and started reading up on how to flash CM10.

    So, I got everything backed up and CWM installed on my phone, downloaded the CM10 zip from CWM's own website (I went with the GS3 AT&T variant) and booted my phone into recovery mode. However, when I go to install the zip from my external SD card, I get a Status 7 error. Am I doing anything wrong? Should I be downloading a different file? Should I be loading it from my internal memory rather than external?

    Thanks in advance!

  2. skorpien

    skorpien Active Member

    Nevermind, got it to work. After fighting with CWM from the ROM Manager for a little while, I was finally able to get it to work.
  3. johndoe5268

    johndoe5268 Member

    You'll be much happier. I've got an SG3 on Roger as well, and it runs much faster on a custom ROM. And all those annoying services messages went away too.
  4. Pappy35

    Pappy35 Well-Known Member

    That's the message I've been getting. How did you get past it?
  5. skorpien

    skorpien Active Member

    I am with Rogers in Canada, and I believe that was my issue, so I'm not sure if my solution will work with your phone...

    I had to download build.prop editor and change all d2can entries to d2att (there are two). After a reboot, ROM Manager allows you to select Samsung Galaxy S3 (AT&T) from the list when you go to install CWM Recovery (previously, the S3ATT wasn't an option). After I installed CWM Recovery, I used build.prop editor to change the d2att entries back to d2can. Then another reboot of the phone to make sure the settings stick. After that, I was able to boot into CWM recovery and install CM10 (or any other ROM) without issues.

    Although I do have to say that I reverted back to the stock firmware and rooted again. I just updated to the Rogers JB update released today and I'm hoping somebody releases a root for it soon. As much as I liked CM10, the little quirks it had were bothersome to me. I'm hoping the stock JB will be better than the stock ICS on this phone, and if any of Rogers' apps are too annoying, I can always uninstall them once I am rooted again.
    spooky2530 likes this.
  6. Wisenos

    Wisenos Well-Known Member

    i'm rooted on stock Rogers JB rom
    the rom is already aviable on xda
  7. skorpien

    skorpien Active Member

    Yeah I ended up rooting my phone the same day I posted that. It was easier than I thought, but I forgot to mention that here afterwards.
  8. AndroidManiac7

    AndroidManiac7 New Member

    Hi there!
    I have a rooted Samsung galaxy s3 on rogers.
    I want to have cm10 on it.
    But its giving me status 7 error, I tried different roms(att, spr, vzw) but nothing worked.
    I am not worried about to backup my data (coz i dont have anything :p ).

    Can you guide me in correct direction on how to ger cm10 on s3 rogers SGH-I747

    Thanks in advance!

Share This Page