1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Can I unroot


Last Updated:

  1. blue2107

    blue2107 Well-Known Member This Topic's Starter

    Joined:
    May 31, 2011
    Messages:
    184
    Likes Received:
    97
    Is this at all possible? (yet)

    Still having issues with 3g speeds and just want to preform some troubleshooting.
     

    Advertisement
  2. interdpth

    interdpth Well-Known Member

    Joined:
    May 18, 2011
    Messages:
    181
    Likes Received:
    448
    remove su from /system/bin and you're good to go
     
    blue2107, wyelkins and new optimus like this.
  3. new optimus

    new optimus Well-Known Member

    Joined:
    Mar 10, 2011
    Messages:
    4,199
    Likes Received:
    1,454
    Good to know Thank you
     
  4. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    Joined:
    Mar 28, 2011
    Messages:
    5,385
    Likes Received:
    5,071
    mount -o remount,rw -t rfs /dev/stl12 /system
    rm -f /system/bin/su
    rm -f /system/xbin
    rm -f /system/app Superuser.apk


    type those into terminal emulator, it will remove all traces of root
     
    wyelkins and blue2107 like this.
  5. blue2107

    blue2107 Well-Known Member This Topic's Starter

    Joined:
    May 31, 2011
    Messages:
    184
    Likes Received:
    97
    Yes thank you shabbypenguin and Interdpth for your quick response really appreciate all your teams work
     
  6. chrisinsocalif

    chrisinsocalif Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    217
    Likes Received:
    45
    Were you able to alleviate your 3g problem BLUE?
     
  7. Dayquil

    Dayquil Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    48
    Likes Received:
    3
    Im not sure what kind of issues Blue was having, but when I got mine rooted. I noticed that dl'ing apps from the market was taking FOREVER. So I ran 4 different speedtest.net tests and my avg for the 4 tests was something like 118/150 with a max of ~180/220. I couldnt figure out what the issue was, so I unrooted mine (thank you shabby!!) and ran a few more speedtests with them being 550/350 and 351/185 for the first two.

    For whatever reason, having the phone rooted slowed the shit out of mine. Only things that I did was install a few root app, remove bloatware.

    Might try again tomorrow, maybe it was just an iffy rootjob.
     
  8. 52mike

    52mike Member

    Joined:
    Jun 7, 2011
    Messages:
    6
    Likes Received:
    4
    im still confused on how to un root (noob
     
  9. chrisinsocalif

    chrisinsocalif Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    217
    Likes Received:
    45
    Download a terminal emulator then try.

    When i tried the command
    mount -o remount,rw -t rfs /dev/stl12 /system
    doesn't seem to work (operation not permitted)
    and i cannot delete su because its read only.

    Any other suggestions on unrooting?
     
  10. blue2107

    blue2107 Well-Known Member This Topic's Starter

    Joined:
    May 31, 2011
    Messages:
    184
    Likes Received:
    97

    Removing root is giving me a bit of a problem. Not sure why but this is what it says when I type in the first command.



    Usage: mount [-r] [-w] [-o options] [-t type] device directory

    Any ideas why?
     
  11. murderousone

    murderousone Banned

    Joined:
    Jun 7, 2011
    Messages:
    160
    Likes Received:
    44
    Had Da Same Problem Un-rooting... With A Lil Playing Around I Got It Removed...
    Jus Type Mount in terminal emulator 1st. Then Type Remount rw . Which Changes The System Permissions To Read & Write. Then I Removed Each File & Folder Listed Above With Root Explorer... Or Yo Can Use The Rm Commands Above. Both Work... Root Gone... Rebooted Phone... Also Noticed That /dev/stl12 /system Wasn't Located Anywhere On My Phone Maybe A Typo.... I DUnnO! Hope This Helps Out...
     
  12. niceguy21

    niceguy21 New Member

    Joined:
    Jun 17, 2011
    Messages:
    1
    Likes Received:
    0
    Is there anyone who can post a video of how they can successfully unroot usinf=g this process please, im very confused, it keeps saying operation not permitted and permission denied.... this would help thanks!
     
  13. socal777

    socal777 Active Member

    Joined:
    Jun 6, 2011
    Messages:
    25
    Likes Received:
    1
    I'm having the same issue. Can anyoneshare some guidance? Thanks!!
     
  14. JDWired

    JDWired Active Member

    Joined:
    Jul 10, 2011
    Messages:
    31
    Likes Received:
    2
    A fix to ShabbyMods coding above (props to him)

    Type in your terminal emulator:

    1) su

    2) mount

    3) remount rw

    4) rm /system/bin/su

    5) rm /system/app/Superuser.apk

    This worked for me perfectly and I hope it does for you as well. TIP: I removed -f in the code and removed the rm /system/xbin as you will have root removed all the way after a reboot from doing step 1-5.
     
    primetime504 likes this.
  15. fcortes626

    fcortes626 Well-Known Member

    Joined:
    Jul 28, 2011
    Messages:
    442
    Likes Received:
    67
    you can use odin multi download. thats how i did it but that wont fix your 3g. i got mines to work but idk how. i was playing around with the dial menus. i noticed the settings for browser were blank and some other ones i dont remember.
     
  16. JDWired

    JDWired Active Member

    Joined:
    Jul 10, 2011
    Messages:
    31
    Likes Received:
    2
    You can use the Multi Odin as a fix but to do a solid removal of root, I would highly recommend anyone to do it manually.
     
  17. new optimus

    new optimus Well-Known Member

    Joined:
    Mar 10, 2011
    Messages:
    4,199
    Likes Received:
    1,454
    If you use odin and stock unrooted, that is exactly as the phone came from the store.:p
     
  18. mecam77

    mecam77 Member

    Joined:
    May 26, 2012
    Messages:
    12
    Likes Received:
    0

    step 3 did not work for me said remount not found and ideas
     
  19. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Joined:
    Oct 5, 2011
    Messages:
    5,551
    Likes Received:
    4,372
    You can just use Odin and flash it back to an unrooted state.

    Or

    Use a root file explorer, mount /system as rw, then:
    1 delete superuser.apk from /system/app

    2 install super user from market (so it's a user app, the root explorer may not work without it, but the system is already mounted rw)

    3. Delete su binary (in system/bin)

    4. Uninstall superuser

    5. reboot
     
  20. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    Joined:
    Oct 5, 2011
    Messages:
    5,551
    Likes Received:
    4,372
    vce2005 and tube517 like this.

Share This Page

Loading...