enable 3G on Samsung galaxy s DUOS S7562


  1. ivianang16

    ivianang16 New Member

    hi ~ i have an android phone samsung galaxy s duos ..
    i've been trying to enable its 3G but it won't .. my sister has a galaxy S3 and all she did is tap the mobile data and then her phones 3g icon will appear ..

    i really want to enable my 3G on my phone .. to see its icon appear
    it feels like my phone was incomple when i don't see it since the day i bought it .

    Advertisement
    Atma likes this.
  2. Atma

    Atma Well-Known Member

    Hi ivianang :hello: Welcome to the forums!

    From what I've found, to enable it you would got to System settings > Wireless & Mobile Networks > check Data allow/Data Traffic

    You might also take a look in our Galaxy S Duos forum.

    Thanks for joining us. :)

Share This Page