Exchange Activesync and certificate issues?


  1. davedamit

    davedamit Member

    Here goes,... I hope I'm posting in the right place.

    Does anyone know if one of the custom roms support self signed certificates when attempting to sync with an exchange server?

    I can sync with RoadSync, and with Touchdown, however thier interfaces kinda suck! (they don't populate the stock interface. ie: calendar, contacts, or mail) not only that, but they cost $!

    I have read everything I could find on the web, I have talked till I was blue in the face to sprint. (sorry maybe that's why I'm so grumpy this AM. they don't know much of anything other than how to apologize for not knowing much of anything!)

    I run a small business server (2003) with exchange 2003 integrated. By default, when installing, my exchange server is assigned a ".local" extention. Installation errors out all over the place if you try to use a ".com or net" etc. so even though I can add a public email domain to exchange ie: "mydomain.net", exchange still presents a certificate with the ".local" extension. Android dosen't give me an error log to confirm my suspicions; however when installing "roadsync" I get an un-trusted certificate warning AND the option to accept it. (similar with "Touchdown")

    I can't see buying a certificate from a third party when I do not host a public site. ($300.00 or so!)

    I hope someone here can help. Thanks again to the site owners, mods and of course the users who give it life.

    Dave:confused:

    Advertisement
    :
  2. mysticmead

    mysticmead Well-Known Member

    replied in your other thread.. but here t is again..

    no...

    what you're looking for is an app... not a custom rom.. now is there one out there that does what you're looking for? don't know.. as far as a SSL.. they can be created for a LOT less than $300...http://tinyurl.com/ydvk5s3
  3. Lappie2010

    Lappie2010 Member

    I dont understand what the issue is. I run the same system, SBS 2003 and Exchange 2003 with a self signed cert. When using the stock Exchange sync on the Hero, it states the cert is invalid, click ok, and it works.

    I dont use any third party apps.
  4. davedamit

    davedamit Member


    The issue is that I can't connect! maybe you could pm me with a few details about your server configuration? I don't get the option to click ok.

    Thanks anyways
  5. Kelmar

    Kelmar Done by choice VIP Member

    Try pressing "manual setup." It was t.he only way I could get my work email setup
  6. davedamit

    davedamit Member


    Thanks for the suggestion, however; I have been reading and trying every combination of tips and hints for about two weeks now. I actually re-installed my server software in it's entirety twice now. once as a front end box and finally back to stock (.local domain with my public domain added to exchange as is typical of a sbs config.) I have hard reset my phone as per one posts instructions, I have issued certificates till the cows come home, and I still can't connect unless I use "roadsync" or touchdown" I don't want to use a third party app! I shouldn't have to! the third party apps however; give me the option to accept a self signed cert.! they also give me an error log so that I can troubleshoot the connection errors. Using the same info that connects me with "touchdown" fails without explanation using andriods tool!!! aaaarrrrg! I have been lurking around on ppcgeeks for three or four years and posted maybe three times. I haven't posted here until today. didn't think I would need to. I just read and can usually resolve my own issues without adding to the overwhelming amount of dialogue in these forums. I'm not an IT guy, but have tought myself enough over the years to be dangerous at least, but I am stuck and could use some help. certificates are something I have virtually no experience with, however I keep reading that the ability to accept "self signed" certs. seems to be the issue. so... yeah, I need help. I don't have much hair left to pull out!

    Thanks for any suggestion or tip you may have
  7. Kelmar

    Kelmar Done by choice VIP Member

    I hear you. It took me 3 solid months to get mine working and just came across it by chance. Just kind of said "what if...." It wasn't a deal breaker for me, but just kind of a sore spot.

    Have you tried emailing HTC directly and getting a response or help from them? Just an idea. :)
  8. davedamit

    davedamit Member

    I actually just got off the phone with HTC! There really IS a tech. support hotline!

    Of course it was almost like talking with sprint though. rep: "Sir, the hero can't sync with exchange servers unless you use a third party app. it isn't supported yet". me: "well, actually it is supported on the hero it's in the mail widget" rep: "yes sir you are correct, however android dosen't like exchange servers" me: "right, umm, is there an error log somewhere in my device that I can use to troubleshoot my connection errors?" blah blah blah... etc. rep: "certificates, yes, android dosen't like certificates on exchange servers. maybe you could remove your certificates?" Again, aaaarrrrrg!:mad: but hey, i wonder if I could remove my root, ssl, and web certs? (without re-installing sbs all over again) it seems like the only thing I haven't tried. by the way, what finally worked for you?

    Thanks,
    Dave
  9. davedamit

    davedamit Member

    Question: is your log in name the same as your email alias? mine are not the same ie:log in:Joe Blow. email: j.blow@yourdomain.com

    again it seems like my problem is something small and obviously, not obvious. at least to me...
  10. Kelmar

    Kelmar Done by choice VIP Member

    No idea on your first question. 2nd question - I hit manual setup instead of next (same info worked doing it that way).

    Good luck!
  11. marctronixx

    marctronixx Moderator Moderator

    i use EAS server 2003 SP2. EAS works beautifully on the hero... i have a pro2 it its unreliable on the same server. i have an open ticket with HTC right now...
Loading...

Share This Page