[FAQ]ROOT MEMORY: a2sd+ / partitions (updated 10th August 2011)


Last Updated:

  1. SUroot

    SUroot Well-Known Member Developer

    I already know about it. What of it?

    Advertisement
  2. edwardmlyte

    edwardmlyte Well-Known Member

    Hey dan. How do I backup my oxygen install which has app2sd+ already set up and working? Can I just nandroid, will that store all the extra apps, and then wipe settings to try out gingervillain?
  3. Hadron

    Hadron Well-Known Member Contributor

    nandroid backs-up the sd-ext partition, so yes, it will fully back up your current oxygen including apps.

    If you want to restore any of those apps and their data on GV you'll need to take a Titanium backup of them as well.
  4. Staggers

    Staggers Well-Known Member

    Eris Ed likes this.
  5. SUroot

    SUroot Well-Known Member Developer

    Added the bold text below:

    How do I get it?

    You need to go through a rooting procedure (unrevoked recommended) and install a custom rom which has support for a2sd+

    You can also flash it separately onto any rom providing it has init.d support.

    You can download the Dark Tremor Beta here

    Pretty much all custom roms have init.d support but stock roms do not. If you want to add init.d support (running scripts at start up [initialisation - hence "init"]) you will have to do this


    -------------------------------

    I have got Dark Tremor a2sd and my internal memory is smaller than expected

    Dark Tremors latest a2sd script does not move Dalvik cache by default as before. You need to download "terminal Emulator" from the market and run it.

    Type "su" and press enter
    Type "a2sd cachesd" and press enter.

    The desire will reboot and you will see a big chunk of additional free space on your internal memory


    -------------------------------

    Are there other options when rooted?

    Yes, titanium backup can move all apps to SD card, however again, this is not on a partition so has many shortfalls.

    Also some custom ROMS allow the default installation location to be changed to external media, but this is the same as titanium.

    There is something called data2sd which will allow you to move your entire /data partition to EXT. This is still in its infancy and does not work on all init.d roms. Read about it here
  6. togger161

    togger161 Well-Known Member

    OK, I'm a noobie, and I'm getting a little lost - only had the phone 2 weeks. Rooted it and running custom rom Oxygen 1.0.4. Have a 16GB sd card and been moving my apps onto there. OK, I was chuffed at this point and thought that's all there was to it.

    Then I started reading threads about creating an EXT partition that would allow all apps to be moved including widgets etc, and that these should always run and be available to the phone as the ext partition is always available to it as it's not mounted as a drive when you plug in to a PC. So I though OK, now this is a better way to go. I backed up my card, created an EXT partition and reformatted the remainder. Had a look at the sd-ext partition and it is being used, I have app, app-private dalvik-cache and lost+found on there, with 55mb of apps in the app folder. Great I thought, all working.

    Problem I have is that I'm not sure installed apps are installing to the card by default, app2sd still gives alerts showing apps can be moved. Also I tried moving beautiful widgets to the sd card and it won't load, fine if I move it back.

    So I'm not sure now I have this setup working fine, if I need to do something else to get it fully working or if I was just expecting it to do more than it is.
  7. SUroot

    SUroot Well-Known Member Developer

    The ext partition is not the same as the sd card you are being alerted to. You don't move anything yourself. All apps need to be moved back to internal memory for apps2sd+ to work.

    This.is all in post 1 of this thread
  8. togger161

    togger161 Well-Known Member

    OK, thanks for that - just to add it was apps2sd that popped the alert up saying the program could be moved so I just accepted it, I didn't use the manage apps move to sd card option.

    So what you are saying is that if apps2sd says a program can be moved, you ignore it.

    I wasn't sure if I'd done things in the wrong order and that was causing a problem. I had already flashed a rom and wasn't sure if it disabled something apps2sd needed as the card was not partitioned at the time of install.

    Everything seemed to be working until I accepted apps2sd's offer to move beautiful widgets. When that didn't work I assumed I had a problem.

    If I am understanding things correctly, the phone sees the ext partition as an extension to the internal memory and just gets on with making it all work without having to intervene.
  9. shauny13

    shauny13 Well-Known Member

    If I am understanding things correctly, the phone sees the ext partition as an extension to the internal memory and just gets on with making it all work without having to intervene.

    You are correct.
    togger161 likes this.
  10. SUroot

    SUroot Well-Known Member Developer

    The apps2sd app does the same as move to sd in manage applications. It's just an easier way of using the functionality.

    It's designed for un rooted phones.

    You should uninstall the apps2sd app now. You won't need to use it again
    togger161 likes this.
  11. togger161

    togger161 Well-Known Member

    OK, now I understand. very new to all this, as my wife says, I am trying. :D

    As I've only had the phone 2 weeks, I have just done a wipe. Am installing everything from fresh and just letting the OS get on with it all. Removed apps2sd as well.

    I appreciate your help, thank you.
  12. SUroot

    SUroot Well-Known Member Developer

    No worries. Enjoy you new found freedom!!
  13. scoobysnax

    scoobysnax Active Member

    Hi folks, trying to use GParted to create a partition on my sd card before I install a ROM.... running into a problem after following the instructions below:
    Properly Partition SD Card For App2SD+ Android ROMs

    Im getting to the step 7 and looks ok, only when i try to complete step 8, I cant do the step in bold below as the option is greyed out and unclickable...

    1. 8: Similarly create another new partition in the unallocated space but set this one as
  14. shauny13

    shauny13 Well-Known Member

    have you tried refreshing devices after step 7?
  15. scoobysnax

    scoobysnax Active Member

    will give that a try, just re-loading gparted on the mac... get back in 5 mins

    cheers for the reply.

    Scooby
  16. shauny13

    shauny13 Well-Known Member

    if not, try right clicking on unallocated space and doing it that way, i think that's how i did it, although quite a while ago for me.
  17. scoobysnax

    scoobysnax Active Member

    hmm... tried refreshing after step 7 and still not able to ''create as'' logical partition, only allowing me to select primary or extended...
  18. scoobysnax

    scoobysnax Active Member

    am clicking on unallocated space and clicking new in the top left corner... as im using the mac there is no right mouse button. usually when in OSX I can just use two fingered click to get right click, but doesnt seem to work while booted from the GpartED disc.
  19. shauny13

    shauny13 Well-Known Member

    i dont know then. U could try with a card reader perhaps? and i've heard many people have success with "mini tool", but this might be a windows only app. Failing that pm Dan here (SUroot), he knows a lot more than me.
  20. SUroot

    SUroot Well-Known Member Developer

    You don't need to specify logical. Just click in unallocated space and create an ext partition
    scoobysnax likes this.
  21. scoobysnax

    scoobysnax Active Member

    Cheers folks, managed to do it... was just wary of trying it without specifying logical. Have now got Gingervillain 1.0 and am currently setting up the phone and getting my apps from the backup I made.

    Thanks!

    Scooby.
  22. SUroot

    SUroot Well-Known Member Developer

    Dont forget to download and install terminal emulator.

    As per this FAQ, it uses dark tremor a2sd.

    Run terminal emulator

    type:

    Code (Text):
    1. SU
    press enter

    Type:

    Code (Text):
    1. a2sd cachesd
    press enter.

    Phone reboots, not dalvik cache is on sd ext too
    scoobysnax likes this.
  23. scoobysnax

    scoobysnax Active Member

    Cheers m8, forgot that...

    Only one small problem, decided to use my personal gmail address this time round, just realised my previous (only a few mind you) paid apps are all in my other gmail address! Had a quick search but looks like there isnt a way to join the 2 accounts... (yet?)
  24. SUroot

    SUroot Well-Known Member Developer

    Dont think so. Youd have to factory reset to set up with your other gmail account to access those downloads.
  25. sameee781

    sameee781 Well-Known Member

    What should be the minimum class of miccroSD card to be used here? What is the recommended value of class.

Share This Page