GNM_TURBO JIT + OC = 8+ mflops


Last Updated: 2011-08-29 00:32:50
  1. gaetawoo

    gaetawoo Guest

    could turbo4 be installed on a stock rooted 2.1?

    Advertisement
  2. darkxsun

    darkxsun Well-Known Member

    Sure, that's how I installed it.
  3. treyjones424

    treyjones424 Well-Known Member

    Just hit 9 mflops.
  4. Eridger

    Eridger Member

    This is (or was) lolbug. Some idiot on bugmenot decided to use that account to break the rules...

    Anyways, drellisdee, I was just wondering about overclocking the Ally. You mentioned that there is no way of pushing the Ally past 787200 without pushing ahb too far. Is it theoretically possible to pass this barrier? In one of your past posts you described the problem with increasing the clock speed any further, and it sounds like a hardware difficulty rather than some sort of software issue so I doubt going any higher is possible, but I was wondering what you thought.

    EDIT: Oh, and when froyo is released for the Ally, will we still see a decent speed increase? From my understanding JIT and the new Dalvik implementation were the the main things giving all those froyo users such a large boost. Am I wrong in thinking this?
  5. jCorrr

    jCorrr Member

    Pretty close to my score. I'll try to get higher if more people come and reach 9 MFlops.
  6. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    787 is pretty much it anything over it crashes immediately or soon after taken off ac power.

    I used eclair dalvikvm and libs and didnt backport like samdroid project. Jit on froyo is much better.
  7. Eridger

    Eridger Member

    So it's simply impossible for the Ally to go beyond that, huh? Oh well.

    It's strange that 2.1 JIT and dalvik aren't usually (ever?) implemented by companies (or by Google itself by default) if it provides such a large performance increase. Is this just because it would be too much hassle for companies to port?

    Nevertheless, it's good to know you didn't go crazy and port 2.2 JIT and Dalvik. Otherwise we might not get into a frenzy after 2.2 is released. :p
  8. mattgaitan

    mattgaitan Well-Known Member

    many thanks, makes my phone much more tolerable :D
  9. jetblack

    jetblack Well-Known Member

    Thanks again, drellisdee. I just flashed GNM_TURBO4 over GNM_TURBO3. Signature verification worked fine this time, and the stock calculator is working again.
  10. Bradferguson

    Bradferguson Member

    I'm having trouble with Barnacle, every time i open it and press start it will freeze and then restart my phone. I also have pdanet when i plug the usb in the first time it also will restart my phone but after it restarts it will work fine. just wondering if anyone else has experienced this. thanks
  11. dots

    dots Well-Known Member

    I use both Barnacle and Pdanet and have not experienced any of these errors.
  12. Bradferguson

    Bradferguson Member

    Ugh just my luck. i have reinstalled wiped and everything it works for a wile then i start having trouble maybe i am having a app conflict
  13. dots

    dots Well-Known Member

    Yeah im not sure there i haven't had an issue and i have to tether since that is my main internet source. Did this happen after you flashed the GNM_TURBO JIT?
    If so try re-flashing it and see what happens.
  14. Bradferguson

    Bradferguson Member

    Ill give that a shot thanks for your response.
  15. KuroTsubasa

    KuroTsubasa Well-Known Member

    Flashed gnm_turbo4 over Velocity 0.2 last night. Made sure to erase both caches. Used SetCPU to up max clock speed to 787mhz.

    I've been having a lot of instability with my phone since then. Mostly hangs, with an occasional FC. I reverted back to my Velocity backup after missing two phone calls this morning due to hangs. Basically my phone rang, but Android was so hung up that it gave me a frozen lock screen instead of the phone app (and wouldn't unlock while ringing either). Also, last night I had one kernal panic while opening the browser, but none since then.

    This behavior hasn't been limited to the Phone app either, its been really slow at switching apps (or even returning to the homescreen). It runs great in any given app, but 30 seconds or more to switch apps (or answer a call for that matter) is way too long.

    Any tips on how to get things running a bit smoother? It sounds like everyone else is having great luck with this. If this was on a pc, I'd think it was a ram or swap space related issue, since it only hangs on switching tasks. On a related note, I don't have any swap space on my sd card... not really sure how that works, but it sounds like my sd card isn't classed high enough to use for swap space anyway.

    Any help would be really appreciated. And I'm really open to suggestions. Thanks.
  16. dots

    dots Well-Known Member

    Have you tried using a lower mhz? Every phone is different and not all of them can handle 787mhz.
  17. jetblack

    jetblack Well-Known Member

    Did you try any of the lower speeds before going to 787? It's possible that your CPU can't handle that speed - there have been a number of reports of that. Sounds like QA is a bit spotty on the processors.

    I spent yesterday slowly easing my way up. I ran it at 600 MHz for a while just to make sure the JIT kernel was ok. Then I bumped it up to each of the OC settings one by one and let it go for a few hours to make sure the phone was stable at each. It might be worth trying that to see if your phone is stable with this kernel and these libs at any clock speed.
    KuroTsubasa likes this.
  18. KuroTsubasa

    KuroTsubasa Well-Known Member

    I'll give that a try. I was thinking that the Kernal Panic was obviously due to the clock speed being set too high. I didn't think that the instability was caused by it, but I suppose it's possible. I'm gonna try running it at 600mhz for a bit and working my way up from there. Thanks for the tip.
  19. Morte

    Morte Member

    6.8 with Linpack without OC. Really Impressive. Now we just need some compcache lovin ;)

    Really Great Work!
  20. railroadryan

    railroadryan Member

    i've been running mine @ 768/245 since it's been releasd .. heavy usage and not had one problem.. it get's 8.0-8.33 on linpack.. I'm amazaed at how far the dev's have come in the 6 weeks since i got the ally.. i'm greatfull for all the hard work
  21. Oblivious72

    Oblivious72 Well-Known Member

    i did not run a test before i flashed this but now i am 8.162 mflops and on quadrant standard i am at 522 mhz
  22. BugsyM

    BugsyM Active Member

    Just figured I'd share my results, running velocity 0.2:

    Linpack tests:
    Original: 4.02; 4.045; 3.963
    New Kernel, stock clock: 6.683; 6.231; 6.838
    748mhz: 7.12; 6.917; 6.854
    768mhz : 7.647; 8.21; 8.064
    787mhz: 8.337; 7.998; 8.196; lots o' kernel panics :(


  23. GameMisconduct

    GameMisconduct Active Member

    I installed the Turbo4 JIT and now I am having issues with the kernel panicking. When I try to load Clockwork to get back into restoring my backup the phone hangs up at the LG screen. Note: I do not have setcpu or velocity
  24. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Simple solution. Dont use F**KING CLOCKWORK!!! Use my recovery which seems to stick a whole lot better on this device. Also, kernel is set to 600mhz same as stock on boot unless you selected set on boot with setcpu to a higher speed (which is a big mistake). This was done as a saftey measure incase you picked a speed higher than you can handle. Try pulling your battery.

    To fix recovery pull your battery and boot holding send + menu + power and let go when you see lg logo. Hopefully clockwork didn't fail you. If clockwork failed you you need to go into irc and get help installing my recovery with fastboot.
    GameMisconduct likes this.
  25. GameMisconduct

    GameMisconduct Active Member

    Well I can load it up with the JIT kernel but it seems to panic every 20 minutes. If I do the send + menu + power I get a blue screen and it freezes there.

Share This Page