Google password change - problems logging into google on my galaxy S2


Last Updated:

  1. ksammut91

    ksammut91 Member

    Hey all, I recently changed my google account password. I am trying to log into google on my phone, however when I enter the new password, it keeps telling me "You have entered the wrong password or your account has changed. Please re-enter your password." I've tried entering the new password a million times, tried re-starting the phone, tried putting in the old password etcetera etcetera, but nothing worked. Could some kind soul possibly help me?

    Advertisement
  2. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Hello ksammut and welcome to the Forums. :)

    Have you tried clearing the data on the google play store app to see if that helps?
  3. ksammut91

    ksammut91 Member

    Hey thanks!

    Nope that didn't solve it :S this is really effing frustrating!
  4. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Do you mean like a G-mail account or a google account in general?
  5. ksammut91

    ksammut91 Member

    google account in general
  6. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    Does it work if you try it on the PC?
  7. ksammut91

    ksammut91 Member

    yeah works perfectly on the pc!
  8. T.M.M.L

    T.M.M.L Well-Known Member

    Greetings ksammut91,

    You can try going to the following link on your PC.

    Underneath the log-in section is a link about accessing your account.

    It will lead you through a few options on how to get a connection.

    https://www.google.com/accounts

    Hope this helps.
  9. gbaker59

    gbaker59 Member

    Hey ksammut91 I had the exact same problem recently. On the phone drag down the notification bar and look for something related to the password change or problem (I can’t remember what it said but it’s obvious when you see it). Press the exclamation point next to the wording an screen will come allowing you to make the change. Why it’s this convoluted is beyond me.
    petersteier likes this.
  10. ksammut91

    ksammut91 Member

    Solved it. I tried entering an application specific password and it worked. I cannot understand the issue of application specific passwords, would someone please explain?
  11. T.M.M.L

    T.M.M.L Well-Known Member

    Greetings ksammut91,

    Welcome to the forums.

    It seems like you have 2-step verification turned on.

    When you use this, it allows you to use apps that request access to your Google account, without having to provide your Google information.

    Application specific passwords are generated to provide these apps with said access.

    Instead of inputting your main Google credentials into the app, you would provide the generated app specific code.

    The app connects to your account like normal and your Google log-in password remains private.

    You can also revoke access by removing the specific code from the allowed codes in your Google account.


    Hope this helps

Share This Page