[Guide] S-OFF and ROOT HTC Desire with Revolutionary - Updated

Last Updated:

  1. desarenezitic

    desarenezitic Well-Known Member

    No problem, no-one gets annoyed in here ;)

    Firstly how did you partition your SD card and what size and format did you make it (Ext2/3/4)?
    Secondly you need an A2SD solution, I can point you to this thread http://androidforums.com/desire-all-things-root/605630-a2sd-error-help.html were a new rooter experienced similar issues, he was using the DarkTremor script and an A2SD GUI (I believe). DrakTremor script should be available on XDA I imagine and should just need flashing in recovery, GUI here https://play.google.com/store/apps/details?id=com.elgubbo.a2sdGUI&hl=en Give a yell in either thread if your stuck.

  2. Laxie

    Laxie Member

    I used Gparted and moved 1gb to ext3. It's a 32gb class 6 sd card.

    I've just flashed DarkTremor and also installed GUI.

    I've gone to phone settings>apps>manage apps and it still shows internal memory as 21mb free. Either I'm looking in the wrong place, or something is still not right.

    Edit, not sure how to do a screen shot of the phone, but Quick System Info says the following:

    SD card storage
    total 29.70gb, free 27.68gb

    A2SD storage
    145mb, free 43.15mb

    Internal storage
    148mb, free 17.62mb

    System Storage
    250mb, free112mb

    System Cache
    40mb, free 36.49mb

    406mb, free 177mb, idle 11.73mb

    ARMv7 Processor rev 2 (v71) 499 MHz

    What next?
  3. desarenezitic

    desarenezitic Well-Known Member

    A couple of points to note if I may; Quick System Info is not showing your Ext partition as A2SD as only showing 145MB as total also I am not sure how DarkTremor works as it sounds like you may have flashed it after installing some apps? I am not sure if it just automatically moves apps to sd-ext but this is a moot point as your sd-ext partition isn't showing up; you could try mounting it in recovery to make sure it is mounted.
  4. Laxie

    Laxie Member

    I've just gone into recovery and checked.

    Cache, data, sdcard & system are all mounted. No mention of ext3 though.

    Checked the mount point and it only shows sdcard - fat32- 29.7gb No mention of ext3 here either.

    This is a bad thing, isn't it?

    I don't suppose flashing the rom again would help find it?
  5. desarenezitic

    desarenezitic Well-Known Member

    It would be under sd-ext I think; it doesn't seem like the partitioning worked; did you create the ext3 after the FAT32 part of your card and did you make it primary in gparted? Looks like you may need to redo it, if possible save everything of your SD card onto your PC and totally format the card and set it up from scratch.
    Laxie likes this.
  6. Laxie

    Laxie Member

    I did fat32 first, made it primary and then did ext3 after.

    Will re-do it now.

    In other not so great news...I can make calls (dial and connect), but nobody can hear me on the other end when I'm speaking. No ringer sound from the phone when I get an incoming call either, despite the volume up to the max. Just when I thought we were nearly there and sorted. Sigh.
  7. desarenezitic

    desarenezitic Well-Known Member

    When you have re-done your SD card I would suggest doing a full wipe and fresh install, flash your ROM (maybe try a different one) and then flash A2SD and then set up your phone.
    Hadron and Laxie like this.
  8. Laxie

    Laxie Member

    YAY!!! I'm all sorted...successful partitions and all.

    Thank you soooooo much for being patient with me and explaining things in an idiot proof way! This idiot really did need the help. lol Thanks again. :)
  9. desarenezitic

    desarenezitic Well-Known Member

    Nice one, glad you got sorted, enjoy your new phone ;)
  10. existinguser

    existinguser Active Member

    By the way. The best rom for s-off rooted desire is RunnymedeMod007_v21_c-CM7-STOCK.zip
    I tried countless Roms and this is really it! The nicest stable rom with every functionality you will ever want and it got Really nice full Sense 3.5 :)
  11. Hadron

    Hadron Well-Known Member Contributor

    Naaah, dGB, completely stable, absolutely minimal (fits in 60MB), add the functionality you need, and only that functionality, yourself. And no Sense whatsoever ;)

    Moral: There's no "best ROM", just the ROM that's best for you :)
  12. existinguser

    existinguser Active Member

    The thing is that I really like sense.
    And since this rom is able to use sd as internal memory, it is lovely :)
    But yeah, every one has their favourite :)
  13. existinguser

    existinguser Active Member

    P. S.
    Hadron, does your rom have the ext function? If yes, I would love if you could link me to the rom you use
  14. Hadron

    Hadron Well-Known Member Contributor

    The ROM I'm using is dGB. There's a thread about it in this forum, as the author is our own SUroot (now moved on to the S3).

    No sd-ext however. It's designed for a different philosophy - really small ROM, then repartition your internal storage to maximise available space.
  15. existinguser

    existinguser Active Member

    Yea, damm. It could be awesome if the rom had ext.
    Maybe you happen to know what other light weight rom has sd ext?
  16. Hi,

    The download links for step 4b are not working, any alternatives ?

    This thread is brilliant btw:)
    Hadron likes this.
  17. Hadron

    Hadron Well-Known Member Contributor

    I've fixed the first link.

    The goo.im archive is having problems at the moment.

    snowdrop23jane likes this.
  18. I have managed to s-off with no problems, But i am stuck when rooting After booting in hboot and selecting recovery My phone shows the o2 logo and then a picture of a mobile with a red warning triangle, Why is it not giving me a recovery option menu? Phone is working normally when I switch on normally so no worries there.
  19. Hadron

    Hadron Well-Known Member Contributor

    Sounds like you haven't successfully flashed a custom recovery (step 6). That's the HTC stock recovery (near useless) that you're seeing.
  20. Ok I have been doing step 6 but after typing in the cmd I get a message telling me it is not recognized as a command, I have been working through the thread making alterations to the cmd but still the same message. I have put the recovery file into C:\ to make life easier.
  21. SUroot

    SUroot Well-Known Member Developer

    Did you read the FAQ in step 3? This tells you how to setup fastboot. This is a requirement
  22. Fastboot is done. So I have repeated step 6 and now have "sending recovery ok" "writing recovery failed" remote image error (bootmagic check fail)
  23. Hadron

    Hadron Well-Known Member Contributor

    Which recovery? I don't know the "bootmagic" message, but first guess is to download the recovery img again.
  24. CaptainBeaky

    CaptainBeaky Active Member


    We have root!

    Thanks, all

    Minor eeek moment with "fastboot is not recognised command or executable", until I realised the directory it was in wasn't on the main path. :eek: A quick cd to the fastboot location and all worked swimmingly. :D

    Now what shall we try first????? :smokingsomb:

    Edit: A2SD, obviously, once the shiny new 32GB Class 10 card turns up :), and then to nuke some of the bloatware :mad:
  25. dpibs

    dpibs New Member

    Hi All, I am a newbie to rooting. I have HTC desire and was facing issues with memory. I rooted my phone. I had following before rooting.
    Bravo PTV4 Ship S-on

    Android 2.2.2
    Kernel - HTC-kernel@and18-2#1
    Build - CL345089 release keys
    Software number -
    Browser version webkit3.1

    Now I have S-off using revolutionary and using ClockworkMod recovery V5.8.0.2.
    My problem started when I tried to move apps to SD. I installed Titanium, partitioned my SD card to ext2 using Minitool partition wizard but Tianium did not recognized ext2 partition. I tried to re-partition my SD card and tried to wipe user data from recovery but looks like i deleted some system files and now I only get 2 messages.
    1. process com.htc.launcher has stopped unexpectedly
    2. process com.android.vending Force close or wait.

    Could you please advice how can i get my phone functioning again?

Share This Page