GV Incoming Calls not displaying Caller ID


Last Updated:

  1. rswheaton

    rswheaton Well-Known Member This Topic's Starter

    Joined:
    Oct 13, 2009
    Messages:
    183
    Likes Received:
    9
    Is anyone else using GV with their HERO? My incoming calls are not displaying a caller ID. Anyone else having this issue?

    I just checked and even if I call my Sprint # directly I have no incoming caller ID displayed. This must be a Sprint issue and not Google Voice. I will call them today
     

    Advertisement
  2. SDscorch

    SDscorch Well-Known Member

    Joined:
    Aug 19, 2009
    Messages:
    568
    Likes Received:
    9
    yeah.. let us know what you find out

    there is some "weirdness" google does to make GV work - it seems when you dial out through GV, they assign that person a unique GV# (i've seen 406 and 916 area codes)



    also, there's a setting on the hero that automatically adds any unknown numbers that dial in

    so.. i had a LOT of duplication - ie, my biz partner had like 12 entries in contacts - just his name and no other info - turned that setting off!!



    and, if you want *only* your GV number to be seen on the other end, you have to either send out via the GV app or send through Messages/Handcent/Chomp to that unique number that GV assigns that person

    which means.. more "bookwork" for you and me - we gotta add that GV number to our contacts' profiles




    still a work in progress......
     
  3. rswheaton

    rswheaton Well-Known Member This Topic's Starter

    Joined:
    Oct 13, 2009
    Messages:
    183
    Likes Received:
    9

    Problem resolved... sprint had my inbound caller ID blocked. The the GV long distant area code thing can be confusing. They are basically NAT'ing phone numbers just as you would IP's in order to create more.
     

Share This Page

Loading...