How do I remove Titanium Backup from my now-unrooted HTC Droid Incredible?

Last Updated:

  1. SuperNova86

    SuperNova86 Member

    I was having trouble with my Incredible (running 2.3.4) so I decided to try a factory reset. Thought I might want to back it up first, so I rooted using Unrevoked and installed Titanium Backup. (Rooted as described in the great sticky thread in this forum... sorry, it won't let me post a link as a new user.)

    So I did the reset, only now things are worse than before, with constant force closes and apps disappearing at will. The phone is no longer rooted and I cannot get it to root again. Unrevoked hangs on "Waiting for system to settle," which I assume is a whole different issue, but one that I don't really care about because I don't want to root again unless I have to.

    I'm still under Verizon warranty and thinking the best thing I can do is just take the phone back and get a new one, since there seems to be something seriously wrong with this one. The only problem is, Titanium Backup is still installed after NUMEROUS factory resets/clear storages/etc., which I assume is a red flag. When I try to uninstall it, most of the time, the uninstaller force closes and does nothing, but when it does uninstall, the program comes back after a reboot. And it always comes back after a factory reset.

    So what do I do? I'm guessing it's installed itself in the system partition, but how do I get it out of there? Do I have to have root to do it? I can't figure out how to get my system rooted again, because Unrevoked isn't working. My phone force closes almost any program I try to run, so I have to do something or I've got a glorified brick. Help!

  2. sdrawkcab25

    sdrawkcab25 Well-Known Member

  3. SuperNova86

    SuperNova86 Member

    Thanks for the suggestion. I have actually done that and as far as I can tell I am now running the stock version. But Titanium Backup stays installed and even if I uninstall it, it comes back. This is even after flashing the stock ROM and NOT installing TB again.
  4. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Do you have it installed to your SD card? that's the only way it would remain if you installed the stock image as described in the link I provided.

    Other than that you can do do a factory reset directly from the phone while booted. This will take you to a point exactly like you just bought the phone (you will even have to reactivate the phone through *228 option 1)
    iowabowtech likes this.
  5. SuperNova86

    SuperNova86 Member

    Well, this is somewhat strange, I know, but a factory reset does NOT delete TB for me nor does it do much of anything (my Google account and Wifi network are still saved on the device, though I think I had to *228 again).

    And the SD card has been re-formatted to FAT32 so I could restore my stock system, so it isn't on there either. (In fact, I tried using the Move to SD Card button on the app, mounting the SD card as a drive on my computer, and manually deleting the file... and on reboot, there it was, as if nothing had happened.)

    Any ideas what could be causing this?
  6. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Try turning on airplane mode when doing a factory reset (before and after) the only thing that would explain titanium remaining, is that it is auto restoring (feature of android).

    The methods described in the linked thread (restoring to stock 2.3.4) will always completely wipe the phone and reinstall the whole operating system if done correctly.

    Try running the file found here from a windows computer:
    iowabowtech likes this.
  7. iowabowtech

    iowabowtech root@android:/ #

    +1 to the above advice although that file can be difficult to obtain as I've found in my evening of trying. They seem to have put MAJOR restrictions on that file sharing site or I was unlucky for hours on end, one of the two. Consequently, I'm of the belief that may be the only location on the net the full RUU still exists.

    If you have problems, I finally got it and I'm mirroring to 2 locations both the RUU (.exe) and I also re-extracted the to provide the PB31IMG option again.

    I will update the return to stock thread and other associated threads tomorrow with the necessary files.
  8. SuperNova86

    SuperNova86 Member

    I tried airplane mode factory reset (doing the reset from the Settings menu). The phone hung on reboot at the screen that has a picture of a phone with a red exclamation point. Thinking I'd seen that screen before, I pressed Volume Up and Power which, as I though, put me into Recovery (stock version, I think). From there, I again chose Factory Reset, then rebooted. It at least got rid of my home screen icons, which it had not been doing on my last few resets, but Titanium Backup was still there, as was my Google account. (It took itself out of Airplane Mode, but there was no indication it had connected to anything.)

    Is there any way that TB (and, apparently, my Google account) somehow got moved into whatever the system uses to re-install itself after a master reset? I don't know how that could happen, but I don't know how else this stuff keeps hanging around.

    Is this the same RUU file from here?

    I tried that previously but had no luck. I will try again after I install HTC Sync, which seems to be required for that version. If this is something different, please let me know. I'll update once I've given that a shot.

    Thank you both so much for your help so far.
  9. SuperNova86

    SuperNova86 Member

    The RUU I am using from pvillecomp's site (4.08.605.2) at first gave me this:

    But now it's giving me ERROR [170], USB Connection Error, despite the cable being firmly connected at both ends and everything else appearing normal.
  10. iowabowtech

    iowabowtech root@android:/ #

    The files I recovered are not the same as the file on that site. That file seems to be only updating peoples hboot to the new version pushed out with the HTC dev tool, unless I am missing something, and it further seems to Bork some peoples phones. The files I posted are the full and final gb ruu for the Inc. Find them here:
  11. SuperNova86

    SuperNova86 Member

    The file says it's an RUU, but I am happy to try your version instead since that one is getting me nowhere. Thanks!

    EDIT: The one I've been using is much, much smaller than 190 MB, so maybe I was mistaken. Fingers crossed!
  12. SuperNova86

    SuperNova86 Member

    OK, your file seemed to work, and didn't give me any of those errors... and yet, Titanium Backup is STILL THERE. My Google account is STILL THERE. Any ideas?

    (For the record, there is no SD card in this phone right now.)

    I'm completely at a loss.
  13. iowabowtech

    iowabowtech root@android:/ #

    After running the RUU and starting up the phone are you entering in any account info at phone setup? Like your google account credentials, etc. Or anything at all for that matter.
  14. SuperNova86

    SuperNova86 Member

    No, it just boots to the home screen. It's as if it was new out of the box BUT it does not bring up the setup program or anything like that.

    But then I open up the programs drawer, and TB is there. Or I go to Settings/Accounts and my Gmail is there. It's like everything gets deleted but these two things.
  15. iowabowtech

    iowabowtech root@android:/ #


    So if you go to accounts & sync your Google account shows up there? If so, can you delete it? Seems like I remember there's no way to delete a Google account in GB without a factory reset but just checking. If there's an option to delete, (perhaps a long press on the account name?) try that first.

    If not, have you tried a factory reset from within the phone's settings menu rather than in hboot or recovery? If you haven't, try that next.

    Next question, go into hboot and let me know what version of hboot you are running? Also, is it s-off or s-on? (should say at top of hboot screen)
  16. SuperNova86

    SuperNova86 Member

    I tried that but it said that the account was required by the system (or something along those lines) and couldn't delete it without a factory reset. I think I've seen (in search results) some threads about ways to delete it without doing the reset, so I may explore that next, but it can't be directly deleted through Settings. And given my experiences, I'm guessing that even if I manage to delete it (like when I uninstalled Titanium Backup), it will just come back on reboot.

    Yes, I did. I think I mentioned above that it did not seem to go through all the way, getting hung up on reboot with a picture of a phone and a red exclamation point in a triangle. I have seen that screen before, so I hit Vol Up + Power to get into recovery (the only way out of that screen, AFAIK) and did a factory reset there for good measure. So I guess the answer to your question is, yes and no: I've tried it but it doesn't seem to work.

    0.92.0000 and S-ON

    Here's the whole thing, if it might help:
  17. iowabowtech

    iowabowtech root@android:/ #

    Now that you have run the correct RUU, would you humor me and try one more time to factory reset from the phone's menu? Just need to satisfy my curiosity. If possible, put a blank SD card in the phone at the time. Or one that doesn't have any prior root dealing associated with it.
  18. SuperNova86

    SuperNova86 Member

    I just have the one SD card, but I went ahead and formatted it using my computer, then put it in the phone. Then I went to Settings/SD and Phone Storage/Factory Data Reset and reset everything, including internal storage and SD card.

    ...And ended up back at the red ! with the triangle screen.

    Possibly worth noting: When I then go into recovery mode, it says:
    Code (Text):
    1. E:Can't open /cache/recovery/command
    And when I do the reset from there, it kicks other errors. Here's the output:
    Code (Text):
    2. Restore factory NV setting...
    3. Formatting /data...
    4. E:Can't open /data/
    5. E:Can't open /data/cw.prop
    6. E:format_volume failed to unmount "/data"
    7. E:Can't open /cache/
    8. E:Can't open /cache/cw.prop
    9. Formatting /cache...
    10. Data wipe complete.
    Any ideas?
  19. SuperNova86

    SuperNova86 Member

    Thanks again for being so helpful. I think I'm calling it a night for now. I'll be back to try again tomorrow, but I thought I should let you know why I won't be responding tonight!
  20. iowabowtech

    iowabowtech root@android:/ #

    Ok so here is what I think may have happened...

    I'm guessing you did the factory reset WHILE you were rooted and that you did it from the phone's settings menu? This has been known to cause very strange issues if that's the case. To be honest, I don't know for sure that there is a guaranteed fix for this. But if it were my phone, I would root again and install Clockworkmod recovery. I would then try to wipe data/factory reset, wipe cache partition and wipe dalvik cache via clockwork. I would then attempt to boot to system. If it boots (give it up to 30 minutes as it may hang a long time), I'd then try to run the RUU.

    If it failed to boot altogether or bootlooped, I'd go back to recovery, redo the wipes listed above and then flash a rooted rom from the sd card which was based on stock 2.3.4 and once it booted, I'd run the RUU at that point.

    This is admittedly a lot of work but it sounds like you may have already been through this if you came from 2.3.4 orginally:

    May want to wait for some other ideas that would be less time consuming but I feel like you've tried everything possible with the phone in it's seemingly stock state. There's only so many options with the stock recovery unfortunately. Good luck.
    sdrawkcab25 likes this.
  21. SuperNova86

    SuperNova86 Member

    It's entirely possible that that's what happened. But I've been trying to regain root without success: Following the instructions in the thread you linked, Unrevoked is able to access the phone, but when it reboots, Unrevoked says "Waiting for reboot" (I think the USB Debugging has turned itself off, so the program can't communicate with the phone)... then I go to turn debugging back on, and Unrevoked says "Waiting for system to settle..." I have not found a satisfactory solution for this issue yet, although it looks like I probably should do some more research as that would allow me to do what you suggest.
  22. iowabowtech

    iowabowtech root@android:/ #

    Just to be clear, you are starting out with the older version of Unrevoked (3.22) for this purpose per the thread right? That whole deal is a workaround due to the constraints of 2.3.4 and the need to go backward in order to eventually use the newest Unrevoked which is a step much later in the process. Bottom line though, if you run into any problems with the process, most definitely post in the downgrade/s-off thread. There are some smart peeps that continually monitor that thread and I'm very highly confident you will be guided to success.
  23. iowabowtech

    iowabowtech root@android:/ #

    Also, did you end up uninstalling HTC Sync from earlier? If it's still on your machine, it will often cause the "waiting for system to settle" problem. You don't need it anymore, you've already obtained the drivers that are packaged with it. If when you uninstall from windows control panel and there is a second, small reference to HTC Sync drivers, leave them there. Uninstall the main program, then retry Unrevoked 3.22.
  24. SuperNova86

    SuperNova86 Member

    Yes, I am using 3.22 with the version of Clockwork recovery posted there. But I will try posting in that thread. I was a little intimidated because it was so long, and I didn't really want/need to get root back, but it looks like that may be the best way to solve this.

    I think so. I've uninstalled and reinstalled it several times, I think, knowing that was an issue. I'll double check before I run it again, though.

Share This Page