How do you root a PendoPad 4.0 PP4MT-7?


  1. styelz

    styelz Active Member

    Hmm, thanks for the info bubbasd. I've tried changing my build.prop. And get some very odd results lately from GooglePlay when trying to install Chrome. See pic:

    [​IMG]

    No biggie really, as I was able to install it via 1Mobile Market. :smokingsomb:
  2. bubbasd

    bubbasd Well-Known Member

    Im sorry my last post had incorrect build.prop settings that made no sense :eek: but i corrected and Im 110% sure its right now ;) this here is supposed to be original pendo PP4MT-7 build.prop settings
    \this below is correct/
    Code (Text):
    1. ro.product.model=PP4MT-7
    2. ro.product.manufacturer=unknown
    your build.prop should look like this if u are to pose as a HTC PG86100?
    Code (Text):
    1. ro.product.model=PG86100
    2. ro.product.manufacturer=HTC
    :thumbup:



    That pic has alot of failed device names (Sooo sorry about that :pound:) u can make them dissappear though
    here's a sort of fix not permanent though
    -------------------------------------------------------------------------
    Removing/hiding devices on Google Play website
    It is not possible to completely delete devices listed under Settings on the Google Play website. However, if you'd prefer to hide a device from view, you can do so:

    Visit play.google.com
    Select Orders & Devices (at the bottom of the page)
    Navigate to Devices
    Click Show in Menus (under Visibility)
    Select Hidden in Menus next to the device you wish to hide

    --------------------------------------------------------------------------
    this above info was Taken from Removing/hiding devices on Google Play website - Google Play Help

    this link below is shortcut to google account orders and settings
    google play's orders and settings
  3. Jase987

    Jase987 Member

    It's all working now. Stupid Me was trying use google play through Browser on desktop instead of Google Play on desktop.

    Everything Works Great. I have the PP4MT-9 and you instructions worked great.

    After install nandc and rebooting, I had no touch screen working. Luckily I could restore back nandc and continue with instructions.

    Google PLay and 1MobileMarket and GetJar all working together.

    Your guys are legends
  4. Ninjafrogv3

    Ninjafrogv3 Member

    Stupid Question, :S

    Where iam i typing the codes? CMD Prompt?
  5. styelz

    styelz Active Member

    Yep, use CMD Prompt, then type "adb shell"
    Once you have the shell running, type "su" to become the root user.

    To make things easy, I copy adb.exe, AdbWinApi.dll and AdbWinUsbApi.dll into C:\Windows\System32\ folder. This way you can just type "adb" from anywhere in CMD Prompt.
    Ninjafrogv3 likes this.
  6. Ninjafrogv3

    Ninjafrogv3 Member

    My cmd is showing C:\documents and settings\administrator> ??
  7. Ninjafrogv3

    Ninjafrogv3 Member

    Ok put them in system32. Can run shell@android but when I type adb shell it says deivce not found?
  8. styelz

    styelz Active Member

    Just to top it off.. Here is a sweet boot up animation, it replaces the ANDROID boot logo.
    Copy this bootanimation.zip file to your /system/media/ folder on the tablet.
    Reboot and say, oooh. nice. ;) hehe
    KomusoDroid and Ninjafrogv3 like this.
  9. Ninjafrogv3

    Ninjafrogv3 Member

    Only problem now is i cant find my device through it?
  10. Ninjafrogv3

    Ninjafrogv3 Member

    Before i type in adb shell, i cant type adb devices and get my device shown
    (20080411 device) but when i type it in after adb shell, i type it again and it cant find device and then when i type adb device, nothing...
  11. styelz

    styelz Active Member

    Once connected to the tablet, dont use adb inside the android shell.
    Here is what I type after using the "unlockroot" program.

    Open CMD window (my username is "pbp" on windows 7):
    Code (Text):
    1.  
    2. C:\Users\pbp> adb devices
    3. List of devices attached
    4. 20080411        device
    5.  
    6. C:\Users\pbp> adb push "c:\pendo-stuff\nandc-root.zip" /data/local/tmp/.
    7. 2388 KB/s (4197434 bytes in 1.716s)
    8.  
    9. C:\Users\pbp> adb shell
    10. shell@android:/ $ su
    11. shell@android:/ # dd if=/dev/block/nandc | gzip > /data/local/tmp/nandc-backup.dd.gz
    12. shell@android:/ # sync
    13. shell@android:/ # busybox unzip -p /data/local/tmp/nandc-root.zip | dd of=/dev/block/nandc
    14. shell@android:/ # reboot
    15.  
    When it's rebooted, here is what it should look like when you start adb.

    Code (Text):
    1. C:\Users\pbp> adb shell
    2. root@android:/ #
    This is root, by default.
    KomusoDroid and Ninjafrogv3 like this.
  12. styelz

    styelz Active Member

    One last thing to change. There is a bug in ICS SmartSync which causes your WIFI to be disconnected when the screen goes into sleep mode. There is a paid app (also free i think) called SmartSync Disabler which fixes this problem.

    Update: I've tested this app over the last few days, and it doesn't work :(
    Leaving the USB plugged in is the only way this thing will keep wifi alive.

    Apparently, this is fixed in ICS 4.0.4.
    This app called REGPON Wifi KeepAlive fixes the problem in 4.0.3. YAY!
    Ninjafrogv3 likes this.
  13. styelz

    styelz Active Member

    Tech Note:

    If you are having crashing issues and other strange problem. I have found that this can cause couruption on the nands. I did a check on them, and they came back as being clean. But when I forced a check, there were many errors.

    If you want to try this, you need to remount any nands that are "RW" to "RO" or install the CWM recovery image and boot into recovery mode (hold both + and - volume keys while turning the phone on and keep holding +/- down until the screen turns on, around 15 seconds). Once it has booted into CWM Recovery, you can use "adb shell" to connect and issue the following commands to do a file system check of the nands.

    Code (Text):
    1. e2fsck -fy /dev/block/nandd >/dev/null
    2. e2fsck -fy /dev/block/nande >/dev/null
    3. umount /cache
    4. e2fsck -fy /dev/block/nandh >/dev/null
    5. mount /system
    6. /system/bin/fsck_msdos -fy /dev/block/nandi
    7. umount /system
    8. reboot
    Ninjafrogv3 likes this.
  14. Ninjafrogv3

    Ninjafrogv3 Member

    Was able to do this and when i went to do the rest it still says that theres no device when i got to push the files (Which would be from gapps-ics?).
    And now, i cant even run anything in CMD promt. going to restart the lappy and see what happens.

    Starting to doubt ill get it to work:(
  15. styelz

    styelz Active Member

    Here is a LiveSuit Image with Full Root, CWM Recovery and GAPPS (UPDATED)
    It is a two part RAR archive. Download and extract the image file.

    Also, download LiveSuit Pack, extract and run LiveSuit.exe (this should install the driver for you).

    Use LiveSuit and load the extracted ".img" file (press the first icon).
    Make sure your tablet is off, and power and usb unplugged.

    Now hold the volume down button, keep it held down and plug the USB cable in and then tap the power button about 6-8 times (tap, tap, tap). Then let go of the volume button. Nothing will appear on the tablet, but your PC should be installing the USB driver and will eventally popup a box to start the process of writing the image.

    Follow the prompts and choose the "format" option so it wipes all your data.
    Make a backup first if you want to keep any data on the tablet.

    The fist time you boot the tablet, it will take a little longer to boot than usual, around 2 minutes.
    Subsequent boots take around 40 seconds.

    I have changed the boot logo and also the loading animation.
    Added latest Play Store, 1Mobile, plus REGPON Wifi (keeps wifi on during sleep), Documents to Go and YouTube.
    There is also a CWM Recovery image with adb access.
    Everything else is stock.

    The STOCK LiveSuit Image file is in comment #23.

    :party:
  16. Ninjafrogv3

    Ninjafrogv3 Member

    Success!

    Finally Done!, Got GAPPS, 1MOBILE and GETJAR WORKING Together!

    Thanks to everyone involved and a very special thanks to styelz, for everything you provided (Love the android start up :p) and for helping me over the last couple of days :).
  17. styelz

    styelz Active Member

    Updated Moded images with fixes -> HERE
  18. bushy73

    bushy73 Member

    After finally succeeding at rooting my Pendo, I attempted to flash the images put up by styles. Everything appeared to smoothely until the very end of the flashing process when a notification box with a yellow triangle "!"popped up. My pendo then appeared to reboot with a light glow in the display, but nothing else. It appears that it has rebooted, but nothing appears on the screen. I should mention that I have a 9.7 (PP4MT-9), but I didn't think that would make a difference. Can anyone help me? I will try to flash back to stock and hopefully that will work.
  19. styelz

    styelz Active Member


    You need the pp4mt-9 image, but I don't have one. I guess they would be the same except for screen size. Maybe it is just a matter of chaning the build.prop. I'm not sure though. Can You supply they stock nand dumps?

    Btw, You can still flash it again using livesuit, it's not totally bricked.
  20. bushy73

    bushy73 Member


    Thanks for your quick response. Unfortunately, I was so sure that I would have no problems just using the pp4mt-7 image that I did not back up the stock! Stupid I know. So unless anyone out there has it I guess I will just have to use it as a paper weight! :(
  21. Jase987

    Jase987 Member

    Hey bushy73,

    I also have PP4MT-9 now working with Gplay and other stuff. I will send you a link of my img if someone tells me how to get img off Pendo as I not sure how to. Detailed Instructions Please.
    bushy73 likes this.
  22. styelz

    styelz Active Member

    If you have "root" on your tablet you can dump the nands to an SD Card.
    Instert an SD Card into the tablet (if you don't have an SD Card, copy them to /data/local/tmp/ instead of /sdcard/), then login to adb shell and type:

    su
    dd if=/dev/block/nanda of=/sdcard/nanda.dd
    dd if=/dev/block/nandc of=/sdcard/nandc.dd
    dd if=/dev/block/nandd of=/sdcard/nandd.dd
    dd if=/dev/block/nandg of=/sdcard/nandg.dd
    sync
    umount /sdcard

    Then zip them up on your pc and upload to mediafire and post the links here. I will create a LiveSuit image from them and post back here.

    Cheers and good luck.
    bushy73 likes this.
  23. bushy73

    bushy73 Member

    Thanks. That would be awesome if you could do that.
  24. kaneelias

    kaneelias Member

    Hi Stylez,

    I have the 9.7" Pendo Pad running ICS and was able to obtain the original image file from Pendo to fix my bricked device using live suit. I have uploaded the image to mediafire in the hope you can use it to create a CWM, Root and GAPPS image for those of us on the 9.7 inch.

    If you need any other files to get this going, please let me know and I will see what I can obtain.

    Free Cloud Storage - MediaFire
    styelz likes this.
  25. styelz

    styelz Active Member

Loading...

Share This Page