How far can you push the LG GW620?


  1. billpayer

    billpayer Well-Known Member

    Hello guys,

    As the title says really, my wife has this phone on contract with T-Mobile, I have the HTC Legend on Vodafone and she is getting mighty jelous of the features/apps.

    I have read that some ppl are running Android 2.x and will probably try this for her, my worries are that I mess it up and end up with a bricked phone.

    I have a few questions to ask to make sure I'm looking in the right places

    1. Is the GW620 also called the EVE?
    2. Is the only way to upgrade the OS via ROOT?
    3. Can the phone be restored back to origanal state via a backup?
    4. What is Rogers?

    just for info

    Model Number
    LG GW620

    Firmware Version
    1.5

    Kernal Version
    2.6.27
    LGE@new1 #4

    Software Version
    GW620-V106

    I would really like to push this phone as far forward as possible, any pointers would be fantastic

    Thanks for reading

    Bill

    Advertisement
    :
  2. johnsolo

    johnsolo Member

    1) Yes, in Canada it's called the EVE in the UK it's called ETNA
    2) Visit OpenEtna to get the details on installation (via the Installation link)
    3) The phone can be restored, although I do not know why you would want to. The 2.2.X build from OpenEtna is great.
    4) Rogers is one the big 3 carriers for cellular service in Canada (Bell and Telus are the other two) - www.rogers.com
    billpayer likes this.
  3. billpayer

    billpayer Well-Known Member

    thanks for the reply, can anyone confirm this is the correct order to do things

    1.back up contacts (i'm presuming they can be added when froyo is installed)
    2.reset to Factory
    3.back up phone (if anything goes wrong I still have a working phone)
    4.root
    5.install froyo
    6.add contacts

    if im missing anything please let me know, I intend to update this thread as I go as a reference for myself and anyone else wanting to try this
  4. johnsolo

    johnsolo Member

    1) You should be using Google contacts, (turn on data sync in settings, should be on by default) when you wipe your phone and sign in with your google account they will be restored. That or you can use this to backup most of everything (but do a backup of your SDCard to your computer):
    Lookout Mobile Security - Android app on AppBrain

    2) Detailed instructions for installing the necessary software and upgrading your phone OS are here: Installation | OpenEtna

    3) Be SURE to download and put the google apps on your phone's SDCard (link on OpenEtna instructions page) so you can setup everything google (refer to this issue if it does not install: Issue 191 - openetna - Gapps does not install on reboot - Project Hosting on Google Code)
  5. billpayer

    billpayer Well-Known Member

    hmmm the more i read (while waiting for the 53.8mb file to download (40mins), the more complicated it looks, im already wondering what this means



    • Note: For windows, you need to add this to your android_winusb.inf in the android sdk usb driver in the [Google.NTx86] section for x86 or in [Google.NTamd64] section for 64bit windows:
      ;LG eve
      %SingleAdbInterface% = USB_Install, USB\VID_18D1&PID_D00D
      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_D00D&MI_01
  6. johnsolo

    johnsolo Member

    Yeah it does look complicated, it's not for everyone, having a development or IT background in general would help, but to your question, I did not have to make the edits to the file you are mentioning.

    That said once the Android SDK is installed, that file is located here (for Windows):
    C:\android-sdk-windows\usb_driver
    The filename is: android_winusb.inf

    and you just have to add those two lines if you are finding that your PC is not detecting your phone - like I said I did not have to do this. The trickiest part I found was hitting the spacebar on the phone early enough for fastboot to start (you should do it as soon as you plug in the phone, if you see the recharge animation, it's too late).
  7. billpayer

    billpayer Well-Known Member

    installed the android sdk and avd manager, its asking to do a few updates everytime i run the programme, ill just install everything it asks for


    backed up sd card to comp

    what does this mean, ive sen it twice now, ill have to look into this

    'As root/admin, do:'
  8. billpayer

    billpayer Well-Known Member

    android sdk and avd manager installed and fully updated

    disc image file downloaded and unpacked

    took out battery and connected usb (phone came on straight away,phone is in fastboot mode (space and enter) driver installed automaticly when connected via usb



    STUCK!!!
  9. johnsolo

    johnsolo Member

    Root, Linux, is the same as doing something as an Administrator in Windows.
  10. dufourjm

    dufourjm Member

  11. billpayer

    billpayer Well-Known Member

    im in the cmd prompt , having trouble with it got this far, just trying to copy whats in the video, no luck yet

    [​IMG]
  12. billpayer

    billpayer Well-Known Member

    had to add 'fastboot -w' to the last command line


    phone now says erasing 'usadata' - OKAY
    erasing 'cache' - OKAY

    guess theres no going back now, just gotta load the image file now i think
  13. johnsolo

    johnsolo Member

    To make things a little easier, try putting all of the files (fastboot, boot*.img and system*.img) into the tools directory.

    1) Go to the tools directory withing the SDK using CMD.

    2) From there (with the phone is fastboot mode, will look like a bunch of text at LG screen) run the command "fastboot -w" (no quotes of course)

    3) Next run the command "fastboot flash boot BOOTFILENAME.img" (replace with the version you are using)

    Hopefully that's successful (can't see why not if you have the files available).

    4) Run the command "fastboot flash system SYSTEMFILENAME.img"

    5) Make sure you have the google apps zip file on your SD Card (DO NOT UNZIP), just put it in the top folder (i.e. root).
    billpayer likes this.
  14. billpayer

    billpayer Well-Known Member

    ok and thanks for your help today,

    ive manegd to get to stage 2 in your order of things, i have a problem with stage 3 when i get this, not sure what to do, unless i download the file again, or maybe just unzip it again

    [​IMG]
  15. billpayer

    billpayer Well-Known Member

    seems im missing a file i think, im trying to write the system file img and not the boot file image, yup just checked and i only downloaded 1 of the 2 files...oops, should be plain sailing now
  16. billpayer

    billpayer Well-Known Member

    DONE IT YEHAAAAAA

    gotta say thanks to johnsolo for your input, very kind of you to help out, thankyou

    hope the wife is gonna understand how to use it now lol, im happy that ive managed it, time will tell if it was worth it. ill post back in a few days with an update

    no market oops, am i missing something, downloaded the google zip and placed it on sd card, rebooted, navigate to sd card and see the file but does not open, maybe needs unzipping and placed in folder?
  17. johnsolo

    johnsolo Member

    Np.

    I did the following because I was not able to see any google apps (mail, maps, market, voice search, etc), BUT when they do install it takes about 10 minutes to appear and sync:
    Issue 191 - openetna - Gapps does not install on reboot - Project Hosting on Google Code

    ---
    In my case the only things i have to do are :

    1/ On your phone open application named "terminal emulator"
    2/ type "su" and validate
    you should have a warning asking you if you want or not to provide root privileges to the terminal. agree.

    3/ type "cd /etc/init.d"
    4/ type "./15checkgapps" and wait for the script to finish.
    you will have an error on the end of the script after the unzip command. ignore it.

    If you wait a little gappz will appear on the menu as fast as they are setting up. (It can last more than 5 minutes for all the applications to appear)
    ---

    Let me know if this works for you.
    billpayer likes this.
  18. billpayer

    billpayer Well-Known Member

    yes worked a treat, just have to wait for the misses to come home for her gmail password and i think we should be good to go

    many many thanks, this site and the people on it are awsome
  19. johnsolo

    johnsolo Member

    One other thing, be sure to turn on WiFi/AGPS in settings for detecting your location for Maps.
  20. johnsolo

    johnsolo Member

  21. billpayer

    billpayer Well-Known Member

    just got the appbrain installed thanks for the tip

    just one more thing if I may, do you know if I can put the htc widgets on this phone?

    after looking through the menus and stuff I came across a whole load of apk files, some of them with htc in the name, i installed them but cannot see where they went to and am a bit lost here, would be nice to get the friends widget and the weather widget from htc
  22. johnsolo

    johnsolo Member

    Search through appbrain.com they have a ton of widgets you can send directly to your phone.

    If you installed widgets, just press home, then the main button (silver) to pull up the context sensitive menu and select Add, then Widgets and scroll through the list to add whatever you like.
  23. illm4tic

    illm4tic Active Member

    The debugging option doesn't come back up on my froyo anymore. So now I can't mount my SD card. How do I get it back.
  24. johnsolo

    johnsolo Member

    So you mean to say that going into Settings, Applications, Development, the option to turn on USB debugging in gone?

    What version of boot and system are you using from OpenEtna? Have you considered opening an issue on their project page?
  25. billpayer

    billpayer Well-Known Member


    Why did you hi-jack my thread?

    If you had read this thread properly you would have seen that I was keeping this thread going for reference, it was reading perfectly till you came along.

    anyway, phone is going great no problems at all, maybe a bit slugish at times but well worth putting up with
Loading...

Share This Page