[How-To] Force the Official Android 2.2 Froyo Update for the Motrola Droid (FRG22D | Update 2 of 2)


  1. starcr250

    starcr250 New Member

    I'm guessing there's a chance that you didn't place the new update.zip file in the root directory or maybe didn't delete the old one so you thought the new one was there. Just a thought.


    The update worked great for me. New flash player available, downloaded and installed.

    However, the new update did not fix the corporate exchange acct info that I and others had been having. Guess I'll have to keep using touchdown for now.
  2. OMJ

    OMJ Bazinga VIP Member

    For those interested in root. Some of our older root methods still work and the method for Rooting the Droid 2 works (its pretty easy if you have adb setup) I will probably put a guide on it together sometime over the weekend although I am sure the 1 click methods will be updated by then
  3. Maybe, but one of the purposes of this update was to close the one click root security hole.
  4. c4ducks

    c4ducks New Member

    I did move it as in step 3. I just did a search in the astro file manager for update and found only the one dated today in /mnt/sdcard/update.zip and /mnt/sdcard/download/update.zip. I really appreciate any help. Thank you starcr250! OK, I have did it all again except this time I used the computer and downloaded the file that way and did as instructed. Now it finally says FRG22D. Thanks for listening to the rambling!;)
  5. OMJ

    OMJ Bazinga VIP Member

    I tried the droid 2 method it works fine
  6. Weird. I'm not sure how that method works. It was reported that this update would fix the udev bug used by one click root: CVE - CVE-2009-1185 (under review)

    Maybe the droid 2 method does it a different way. It will be interesting to see how this plays out then. I was looking forward to this update so my droid would be more secure.
  7. OMJ

    OMJ Bazinga VIP Member

    I haven't had a chance to really look at the bin file from the d2 method but I read something about it basically being exploid backwards/reversed. I'm not quite sure how it works but I tihnks its very similar to the original exploid
  8. carassius

    carassius Well-Known Member

    Just manually upgraded using method 2 and went without a hitch...as did the first manual update thanks to androidforums!

    Also, I ran Quadrant and where I was getting 780-810 before I just got an 878. I am not sure if this is meaningful, though, with such a relatively minor update.

    Haven't checked for flash in the market cause I am pretty sure I already have the most recent version installed already.

    THANKS!
  9. EDIT: It looks like RageAgainstTheCage takes advantage of a bug in adb, and isn't related to exploid. One click root probably won't be back then, at least not any time soon.
  10. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Thanks for this - now I can finally refer people to this thread instead of telling them to get the file and then follow the original thread lol...
  11. thanks guys worked without a hitch and i searched for flash and it was there. good write up thanks agian guys
  12. Tenzen

    Tenzen Well-Known Member

    Couldn't change the file name. Asked if I wanted tlo overwrite the old file I hit ok and still didn't change it. Went throught the rest of the process as normal. Still got frg01b. What did I do wrong?
  13. Tenzen

    Tenzen Well-Known Member

    Please disregard that last post. Fixed it. Thanx
  14. Byf619

    Byf619 Member

    Is anybody getting a pop up when you try to download the update that says there are problems with the security certificates of the site? Im getting this and I am not sure if I should proceed or not.
  15. BLSCHMITZ

    BLSCHMITZ Member

    Sweeeeeet. Been waiting patiently since FRG01b install. Much smoother.
  16. carassius

    carassius Well-Known Member

    Yeah, I got that and just proceeded on with no problems.
  17. OMJ

    OMJ Bazinga VIP Member

    interesting....I glad they completely closed that hole then. That guy sure is fast at finding new root exploits
  18. SlowMovingTarget

    SlowMovingTarget New Member

    Just updated. worked fine! Thanks!
  19. PJnc284

    PJnc284 Well-Known Member

    You can also get root back by following the instructions here. Relatively easy process and it's nothing more than using rsdlite to flash sprecovery and then flashing an update.zip
  20. x026092

    x026092 Well-Known Member


    I did & proceeded. No problem yet.
  21. jbang42

    jbang42 New Member

    Went without a hitch.

    Thanks, guys!
  22. Poloki

    Poloki Well-Known Member

    I keep getting 'Download unsuccessful' is this because the servers are getting hit hard?
  23. OMJ

    OMJ Bazinga VIP Member

    I just checked and it worked fine for me although I am using a computer and not the droid.

    Do you have astro installed like the guide says?
    Poloki likes this.
  24. x026092

    x026092 Well-Known Member

    I used the droid & it worked fine.
  25. ian.alex

    ian.alex Member

    Can someone report on whether the update fixes known issues like wifi and battery use.

    Thanks.

Share This Page