1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

invalid package file...Support


  1. TonyG916

    TonyG916 Well-Known Member

    is the error message I receive when I try and download google earth from the market. Has anyone else received this error message; if so, did you manage to get it resolved?

    Advertisement
    :
  2. CountVlad

    CountVlad New Member

    This issue is a pain in the a$$! It happened to me 2 weeks ago and it was b/c i downloaded the .apk file for google earth b/c i was to impatient to wait for it on the marketplace. If you did, download astro file manager(it's free) and delete all traces of it from your SD card (look closely in all files) then go to settings>applications>manage applications and unistall google earth. Reboot phone. Attempt to download again. If unsuccessful or you never downloaded the .apk, then your only solution is to factory reset your phone. Trust me not as bad as it sounds, but before you do this, use astro manager to delete everything you can do without. (i recommend everything but your photos) Don't worry about the applications as those can be downloaded again, including the paid apps @ no charge (Google has a backup in place that recognizes your specific phone and what apps you paid for on the marketplace so when you search for it, you'll just be prompted to re-download) Next, settings>privacy>factory reset. This takes a minute or two and all you'll need to do after it's done is sync your device w/ Verizon's network (phone automatically prompts and dials, no speaking to anyone just technical mumbo jumbo) which can take 2-3 minutes. Then just set your homescreens the way you had them and download your apps. Google earth will work now 100% guaranteed if you went this route, i know b/c it's what i had to do. Good luck!
  3. necosino

    necosino Well-Known Member

    I had to get an .apk off of 4shared (or a torrent, but I think 4shared) to get it to work. But yes, it's a pain, but its also worth it.

    No factory reset is required :)
  4. CountVlad

    CountVlad New Member

    The reason i left my .apk (droid-life) is b/c the marketplace will not recognize that you have google earth, and thus, no updates. See for yourself, check the marketplace and it will not show up in your "installed" apps. It's worth resetting for that reason alone, and really only takes 45 minutes to get your phone back the way you had it.
  5. eug

    eug Member

    I had the same invalid package file message with Google Maps and Touchdown when i tried to update them. What worked for me was to delete the relevant apk file from /system/app *as well as* the relevant classes.dex file from /cache/dalvik-cache. Root Explorer is required for this, Astro will show /cache as being empty.
  6. superchaos

    superchaos Well-Known Member

    I had the same issue. It was fixed by uninstalling version 9 through the apps manager and then installing 1.0 I thought Google would be able to recognize their own software version to overwrite.
  7. -l3x-

    -l3x- Well-Known Member

    Worked great Root Explorer is worth the taxes :)
  8. sdrawkcab25

    sdrawkcab25 Guides Guide


    Es file explorer is free and has root access also.
  9. -l3x-

    -l3x- Well-Known Member

    Didn't find that cache. Unless their was a setting i didn't turn on. lol.
  10. sdrawkcab25

    sdrawkcab25 Guides Guide


    Yeah there is a hidden setting for it, and think it's a relatively new feature (last couple months)
  11. GenesisNemesis

    GenesisNemesis Well-Known Member

    I have done a factory data reset and even updated my tab to gingerbread but, the problem persists. However i have noticed that the smaller the app the more likely it is to download and install properly. The larger apps are the biggest problem.

    The conclusion i have come to is that dropping connection while downloading is the cause of this problem. It can not be the cache of the app as it occurs when i download an app i have never installed before.
  12. Lucyfr

    Lucyfr New Member

    It's the network!!! Are you using T-Mobile or a provider which 'piggybacks' off T-Mobile like Orange? Switch to WiFi and turn off the mobile network and you will probably find the updates run OK...
  13. GenesisNemesis

    GenesisNemesis Well-Known Member

    I am on t-mobile and it is the network. I have tried wifi but the download does not even start. I put it into gsm only and then the updates downloaded and installed. This has worked perfectly for me.
    If anyone else has this problem try this and tell us here how it goes.
  14. scottg07

    scottg07 New Member

    Im on T-Mobile (UK)... i have 3 android based phones in the house...none of which will download and install apps when on the T-Mobile network. All get the same error message package file is invalid, as soon as i switch to wifi i have no issues.

    I have cleared cache, remounted SD card even done a factory reset but still get the same error message.

    Is it T-Mobile or is it Android Market which is the problem? or both?

    and does anyone have any advice...as this sucks big time.:mad:


    thanks in advance
  15. sii777

    sii777 New Member

    I've got the very same problem too. I'm convinced it's the T-Mobile network.
    A temporary fix is to go to:
    settings > Wireless and network > Mobile network settings > Network mode
    .... and select GSM only.
    Make sure "Use packet data" is ticked under > Mobile network settings.
    You should now be able to download and update apps via GSM. It'll take forever, but it should work.
    Don't forget to re-enable GSM/WCDMA(Auto mode) when you've updated.
  16. TnIan

    TnIan Well-Known Member

    This may or may not be relevant to your situation, but here's what the deal was with mine. I have CyanogenMod 7.1 installed, which puts dalvik-cache in the /cache partition instead of /data.

    When you install apps from the Market, it downloads the .apk to /cache/downloads and installs it from there. If you don't have enough room in /cache/dalvik-cache for the installer to put the necessary files there, the install fails with a "package file is invalid" error.

    There's nothing wrong with the package file at all. It's purely a matter of not having enough space in your /cache partition.

    (forgive me if you see this exact same post in multiple places - if I'd known weeks ago that it wasn't really an "invalid package file" issue, it would've saved me a ton of useless googling - I'm just trying to spare others the same hassle)
    Andima likes this.
  17. scottg07

    scottg07 New Member

    my phone is not rooted can i do anything? cheers for the reply.
  18. TnIan

    TnIan Well-Known Member

    As far as I know, there's not much you can do except delete some stuff to free up space. Some people have had some success at moving their dalvik-cache to a partition on their SD card, but I'm not intrepid enough yet to give that a try (and you'd need to be rooted to do that anyway, I'm pretty sure).

    Wish I could figure out something - I've got 92 megs free on my phone, but I can't install anything because dalvik-cache has filled up the /cache partition.
  19. Bzegil

    Bzegil New Member

    Thanks, this works perfectly. I was getting the invalid package file message while trying to update google maps.
  20. Andima

    Andima Well-Known Member

  21. GenesisNemesis

    GenesisNemesis Well-Known Member

    You don't need a reset. Put the phone into GSM mode and the downloads install.
Loading...

Share This Page