It suddenly won't turn on?Support


  1. jjshamoon

    jjshamoon New Member

    I bought a new phone and restored my L9 to factory settings with my SIM card still in and empty 4GB micro SD (if the presence of those two matters). I didn't use it for a few days and the battery died. I had it charging for over a day and now it won't even turn on. I've tried charging with different cables different plugs. Whether I plug it into my PC or Mac there is no recognition of it. I've also tried doing the hard reboot (holding down volume down, home, power buttons). Any ideas?

    Advertisement
    :
  2. krkhns

    krkhns New Member

    I've got the same problem, except mine was fully charged. Woke up this morning and its dead. Tried a fresh battery, hard reset, etc. When I attach it to my PC the only thing that is recognized arde the OMAP drivers and they keep going in and out. One second it'll say working fine, the next second it'll say can't start the device.
  3. gmusetti

    gmusetti New Member

    I have the same problem please help! Do not what to do took it over to a shop and they didn't know what to do they couldn't help me
  4. xdrc45

    xdrc45 Guides Guide

    When installing the OMAP 4 drivers... You have to install the drivers on the first try and then reconnect the device to your PC again and then reinstall the drivers again a second time. using the same way you installed them . Open device manager on the PC run the lelus fastboot script and chose option 1 and when you see the notification on device manager you have to quickly right click on it before it disappears and choose update driver... Then then go through the process of reinstalling the driver again, the same way you installed it the first time. Now the unofficial fastboot should work.
Loading...

Share This Page