Jelly bean / Google music / bluetooth frustrations!!!Support


Last Updated:

  1. EvilBunny

    EvilBunny Member

    Before jelly bean (or possibly the last google music update?), Google Music would always start up and I could never ever ever prevent it from happening, even if I didn't want it to. That was irritating enough...

    Now... with jelly bean, Google Music will do the same thing, but as an added annoyance, I can no longer stream Pandora or Slacker radio.

    Before, I could just pause Google Music (because god forbid we be allowed to actually have a "stop" or "quit" button to turn the damned app all the way off) and start Pandora and it would work fine.

    Now... I start Pandora and the phone gives every indication that it is playing through the bluetooth, but I have no sound. Same with Slacker.

    The funny thing is... If I go back to Google Music (which works just fine over bluetooth), and start Pandora at the same time, it will play Pandora for a second or two and then pause everything. Still never allowing me to stream Pandora. Also of note... My bluetooth screen on my radio indicates that the song (that was playing from google music) is on but paused. That didn't happen before.

    I hope at least some of this made sense.

    I hope even more that someone out there can help...

    Advertisement
  2. EvilBunny

    EvilBunny Member

    bump... Anyone else having this problem?
  3. socobandit

    socobandit Well-Known Member

    did you fdr after the jellybean update?
  4. 330D

    330D From My Cold Dead Hands VIP Member

    Do you have a setting in smart actions to start music when headphones are plugged in?
  5. MxLockwood

    MxLockwood New Member

    After updating my Motorola Razr to Jelly Bean 4.1.2 both Pandora and Amazon play for 2 to 3 seconds and then no sound. But the Google music player works fine. This is the exact same issue that EvilBunny described.
  6. EvilBunny

    EvilBunny Member

    I finally got around to doing the FDR... and it DOES NOT fix the problem.

    Pandora acts like it's streaming but no audio. Google Music works fine.

    Again... one strange behavior to note is that if Google Music is playing and I start Pandora at the same time, Pandora will play for about 2 seconds then stop. If Google Music wasn't playing to begin with, I don't even get the 2 seconds... the audio just doesn't come through bluetooth.

    This was not a problem before the jelly bean update.
  7. EvilBunny

    EvilBunny Member

    No, it's not smart actions...

    Unless there is a setting out there someone knows about, jellybean has essentially disabled the ability to stream Pandora via bluetooth in the car.
  8. 330D

    330D From My Cold Dead Hands VIP Member

    I use spotify. I haven't had any issues streaming via Bluetooth... weird
  9. NICDON

    NICDON Member

    I am having the same problem. Cant stream Pandora via Bluetooth but Google Music works great. actually better. I even now have Tack and Title information on my car radio.
  10. dkaakd

    dkaakd Member



    Interesting, I noticed the same thing except I use Mixzing. I have a IS350 (2010) and it always bothered me that I could not see the MP3 tag info on my screen when BT streaming. Now that I have the JB update I can see the album, title and song name. However, Pandora does not show any track info.. Every works the same though.

    I guess it is the JB upgrade and not the MP3 software, but am not 100% sure.

    David
  11. TheBigTim

    TheBigTim Member

    I am having the same issue.

    Anyone have any ideas? Pandora worked great with ICS.
  12. Ssith

    Ssith Well-Known Member

    i listen to pandora via bluetooth headphones all the time.

    try resetting data on the pandora and bluetooth applications, it could flush out the problem.
    TheBigTim likes this.
  13. TheBigTim

    TheBigTim Member

    Ssith,
    Thanks for the idea. I tired that this morning. Still no sound. I have deleted the BT connection from the radio and repaired, cleared all the cache, renamed my phone under BT settings and still nothing. It worked great before the upgrade to 4.1.2. I can still make and receive calls and the internal music player works. It’s just navigation and Pandora that have no volume. Any other ideas?
  14. Ssith

    Ssith Well-Known Member

    did you FDR it after the upgrade? that will likely solve it. it's kind of an extreme measure, though it has other benefits as well. just back up your sms first, there are lots of apps on the store that will do it.

    and by reset the data, i meant going into the "application" section of system settings and click the "wipe data" button. it could be a setting you forgot, don't know about, or some switch that got flipped by accident. do that for both pandora and bluetooth.

    since nav is included, i'm thinking it's more a bluetooth problem than a pandora problem, but it doesn't hurt, other than having to re-enter your password.
  15. TheBigTim

    TheBigTim Member

    I will give that a shot. I just did a FDR about a week before the upgrade. It was a pain but I will try anything at this point.

    Before I do another FDR I will try to wipe the BT data too. I only wiped the data for pandora and that didn't fix it.

    Thanks!
  16. djclemon

    djclemon Well-Known Member

    Yeah I agree, I wld try wiping data maybe, also maybe delete Pandora and re download! I listen to both my Google play music and Pandora all the time since JB update threw blue tooth and haven't had any issues
  17. TheBigTim

    TheBigTim Member

    I wiped all the data (both BT and Pandora and google maps). No change.
    I did the FDR. No change.
    After playing with it for a bit I am not convinced that the play music app is the problem. I was able to uninstall the update for play music (I can’t uninstall the play music app because I am not rooted) and that allowed my Pandora to play through the car speakers, for a short time. After I re-installed the play music app update, now when I select BT audio on my cars radio is launches play music and starts playing it. Are there any controls to change that setting?
    Still have no way to play Pandora through my cars BT. The app runs but no sound.
  18. Ssith

    Ssith Well-Known Member

    i don't know what to tell you. as far as i know, nothing in JB should have caused this.

    were you EVER able to get a BT connection going in the car? like pre-JB, or with another phone?

    i know my car allows BT connections, but only for the phone app for some stupid reason. i can't connect pandora, but i can call people.
  19. SlowRideT140

    SlowRideT140 New Member

    I have a Razr and a Razr Maxx HD. Both worked perfectly with Pandora and Slacker in my 4Runner and Sienna before the JB upgrade. Interestingly enough, all that works now are phone calls and streaming media (mp3's) from the device with Play Music. I do have a Bose Soundlink and Jaybird headset, both of which continue to work perfectly.
  20. TheBigTim

    TheBigTim Member

    I am the seeing the same as SlowRide. It worked for phone, MP3, and Pandora before the update to JB, but now only phone and MP3.

    Ssith, it sounds like you may be having the same problem.
  21. NICDON

    NICDON Member

    Is there any solution to this problem in sight. I would really like to be able to play Pandora again. Especially since my XM radio expired.
  22. EvilBunny

    EvilBunny Member

    Okay... let's recap...

    Streaming Pandora (via bluetooth in the car) worked PERFECTLY before the JB update. After JB upgrade, it no longer works.

    Google Music works perfectly (actually better now that you can see song names displayed on screen in your vehicle's dash).

    FDR does not fix the problem.

    Google Music cannot be deleted (unrooted, can rooted users add to this discussion?). But I have uninstalled the upgrades, force stopped, and disabled this app... still does not fix the Pandora issue.

    One strange thing to note... If you are playing Google Music in your car and then you start Pandora (while GM is still running), Pandora will play for a few seconds and then everything stops. When this happens, your car display screen shows that the song you were playing on GM is now paused. No sound... Pandora still acts like it's playing.

    This is very frustrating for those of us who like to stream Pandora in our vehicles.

    JB has, essentially, disabled Pandora for us.
  23. Clambake12

    Clambake12 Member

    I am rooted and i froze google music (did not want to acutally uninstall, just did not need it). I use Poweramp and it works great with bluetooth streaming minus the fact that you cant pick or search songs from the unit.

    But i just found this problem out as well, i went to turn on pandora and it plays for a couple seconds through bluetooth and then stops. i have to reconnect my bluetooth to get anything back. But this could be user error. I probably should have stopped the music streaming source and then started pandora. I have a Pioneer x8500 that i am streaming to.

    Never gave google music a shot so cant say anything about it and bluetooth.
  24. NICDON

    NICDON Member

    I'm not sure if this is a solution for all...but I have found a little work around to this problem. I have started Pandora. (which will not play through radio Via Bluetooth) then hit home and select Google music from apps.(of course plays perfect and works great) Now I hit home again. Then I hit setting and manage apps. Scroll to running and first select google music and stop it. Sometimes Pandora will start sometimes not. Then I select Pandora from the running list and stop everything under it. I then restart Pandora and it plays fine. ( except screen on car radio is frozen on the last goolge music song title).
    TheBigTim likes this.
  25. VoidedSaint

    VoidedSaint Resident Ninja VIP Member

    what kind of car do you have?

Share This Page