Kernels; a question for the experts?!


Last Updated:

  1. guss606

    guss606 Well-Known Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    67
    Likes Received:
    1
    Hello again,

    I have FV1.5.0 installed on my unbranded GSM Hero, and I am curious about the Kernels. Which one should I install?

    The CPUSpeed app is set to Interactive: 123-576MHz. Sometimes it feels that it should be faster and it should run without heck-ups.

    Could you please help me with this?

    I am not expert about Kernels at all, so please bare with me :eek:
     

    Advertisement
  2. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,759
    Likes Received:
    8,894
    I'm not an expert, but you really don't need to know much about it in this instance. Basically the kernel included by default is not overclocked at all, so you need a better one.

    The speeds your phone can handle varies phone to phone, so you'll have to see which max speed suits your phone. Every Hero seems capable of 690MHz, so that's a good bet. Unless you're attached to boot animations, go for the one without.

    Put it on the sdcard, do a dalvik cache wipe, flash the new kernel and boot. In CPUSpeed set it to 123-Max on interactive for the screen on and the same frequencies on conservative for screen off.

    You can download them here.

    (I'm just in the process of flashing 1.5, so the CPUSpeed settings are based off how I assume it will work - Haven't set it up my self yet).
     
  3. stoney73

    stoney73 Well-Known Member

    Joined:
    Feb 22, 2010
    Messages:
    155
    Likes Received:
    9
    seems to be that the 'average' choice is the 691mhz kernel, which seems to be the kernel that most(if not all) heros can run. Some heros can run 729,748, or even 768, depending on when their phone was manufactured,etc.

    The safest will always be stock, but 352-691 on interactive gives a nice medium, without straining anything, whilst still giving some conservation of energy. As with most things, common sense etc. Make sure to set conservative for off-screen.

    1.5 sure is slick though, even on stock.
     
  4. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,759
    Likes Received:
    8,894
    Had to restart flashing 1.5 because I forgot to stop the market re-downloading my apps :mad:
     
  5. nedamdam

    nedamdam Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    385
    Likes Received:
    27

    haha :p me tooo :p 44 apps were downloading via edge :p

    Am seriously no expert :p but Xyro is soo right how it will work. So 123 min 691 max interactive and conservative when screen off.

    Wouldnt experiment with the 3xx setting. If the 123 wont work, it just wont wake up. So take out battery and boot again set it to some other setting. If you are worried a nandroid backup is always a good choice.

    What I noticed is that in conservative when I have something running like wifi or some background app the screen sometimes gets darker :) . Just that you arent scared if this happens to you (Scared me the first time, but Xyro was there to explain :) ) It doesnt happen when screen off on interactive only conservative :)

    On 1.4.4 I used the 614 kernel since the 691 got my battery warmer, this 1.5 I think the 691 is behaving nicer so sticking with that. Max I got was 748 but wasnt stable :)
     
  6. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,759
    Likes Received:
    8,894
    I get the purple screen bug when I have 123-690 on conservative :(. I wish I could specify separate speeds for when the screen's off. I might switch to SetCPU again, if I can still use the interactive governor.

    Whilst it's nice to be appreciated, are you sure that was me? :p
     
  7. nedamdam

    nedamdam Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    385
    Likes Received:
    27
    I think SetCpu is not an option. Got a lecture from Ninpo as I just mentioned it:p.
    As I tried it on the 1.4.4 had some trouble forgot which it was. Thats why I asked them.

    Even as I was trying the SetCpu on the 2.1 stock, I got mixed results. Sometimes it ignored the 122 entirely. (According to logs)

    And the purple screen. I get it only when I run Wifi or Lookout or something is in the background (Titanium backup) basically something in the notification bar, except the battery info pro that works for me.
    If its just the regular things it comes out of it nicely. LAST TIME I SAID THIS IT CAME! Will be angry if it does it now too!


    Yes was You click :D . That time you was green though I think a guide. Such a long time :p
     
  8. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,759
    Likes Received:
    8,894
    Yeah the VillainIRC makes me feel like a real android newb :p I wouldn't go asking questions in there... I guess I'll have to go for 350-690 all the time then.

    Well, I run screebl, tasker, juice defender and 3G watchdog all the time. Which would explain why it happens nearly every time :p

    Ahhh ok, I didn't realise you were talking about the purple screen bug too.

    But yeah, I got promoted last week :D
     
  9. nedamdam

    nedamdam Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    385
    Likes Received:
    27
    Well am after few kicks but not cuz I asked like a noob :p . And You dont have to go right away on this 350-690.

    Either go Interactive on sleep AND 123-691 that should help. OR try conservative on sleep AND 176(248)-691 if that doesnt help.


    Congrats ;)
     
  10. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,759
    Likes Received:
    8,894
    I'll try out a few setups and see how I go for battery power.

    At least if I had 350 as my minimum it would stop telling me it crashed every time I reboot the phone :p
     
  11. guss606

    guss606 Well-Known Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    67
    Likes Received:
    1
    Hi again,

    First, I want to thank you all from the bottom of my heart for this "interactivity" and the way you help and support people :p you guys are amazing. ;)

    SO, I installed the 691 Kernel without the boot animation, and I set it Interactive: 123-691 and Conservative when screen off, BUT I start to have the purple screen bug, so I changed it to Interactive when screen off and now i'm not having the purple screen -at least so far-. Is what I did good, or still do i have to do other things?

    I have another question please, Will the kernel effect my battery life, I mean will it last longer or drain faster?

    again, I can't thank you enough guys for all your support :)
     
  12. nedamdam

    nedamdam Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    385
    Likes Received:
    27
    This question I asked many times :p . On the IRC of the VillainRom :p . Or here. And the only thing everyone gonna tell you. Test it and you will see :) .

    As I wrote you up (or somewhere :p) Now I am on 691 and it seems nicer as it was on the previous ROM. There I had to use 614 cuz 691 got it too warm. And the general recommendation is to keep the temperature under 40
     
  13. guss606

    guss606 Well-Known Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    67
    Likes Received:
    1
    Thank you for the reply, I'll just keep it this way now and will see, but generally looks good.

    After each new ROM installation I do a Battery Calibration.

    I do not play games in general on my Hero, but I'll give it a try to see how it will handle it.
     
  14. Slug

    Slug Check six! Moderator

    Joined:
    Aug 1, 2009
    Messages:
    20,386
    Likes Received:
    16,492
    That's good to hear. First and foremost AF exists to help, so it's always nice to know it's meeting its "mission statement". :)

    It's not 'bad', don't worry. The conservative governor simply attempts to maintain the lowest-possible frequency whenever possible. To allow for this, try a slightly higher frequency as the minimum for "screen off" - my own Hero can't cope with anything lower than 176MHz without display corruption.

    I've not played with Ninpo's most recent kernel, but if it's anything like other recent Froyo ones (which is highly likely given that the devs all work from the same source code) then even overclocked to 691MHz it'll be more power-efficient than 1.5/2.1-based builds. Generally speaking the handset spends much of its time in "standby mode" i.e. screen off and idling, and only kicks up to full speed when required.
     
  15. guss606

    guss606 Well-Known Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    67
    Likes Received:
    1
    Now I set it as Interactive "screen on" 176-691MHz and Conservative "screen off" and it's running without any issues. :D

    Thanks Slug.
     
  16. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,759
    Likes Received:
    8,894
    The question of whether to go really low with interactive on screen off, or not so low with conservative on screen off is the problem I have too.

    I'll just have to try them both out.
     
  17. guss606

    guss606 Well-Known Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    67
    Likes Received:
    1
    GOOD MORNING :mad:

    EVERYTHING was working perfectly yesterday, this morning, I had really bad problems with my phone that i really started to hate myself :p

    The phone rebooted by itself few times. and I have the Purple bug again, I recieved few phone calls and it drove me crazy, the phone ring and vibrate normally when i recieve the call, and when i pick up and keeps on vibrating continously for about 15 seconds with only the lock screen on the display.

    What would it be? could it be the Kernel?!

    FYI- I'm running 691MHz Kernel and it's set to Interactive: 176-691MHz "Screen On" and Conservative "Screen Off".

    HEEEELLLPPP PLEAAASEEE :confused::confused:
     
  18. nedamdam

    nedamdam Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    385
    Likes Received:
    27
    Go interactive on screen off - sleep . This is well known. Nothing wrong with the kernel or anything. Some phones just wont wake up when the frequency is set to low. Either go 248-691 or Interactive 176-691 OR both :) or Interactive 248-691.
     
  19. guss606

    guss606 Well-Known Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    67
    Likes Received:
    1
    Thanks for your reply, :)

    I've set it to Both Interactive 246-691. I'll see how it goes.
     
  20. nedamdam

    nedamdam Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    385
    Likes Received:
    27
    You could even try interactive 123-691 and call yourself or if you get the purple bug.. The interactive governor doesnt have to be switched to and the CPU has more time to adjust the SPEED. So even 123-691 MIGHT work :) .

    So interactive 123-691 . Go into sleep. usually 5 seconds should be enough. (Some test it after an half an hour...) And call yourself from some other phone.

    The preference between conservative an interactive is , that conservative should underclock faster. But in the long run like at night. It should have the same effect. And it should be more responsive on both settings interactive.
     
  21. guss606

    guss606 Well-Known Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    67
    Likes Received:
    1
    Worked fine. iLikes :D

    I'll see IF i'll have any issues i'll go back to Both Interactive 246-691 because it worked like a charm.
     

Share This Page

Loading...