1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support LG Optimus Black P970 Won't Connect To Computer!


  1. Daniel12327

    Daniel12327 New Member

    Hey, maybe a week ago or two ago I got a new a LG Optimus Black P970. When I first plugged it into my computer I had to set it up of course, but after that, whenever I tried connecting the phone to my computer it wouldn't work. I have tried everything. I have tried downloading the drivers, i have unmounted and mounted the sd card. I have selected and deselected both debugging mode and mass storage and none of it worked. Could you please help me? Thanks...By the way I am running Windows 7.

    Advertisement
  2. Callistus

    Callistus Active Member

    Have you tried turning the phone off, pulling/re-plugging the battery, then turning it back on and finally plugging it to the computer's USB port?
  3. cpoticha

    cpoticha Member

    Used to work fine. Now it doesn't.

    I've read half a dozen threads from LG users (many different phones) with the same complaint.

    To make matters worse, I have a Mac, so the whole PC-Suite and "SmartShare" options don't work either. I just have to transfer music and photo files via Bluetooth or to a dropbox in the cloud.

    Annoying that such rudimentary connectivity is so buggy.
  4. Lenny25

    Lenny25 New Member

    Same problem here :mad:
  5. volitans

    volitans Member

    Sadly no-one seems to have an answer. My wife & I both have P970's (we always get identical phones so we can cross check & learn from each others phones). Now she has the above mentioned problem.
    When we plug in her USB cable the phone shows the "charging battery" icon (ie a flash in the battery) but the USB icon is not displayed in the top notification area (as it is in mine (and was on hers previously)) and we cannot get her phone to connect to any PC or laptop. We have several USB/phone cables.
    I've tried to connect via Wi-fi but that only lets me use my router as her modem/internet access. I tried downloading LG-PC Suite for Mobiles direct to her phone but the 'set up' file is a .exe file that the phone doesn't recognise.
    Tried bluetooth without success.
    I am now completely stumped.
    My last resort is a factory reset (losing all her data) but I am yet to find out how to do that. I'm hoping I'll find it in these forums somewhere.

    Cheers
  6. eedgar356

    eedgar356 New Member

    Factory Reset= settings....>Privacy.....>Factory Data Reset
  7. WillyTheWaiter

    WillyTheWaiter New Member

    might be a bit late - had the same issue.. used to work then just stopped.

    today I just went into the 'sd card & phone storage settings'

    under 'USB storage only' ticked the 'usb connect mode is mass storage only' and hey presto I can now browse to my phone again from my pc via USB like I used to be able to.

Share This Page