Names of some contacts reversed on Droid even after syncSupport


Last Updated:

  1. verydroid

    verydroid New Member This Topic's Starter

    Joined:
    Jan 8, 2010
    Messages:
    2
    Likes Received:
    0
    I use gmail contacts and synced them with the Droid (A855). The problem is that some contacts show up with their given and family names reversed on the Droid. For example, in my gmail contacts list I have listed "Doe, Jane." On my Droid, even after a sync, it shows up as "Jane Doe." Most curious is that this only happens for a few names (3)! Everyone else shows up exactly as I listed them on my gmail contacts. I researched this and ruled out a few things.

    I added a "Test, First" contact to gmail, synced on droid, it shows up the same way on the Droid. So, the sync is working.

    I deleted all my contacts from the Droid and started a fresh sync with gmail. Same names were reversed.

    I edited those contacts to make sure the given and family names were listed correctly. No change.

    I considered whether the order of someone's name on facebook was affecting the Droid contacts listing, but it does not happen to all the facebook names.

    I went to Contacts, Menu, Display Options and checked to make sure that my gmail contacts were checked to display all names and that facebook account ones were not. No change.

    For those problem names, I made sure there were no other contacts with duplicate phone numbers.

    I tried a few other things, but now I forget what else . . .

    Any one else run into this or have any ideas? I know I can search on the names for a short solution and it doesn't really matter what the order is, but (1) I like consistency and want the same list on the Droid as on gmail and (2)I want to know if this is an indicator of a bigger issue.

    Thanks.
     

    Advertisement
  2. magnus

    magnus Well-Known Member

    Joined:
    Dec 8, 2009
    Messages:
    204
    Likes Received:
    1
    Its usually an indicator of wrong text entry...somehow.

    What you can do is go to google contacts on a desktop. ....export it as a csv. Open in Excel. Make edits the way you want for the whole database. You'll need to make sure that there are no commas and that all names are in the right fields.
    I vaguely remember an issue with the google database NOT identifying the comma as a separator between names.....but rather fills 'Doe, Jane' as given name....or something similiar.

    Anyway...do what I suggested and you'll immediately see what's wrong.


    I had a rather complicated database coming from a RAZR before....but do this. Then import that csv back into google contacts.

    It should sync automatically and flawlessly to your phone after

    Hope this helps
     
  3. (G)

    (G) Well-Known Member

    Joined:
    Dec 16, 2009
    Messages:
    746
    Likes Received:
    47
    I had this happen to me when my Verizon rep initially got my contacts off of my Palm Treo and put them into my Droid. Turns out I had MULTIPLE instances of the same name for some contacts, which got filed under one or the other. When I went to JANE DOE and scrolled down on her contact info, I also found DOE, JANE on the same "page" with the same phone number, address, etc.

    I solved it by using the "SEPARATE" (I think that's what it was called) option from the menu, which then turned them into two separate contacts, and deleting the inconsistent one.
     
  4. magnus

    magnus Well-Known Member

    Joined:
    Dec 8, 2009
    Messages:
    204
    Likes Received:
    1
    Ah...that's a likely possibility as well
     
  5. messenger13

    messenger13 Well-Known Member

    Joined:
    Dec 8, 2009
    Messages:
    3,133
    Likes Received:
    381
    Werd! :cool: Excel is such a great tool to manage your Contacts. (For those that can't afford MS Office, download and install Open Office, ... their version of Excel is called "Calc".)
     
  6. verydroid

    verydroid New Member This Topic's Starter

    Joined:
    Jan 8, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks for the input everyone.

    (G), I don't think I have more than one page. I had already gone through and merged the different pages. Also, I can't find the "SEPARATE" or similar function to test it.

    Magnus, I exported the gmail contacts to an excel file and the contacts are a mess. Most of the last names were listed under the column "First Name" and some first names under the last column or middle column, etc . . . I am not great at Excel so not sure what I did wrong. I exported as csv.
     
  7. (G)

    (G) Well-Known Member

    Joined:
    Dec 16, 2009
    Messages:
    746
    Likes Received:
    47
    I think it only shows up if you have two contacts on one "page" because the system has merged them. For example, I had a Pat Smith and a Smith, Patty as two different entries, both with the same phone number. Android was "smart" enough to merge them. At that point, under "SETTINGS" there was an option to "separate contacts," which I did, and it gave me two different file entries, and that's when I deleted one.
     

Share This Page

Loading...