One click Root!


Thread Status:
Not open for further replies.
  1. new optimus

    new optimus Well-Known Member

    I ran this on a brand new phone, it was just delivered this afternoon, talk about awesome timing thank you.
    It worked first time no problem, the instructions are so easy a blind man can do it.
    I left the SD card OUT I think that may help anyone that is having trouble.
    When you run this do not be fooled by it saying error shabbypenguin is not a ... what ever the rest of it said, just keep hitting "anykey" when it tells you to.
  2. gu1dry

    gu1dry New Member

    I was trying to get Deca to get the Shift when he picked up his new phone. CM on the NS4G could use Deca's support though.

    My buddy (who also had a HeroC as long as me) just picked up the NS4G & is loving it. I'm tossed between the Shift, NS4G (wasn't considering it till mu buddy gone one) or the SGS2 when it comes to Sprint, but I will require CM support, which is unknown at this point with the SGS2 phones...
  3. interdpth

    interdpth Well-Known Member

    Video by 8 PM central. >_>
    hammer422 likes this.
  4. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    nah nemith has joeykrim, netarchy and spiicytuna all helping. afaik the only things need to be done are make a cm7 kernel for it (they currently use the aosp based one from google) 4g toggle, and sprintmenu.apk

    the sprint within seems very promising but due to unseen events i was forced back to my heroc without an sdcard.. it was just torture :p hence why i didnt just wait it out for the nexus 3. the shift is a good phone but honestly at this point i wouldnt consider it much of an option, you know toast is going to get cm on the evo3d ;) the ns4g has what honestly could be considered a stable. who knows tho with the new developments on cm7 on the epic i wouldnt be surprised if cm supported the sgs2 fully due to the rising samsung devs


    carben i told you to stop spamming earlier.. if you cant figure out a 1 click or on how to click on the link in my sig that says prevail then you really prolly shouldnt be rooting...
  5. teddyfisk

    teddyfisk Member

    ok im new too i have wanted to root this phone sence day one i dont know much but i am retarted you can say ok i got windows 7 and i have pda net installed on my phone ok that mean i have download somthing from samsung to my computer to make it work... ok what is my next step with windows 7 i have my phone on debugging now what do i down load please help i will donate fast
  6. teddyfisk

    teddyfisk Member

    ok my computer will not let me open the link you put something like holy living **** how can i do this root please
  7. gu1dry

    gu1dry New Member

    As far as I know the only official maintainer for the NS4G was Koush, I can't been told otherwise from the powers above. Toastcfh will only be able to get CM on the E3D is the bootloader is unlocked, and really I wouldn't want the E3D, or as I call it, the super clown phone. Keeps comments about the Epic, the SGS2 & CM to self....
  8. Flame3

    Flame3 Member

    Thank you all for telling me, wow I can't wait to see what this phone can do been so long since I had to root a phone I rooted the hero when it came out
  9. chrisinsocalif

    chrisinsocalif Well-Known Member

    You dont need a video for this.

    -Download and install the Samsung USB drivers for your computer.
    -Put your phone in USB debugging mode - settings>applications>Development>USB debugging
    -Unmount and remove SD card
    -Download and unzip root files and run the .bat file
    It will go through the process to root your phone. If it doesn't work, reboot the phone and try again.
    **May take a number of times before it works**

    Not sure your phone is rooted?
    To check if your phone is rooted, download "Root Checker" from the android market
    Root Checker

    Download superuser after your phone is rooted to Grant and manage Superuser rights for your phone.
    Superuser

    Use Titanium Backup to backup and uninstall unwanted apps (be sure you don't uninstall the wrong apps)
    Titanium Backup

    Google is your friend.
    deleoncd4, Neondale, joeykrim and 3 others like this.
  10. blue2107

    blue2107 Well-Known Member

    Has anyone had 3g issues after root? I have gotten deadfully slow speeds. So I did a factory reset with no change. Any sugguestions.
  11. Necrotoxin

    Necrotoxin Well-Known Member


    That's not from rooting. The boost 3g network is spotty at best. Even before I rooted my phone it would run fine then go incredibly slow then fine again then slow.
  12. teddyfisk

    teddyfisk Member

    killing me softly is not coming up and help
  13. blue2107

    blue2107 Well-Known Member


    Yes I'm aware it is not that great but it now takes more than 45seconds just to load the plain ol' google search page.

    And this is from my home where it has been decent since the day I got the phone.
  14. novox77

    novox77 Leeeroy Jennnkinnns! VIP Member

    I deleted all of your subsequent posts (all asking about making a video on how to perform this root). Your posts are not helpful and are disrupting the thread. Please don't troll. Consider this an official warning.

    I've deleted some of the responses to carben24's posts to keep the thread clean. PM me if this becomes a problem again.
    Necrotoxin likes this.
  15. Kurstnelson

    Kurstnelson Member

    i cant get the usb drivers to install on my comp. advice please
  16. Flame3

    Flame3 Member

    I thought everyrthing was ok yesterday until I realized I don't know the command the file is on my desktop
  17. Necrotoxin

    Necrotoxin Well-Known Member


    Cd to your desktop then
    chmod <filename.sh> 777
    ./<filename.sh>
  18. haris163

    haris163 Well-Known Member

    I am new to Android, sorry if this is obvious, is it possible to return a phone to its factory state (as shipped) after it is rooted? Even if some applications are deleted while it was rooted?

    Thanks,

    Haris
  19. junx

    junx Well-Known Member

    anyone figured out what is ok to uninstall yet?
    first android and i'm afraid of uninstalling something needed right now..

    also, thanks a lot to the op and whoever else was involved.

    uninstalled the following and havent had a problem...yet...:
    home screen tips 1.0
    layar 4.0.5
    scvngr 3.5.7.spr
    telenav gps navigator 6.1.6201406
    twidroyd 5.0.4
  20. RRSpikes

    RRSpikes Well-Known Member

    Easy as pie! Thanks.
  21. barrettf

    barrettf New Member

    Thanks! I rebooted before running the .bat file and had no problems.
  22. barrettf

    barrettf New Member

    My works the same as it did out of the box.
  23. DKeathley

    DKeathley New Member

    I keep getting this when running the prevailtoexistence.Bat file:


    PLEASE REMOVE SD CARD PRIOR TO USE
    PRESS ENTER WHEN DONE
    You need to enable usb degubbing first
    Press any key to continue . . .
    * daemon not running. starting it now *
    * daemon started successfully *
    193 KB/s (6143 bytes in 0.031s)
    reboot: Operation not permitted
    [*] CVE-2010-743C Android local root exploit (C) 2010 743C
    [*] The Android Exploid Crew Gentlemens club - dominating robots since 2008.
    [*] Donate to 7-4-3-C@web.de if you like
    [*]Modified by interdpth for the prevail and possibly other phones
    [+] Found prop area @ 0x40000000
    [*] : 0
    [+] ro.secure resetted to 0
    [*] Restarting adb. Please reconnect for rootshell (adb kill-server; adb -d shel
    l).
    Wait for phone to reconnect...
    * daemon not running. starting it now *
    * daemon started successfully *
    mount: Operation not permitted
    161 KB/s (4292 bytes in 0.026s)
    Copying files onto phone...
    failed to copy 'su' to '/system/xbin/su': No such file or directory
    failed to copy 'Superuser.apk' to '/system/app/Superuser.apk': Read-only file sy
    stem
    failed to copy 'busybox' to '/system/xbin/busybox': No such file or directory
    failed to copy 'remount' to '/system/xbin/remount': No such file or directory
    Setting permissions...
    Unable to chmod /system/xbin/busybox: No such file or directory
    Unable to chmod /system/xbin/remount: No such file or directory
    Unable to chmod /system/xbin/su: No such file or directory
    Unable to chmod /system/xbin/su: No such file or directory
    link failed Read-only file system
    Installing busybox...
    /system/xbin/busybox: not found
    Cleaning up files...
    reboot: Operation not permitted
    "You should have root!"
    Press any key to continue . . .

    I do not Have root though and I have the sd card unmounted and removed...Thanks
    and I have tried rebooting and closing non essential programs

    Update: Nevermind..Teach me to not read all the way down to the bottom of the readme file
    All I had to do was reboot and open the .bat file while the samsung logo was on the screen...Thanks
  24. wyllem

    wyllem Active Member

    this was simple nice ok Ladies bring on the roms :D
  25. AceKing721

    AceKing721 Member

    Worked perfect! Thank you!!
Loading...
Thread Status:
Not open for further replies.

Share This Page