Play Store stuck on Downloading - Galaxy S III


  1. Green Airplane

    Green Airplane New Member

    Hello, I'm new to Android, just got my first one yesterday. Right off the bat I'm trying to tackle a problem.
    I may be an Android newbie, but I'm also a software developer, so feel free to get technical with me.
    I got my Galaxy S III yesterday. It says it's Android 4.0.4
    there is no SIM card in it yet, because I've also switched operators and I'm now waiting for my phone number to be transferred and the new card to be activated. I can't put my old SIM card inside, because it's the original format, which is bigger.
    So I'm connected through my WiFi router, I have a decent speed aDSL, both browsing and YouTube app work great on the phone. I've also connected to my gmail account without any problems.
    The problem, as the title suggests, is with the Play Store. At first it seems to work fine, i.e. I can browse the apps, preview screenshots, and so on. But when I try to download an app, it just gets stuck. It doesn't freeze up or anything, but the app is eternally stuck in the downloading phase.
    I've only tried this with two apps, both free. One of them is about 3.65MB, the other is 1.33MB, so they should have been downloaded in a matter of seconds.
    Instead, what happens is the app keeps 'downloading' for tens of minutes, and then I get an error. first time I tried I got this:
    "App Name" could not be downloaded doe to an error. (500)
    every other time I've tried so far I got this:
    "App Name" could not be downloaded doe to an error. (495)

    Things I've already tried with no result:
    Cancelling and restarting the download
    Killing the Play Store app through application manager and starting it again
    Clearing the Play Store app's cache through application manager
    Clearing the Play Store app's data through application manager
    Uninstalling the updates for Play Store app through application manager
    Rebooting my phone
    Resetting my phone to factory defaults

    I've also tried gauging if the Play Store app is downloading by looking at the size of it's cache (as I presume that's where it stores ongoing downloads) after I've cleared it and tried downloading again. Right after I start the download, some data usually appears in the cache, something like 645KB, or 1.04MB, or some such number. But it doesn't go up from there in any number of minutes.
    I have no idea what to do next, so any advice would be appreciated.

    Thank you in advance.

    Advertisement
  2. drowe

    drowe Well-Known Member

    Found this in another post, might be worth a try...

    go to setting --> mobile network --> APN --> clear the Proxy (make it blank)
    and then go to Play Store and download the apps you want
  3. annebrooks64

    annebrooks64 Well-Known Member

    This may be a stupid question or even a stupid question but have you checked to see if the play store is linked properly with your gmail account? If it isn't you probably won't be able to download anything.
  4. Green Airplane

    Green Airplane New Member

    Hi, thank you for your reply, but when I try to access Settings -> Mobile networks, I get a message that says "Insert SIM card to access services"
    As I stated in my original post, I don't have a SIM card in the phone yet, I'm trying to download via WiFi, so mobile network settings should in my (as of yet rather uninformed) opinion not be a problem.

    Small update:
    I found out that the version of my Play Store app was 3.9.16.
    I searched for the latest version and found out it's 3.9.17 (actually released yesterday). I downloaded the .apk from androidadvices.com, and installed it. Other than the version of my app now saying 3.9.17 instead of 3.9.16, no change.
  5. annebrooks64

    annebrooks64 Well-Known Member

    You should be able to access the play store on WiFi if your phone is linked up to Google via gmail. Check on the play store as I said above to see if your account is linked to it. Also check in phone settings under accounts to find gmail and try syncing it.
  6. Green Airplane

    Green Airplane New Member

    Yes, my Play Store is linked to my google account. And I can access Play Store. I can browse and search for apps. It gets stuck during the downloading phase. I appreciate you trying to help, but I've provided a very detailed description of my problem in the original post, in order to avoid getting advices thay I've either already tried, or are irrelevant to my situation. This kind of back and forth clutters up the thread and discourages the people who might actually be able to help from reading it.
  7. Green Airplane

    Green Airplane New Member

    Alright, this one is solved. The problem was in my WiFi router's settings. Play Store works fine over 3G as well as other WiFi networks.
  8. yokarin

    yokarin New Member

    May I ask how you solved this? I'm having this same problem. What settings did you change for your wifi router?
  9. gnr319

    gnr319 New Member

    Hi, All:

    I've recently switched to Android and I have the same problem with my Galaxy Note 2. Any help on what I need to change on my router is greatly appreciated!

    Thanks!
  10. alexasthoma

    alexasthoma Member

    If it isn't you probably won't be able to download anything.[​IMG]
  11. tjillett

    tjillett New Member

    I hope this helps a lot of you.. So I had the same problem as so many of you have stated and was at my witts end.. I received many emails from Google Play store as well as many other forums and finally after reading this one a lightbulb went off.

    So I just switched from Tmobile to Sprint.. When I was with Tmobile I had a plug in signal booster since I live in a little of low land, So when we switched to sprint I wanted the same.. Well sprint is a little different which offers the Airave which works really well,, but the instructions are to go from Modem to airrave to wireless router..

    This will screw up your wireless network and wired network as you will find many things that just dont work..

    Back to my 3 / 4 weeks of no Google play on my phone or my multiple tablets in the house..

    Just a few minutes ago switched to Moden, Router, airave and bang I'm back up and running..

    I tried everything else prior to this and nothing worked, for those of you who I helped I'm glad for those of you who are still having google play issues. Please email them as they may be able to help.

    Thanks
    Ted

Share This Page