[Recovery][CWM] Fully working CWM recovery with nandroid and everything!


  1. chui101

    chui101 Member

    ClockworkMod Recovery (Unofficial)​

    Finally we have fully functioning CWM recovery for the T-Mobile MyTouch Q, also known as the LG C800! After many said it couldn't be done... here we are!
    [​IMG]
    How to Install
    0. Prerequisites
    You will need:
    - Root. (Use SuperOneClick root)
    - ADB and fastboot (http://dottech.org/downloads/adb_fastboot_and_other_tools.zip)
    - LG's ADB drivers, available here.

    1. Back up your old recovery!
    Open up a shell on your device by using adb shell or running your terminal emulator.
    If you see a $ prompt, type
    Code (Text):
    1. su
    to get root. Otherwise if you see a # prompt you are ready to proceed.
    Type
    Code (Text):
    1. dd if=/dev/block/mmcblk0p17 of=/sdcard/stock-recovery.img
    to write the stock recovery to your sd card. This will take about 8 MB of space.

    2. Prepare the phone for future awesomeness

    First, we must get the device into fastboot mode. In order to do this you must be able to have ADB access to the device. ADB is accessible when you are on the charging screen and in stock 3e recovery. You can also enable ADB access in the Application settings while your phone is fully booted.

    Get the phone to the charging screen, stock recovery (see directions below), or enable ADB in the OS. Now, plug in the phone and verify you have adb access from your computer:
    Code (Text):
    1. adb devices
    If your phone is not showing up, go into device manager and make sure the LG ADB drivers are properly installed.

    Once you have ADB access, run this command on your computer:
    Code (Text):
    1. adb reboot bootloader
    This brings the device into fastboot mode. What does fastboot mode look like? Well, it looks like a whole lot of nothing, mainly. If your phone boots up at this point and hangs out at the LG logo for a while, you're in fastboot mode. To verify it's in fastboot mode, run
    Code (Text):
    1. fastboot devices
    it should show something like

    Code (Text):
    1. C:\androidsdk\platform-tools\> fastboot devices
    2. ?               fastboot
    If you see this, you are ready to flash!

    3. Flash!

    To flash, first run

    Code (Text):
    1. fastboot erase recovery
    This erases the recovery partition and ensures that everything is zeroed out so nothing gets in the way.

    Now run
    Code (Text):
    1. fastboot flash recovery C:\Path\to\downloaded\cwmrecovery.img
    protip: Tab autocompletes. It saves a lot of key strokes if you have a lot of long folder names like I do!

    It should almost instantaneously transfer the recovery image, and pause just a few seconds more to write the CWM recovery image. When done, you can type
    Code (Text):
    1. fastboot reboot
    to reboot the phone back into the main OS.

    4. Reboot into recovery!
    To reboot into recovery:

    - Issue an adb reboot recovery from your computer wherever you have ADB access (charging screen, stock recovery, or the main Android environment if you have it enabled there.)
    - Or, from the phone's powered off state, hold down VOL DOWN, F, and A, and press the power button. Once the LG logo appears, you can release the power button. Once the LG logo disappears and reappears, release all the the buttons.

    Welcome to CWM recovery! You can take a nandroid backup, mount USB storage, and flash zips from here! Hopefully this opens the door to CM9 and other custom ROMs on this device!
    Buttons are:
    VOL+ = up
    VOL- = down
    ENTER = select
    DEL = back
    POWER = screen saver mode

    Note: If anything goes wrong, you can return to stock recovery by using
    Code (Text):
    1. dd if=/sdcard/stock-recovery.img of=/dev/block/mmcblk0p17
    If you need the stock recovery image it is available here (zipped, but NOT for use in CWM).

    Stock Stuff to Flash from CWM
    Stock /system image bloatware and CarrierIQ removed.
    Download Link 1

    Stock Baseband
    Download Link 1

    Thanks to:
    misterfamilyguy for getting the ball rolling
    vtinoc for getting the ball rolling again
    mudtub for helping build all those recovery images and deodexing

    Attached Files:


    Advertisement
    tolski316 and Freddy1250 like this.
  2. mudtub

    mudtub Active Member

    Some information is left out.
    Hold down 'HOME' from *any* device to open fastboot and flash.

    Using fastboot is highly recommended, dd doesn't zero out data after what is written. Stick to this method, it works 100% and fewer failures can occur.

    Was this my build of CWM? :p
  3. chui101

    chui101 Member

    No, but I looked in the queue and I think we built pretty much at the same time, lol.
  4. vtinoc

    vtinoc Member

    all is working the cwm the backup and such thank you both for this work.
    tested and restores but since i used the KDZ file V10D for C800G
    mine is c800VL i messed up my gsm somehow i thought this would fix it but i was wrong well i guess all i need is a baseband or someting to fix it.
    any ideas would help.
  5. strumcat

    strumcat Member

    You just need to find someone with a freshly rooted but otherwise unmodified C800 who will let you install CWM, do a nandroid, and reinstall stock recovery. Then restore the nandroid to your phone. I'll do it, but I've deleted the two games, tetris and bejeweled, and killed Carrier IQ. Other than that, it works fine and would get you up and running again.

    And CONGRATULATIONS MUDTUB AND CHUI101! GREAT WORK! And misterfamilyguy, who started the whole thing, and vxbinaca, who got the ball rolling again, and vtinoc, who tested it. You'll all be legends!

    BTW, I forgot to do a backup of my stock recovery before I installed CWM. Can someone upload a copy to Mediafire, 4Shared, wherever? Thanks.
  6. mudtub

    mudtub Active Member

    If not that, you can reflash using the update utility. They were talking about it in the original thread.
  7. vtinoc

    vtinoc Member

    I have 2 c800 well my girl does I broke this one and brought her an other one working did a nandroid backup on hers and restored on the old one it don't not work and used the updater and it says no update for your phone.
  8. strumcat

    strumcat Member

    The updater utility would probably work if we had the V10D_00.KDZ for the C800VL (the GSM version). We only have the V10D_00.KDZ for the C800DG (the Verizon version). vtinoc's phone is GSM, but he flashed it with the other version. It unbricked his phone, but it doesn't have the right stuff for GSM communication.

    BTW, can someone remind me again why we started a separate thread? It's exactly the same subject as the original thread, and that one has a lot of valuable background material in it.
  9. strumcat

    strumcat Member

    Sorry to hear that, vtinoc. We really need to find the right KDZ file for the C800VL, I guess. I've been searching for it without success, but I'll keep trying. I might need it at some point, too.
  10. chui101

    chui101 Member

    In that case we might just need to figure out which partition contains the radio. I'll dump all of them so we can experiment!
  11. chui101

    chui101 Member

  12. vtinoc

    vtinoc Member

  13. vxbinaca

    vxbinaca Member

    Whos building the stale AOSP GB for the c800?
  14. vxbinaca

    vxbinaca Member

    Can someone make an update.zip from this? I've never been able to get the phone into fastboot and 2b isn't working, doesn't overwrite the recovery and just wipes out my spare c800.

    I could flash from stock recovery with an update.zip.
  15. mudtub

    mudtub Active Member

    You should always be able to access fastboot by removing battery, hold down HOME (physical button on keyboard) and power.
  16. vxbinaca

    vxbinaca Member

    No dude, thats not working. Pull battery. Wait 20 seconds. Depress physical home button on keyboard. Insert battery. Hold power button until LG logo appears. All this time I'm still holding that home button. With my free hand (acrobatics) I'm running (up-enter in terminal on laptop) adb devices over and over to see if i can see a device, nothing. Home button is still depressed. Android logo comes up. Chuck phone across room.

    And by the way this turd is rooted so i have busybox on it and can reboot to bootloader. I do that to see if i get that white screen, and what I get is stuck at the LG logo.


    You guys must have modded phones because my stock c800 doesn't do it when i follow the instructions
  17. vtinoc

    vtinoc Member

    You can adb reboot bootloader from the charge icon
    Power off phone plug to PC wait to it shows the battery icon
    Then adb reboot bootloader to get in fast boot.
  18. mudtub

    mudtub Active Member

    No, you won't find a device in ADB.

    Code (Text):
    1. fastboot devices
    When it's in fastboot, it will hang at LG logo.
  19. brettvanpelt

    brettvanpelt Member

    i cant seem to get fastboot to work. i tryed flashing via phone but failed. so using adb i type
    "adb reboot bootloader"

    it reboots than hangs at lg screen like you guys said than i type fastboot devices and it comes back with nothing. why is this?

    does usb debugging need to be turned off?

    i
  20. vtinoc

    vtinoc Member

    Are all the drivers installed from the lg website?
    And have you tried to unplug and plug back in USB wile in fastboot.
  21. brettvanpelt

    brettvanpelt Member

    i do got the t-mobile version of the mytouch same as yours right?
  22. brettvanpelt

    brettvanpelt Member

    i am going to try that but when i tryed to install the recovery via phone. and test it i found that the install did not work and that i got the phone stuck to where every time it boots it wipes the phone. you know the android coming out of the box screen.

    now when i run adb reboot bootloader it goes to that screen now! lol any help?

    i just hope i dont gotta use that updater program to fix the loop.
  23. vtinoc

    vtinoc Member

    Now try to flash from PC
    Place the recovery.img somewhere like c:/
    Copy cmd where your adb files are and
    Have fastboot with the adb files and enter
    fastboot devices
    It should list ? Fastboot or something like that
    Then enter
    Fastboot erase recovery
    Then
    Fastboot flash recovery c:/recovery.img
  24. brettvanpelt

    brettvanpelt Member

    i got cmd and adb all ready. just cant get no fastboot to work i type fastboot erase recovery than it says waiting on device.

    adb its self works fine i type adb devices and phone is listed.

    fastboot.exe is in the same place as adb and all but i am lost

    edit: when i unplug phone while its on fastboot and the lg screen is hanging the pc says it cant find the driver. is it an different driver than the one needed by adb?
  25. vtinoc

    vtinoc Member

    Try this http://octopusbox.com/files/drivers/LGAndroidADBDriver.exe
    brettvanpelt likes this.

Share This Page