1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Return Your Xoom to Stock.


  1. OutOfPhase

    OutOfPhase Premium Member Guide

    This Will Restore Your Xoom back to Stock, Locked Factory State. It will wipe all your data that is not saved on the Micro SD-card.
    This program just automates the fastboot steps.

    This will return you Xoom to Honeycomb because that is the only fastboot files available to the community.

    The usual: Myself, Android Forums and any other person you want to include are not responsible for what you do with this or your device.

    I have tried this out on my 4G Xoom and it worked great so I thought to share it and also made it for the 3G and WiFi versions. I do have ADB set to run where ever I need it on my PC and this is set up to run ADB in a specific folder for those user that don't have ADB installed. If you have never installed ADB and this works for you please post back.

    This will help you if:
    1. You need to return your xoom to stock
    2. You screwed something up and are boot looping or your system keeps crashing.
    3. You just want to try it out for me.

    Downloads:
    4G Xoom Restore
    3G Xoom Restore
    WiFi Xoom Restore

    Steps:

    1. Download the zip for your Xoom
    2. Create a folder on your PC C:\Xoom (that's a Xoom folder on the c drive)
    3. Unzip the contents of the restore file into the folder you created so it looks like image
    4. Plug in your xoom
    5. Click on the Xoom_Restore.bat
    when the screen pops up answer yes if you downloaded the correct file, no if you didn't and go back and get the correct one.
    6. If you don't have your moto drivers for your Xoom installed answer no and follow the instructions on the screen to install motohelper. Then reboot your computer, plug in your Xoom and allow the drivers to install. Restart this program and answer yes you have drivers installed.
    7. Follow the rest of the steps on the program
    8. When your Xoom is restored you will have to allow the updates to download and install to get you to ICS or Jellybean depending on your Xoom.

    Good luck and let me know how it works for you.

    Advertisement
    John Dorian and Ketchup like this.
  2. thlobato

    thlobato New Member

    Does this will work at Xoom 2 ME WIFI (mz607)?
  3. OutOfPhase

    OutOfPhase Premium Member Guide

    Welcome to Android Forums :)

    No. I am trying to download the fastboot files for the Xoom 2 ME and see if it can be adapted. I will post back in a minute.
  4. OutOfPhase

    OutOfPhase Premium Member Guide

    I am still trying top find the files.... What is the problem you are having? I might be able to help you out with out using the files.
  5. SteverP

    SteverP New Member

    Hi. Very new and in desperate need of help.

    Xoom Wifi is not being seen by my computer.

    Can any of these files be copies to an sd card and flashed to the xoom?

    Long story but lost ROM and nothing seems to work. I can get into recovery mode.

    Any help would be appreciated...

    SteverP:confused:
  6. OutOfPhase

    OutOfPhase Premium Member Guide

    Welcome to AF SteverP. :hello:

    The files I have posted can not be flashed on the xoom they have run from your pc. Did you follow the instructions I posted in the OP? I am assuming you unlocked and rooted your device.

    I can definitively get you going again with a little info.

    Did you make a back up of your rom?
    What recovery are you using?
    What rom were you using?
    Do you still have a copy of that rom on your sd card?
    MBProductionz likes this.
  7. MBProductionz

    MBProductionz Member

    Hello, i've had a problem with the stock restore method.
    I have Xoom MX601 with 3G, i bought second hand, it had an OS version of 4.04 and the 3G wasn't working. The person i bought it from refusing to refund for faulty 3g issue.

    Anways, thought i'd try the stock honeycomb, as he claimed only ever used official upgrades, but he never used 3g.... probably did till he stuffed it in!

    So i ran your steps as noted... (FYI may want t state device needs bootloader unlocking, else won't run)

    Steps went through fine and i go to the point of re-locking bootloader.
    First time through i opted to do this, i got an error on reboot - Failed image LNX 0x0002.

    So can still restart the device and get into fastboot (fairly savy with pc and commandprompt) so used fastboot to unlock bootloader again then re - ran your install this time refusing to lock device bootloader.

    Now all i get is the Motorola Dual Core Technology screen and nothing more.
    Didn't have CWM installed on Xoom so no backup made... although nothing to backup user wise anyway.

    Any suggstions or advice?

    Thanks

    Ben
  8. OutOfPhase

    OutOfPhase Premium Member Guide

    Try powering off by holding volume up and down and also power. As soon as boot logo disappears hokd the volume down button until you see fastboot protocol on the screen. Then try and run my script again. If this does not work we can do it manually.
    MBProductionz likes this.
  9. OutOfPhase

    OutOfPhase Premium Member Guide

    The problem might have been when you tried to look the bootloader that was already locked. the last step in the script is to lock the bootloader.

    Try what I posted above and you should be fine.

    You should not have to unlock your bootloader in order to flash stock images. You might have something else going on.
    MBProductionz likes this.
  10. MBProductionz

    MBProductionz Member

    Hi OutofPhase, Thanks for your reply. Will look at attempting this again tonight or tomorrow night (depends what time i get home). Will post back with results and maybe attempt a manual install if needed.

    Currently got a cutsom rom from XDA installed, which isn't what i'm actually after.
    Main goal is to try getting my 3g to work again, currently sim not recongnised.

    Think 2 possible reasons
    1. Device locked to a particular network
    2. Board faulty causing sim card to not be recognised.

    Anyway, again thnks for your reply and i'll be in touch. :)
  11. OutOfPhase

    OutOfPhase Premium Member Guide

    Dumb question but is your sim card active?
    MBProductionz likes this.
  12. MBProductionz

    MBProductionz Member

    Hello outofphase,

    So update, tried your installation method again and returnd same error "Failed image LNX 0x0002"

    I locked bootloader manually "Fastboot oem lock" (went through onscreen options) then re-ran.

    Message pops up in red "Device still locked. Device must be unlocked first. Failed to process command error(0x8)"

    and Yes Sim cards are active for data. :) both are orange sims 1 personal and 1 work.

    FYI, while i had software on xoom i ran a logcat for radio command but output files are too big for upload... didn't want to cut any data out as not sure what is relevant to not being relevant! Can upload somewhere if you wish to see these files.

    Think starting point is to get Stock Rom and baseband on the unit.... then update from there.

    So, i'm fairly tech savy, i.e know to open .bat files and comfortable running commands in cmd. Have android SDK installed with Eclipse for work testing stuff.

    Presume manual install would be to follow the steps in the .bat.
    If this is correct, is there a chance one of the image files is bad or wrong. Hence the error LNX 0x0002.

    Thanks

    Ben
  13. OutOfPhase

    OutOfPhase Premium Member Guide

    I would try running fastboot manually to see which step is failing.

    What network are you trying to we the Xoom on?
    MBProductionz likes this.
  14. MBProductionz

    MBProductionz Member

    HI oufofphase,

    So i managed to get the stock rom on following your install .bat manually.
    but used files from another stock image.

    however still no coms, baseband and kernel still the same tho.

    Baseband:N_01.100.07p
    Kernel:2.6.36.3 a7301c@il93lnxdroid47 #1

    Trying to get the 3g on Orange/EE.

    P.S. Tablet auto upgraded when i connected to wifi.

    Any ideas with what to check next?
    Do i need to regress baseband or kernel (Not sure what these things actually are)

    Thanks

    Ben
  15. OutOfPhase

    OutOfPhase Premium Member Guide

    Does wifi work still? I think the issue with 3g is that you are trying to use the xoom on a network other than Verizon's. The us xoom is a cdma/3g/lte network device which is verizons network. The otherbetworks luje att use GSM for their data and the XOOM is not capable to do it.
    MBProductionz likes this.
  16. MBProductionz

    MBProductionz Member

    yes wifi still works, xoom is a mz601 with the EU software build. Suppose it could have had the wrong radio software added. So device model and software are both EU based.

    Had an error up while receiving further updates stating "A SIM CARD ERROR HAS OCCURED. A MOBILE DATA CONNECTION CANNOT BE MADE UNTIL YOU INSERT A VALID SIM AND POWER CYCLE THE DEVICE"

    Power cycle didn't do anything, so i guess from this error, this tells me there's no hardware fault here! and that it's a software issue!

    Would you agree?

    Cheers for all your support so far
    Frustrating this stuff, especially when it's all new to me.

    :)
  17. OutOfPhase

    OutOfPhase Premium Member Guide

    Now we are getting some where. The 3g restore have posted is for the us version. That is the reason it is saying it is
    download this file here( it is the EU software) and copy it over where you unzipped the others and then run either the manual or my script. et me know what happens.

    The radios are messed up because the kernal/baseband are looking for cdma lte hardware so it is throwing the error.
    MBProductionz likes this.
  18. MBProductionz

    MBProductionz Member

    Okay so i mentioned i used other rom image but followed your instructions... just so happens it was the same rom as the one you asked me to download.

    This was the rom where i got the error.

    Does the Baseband and kernel update with the rom or are these additional fixes /updates?

    I have progressed the stock software all the way through to ICS 4.0.4 using motorola "update Software" tool under settings.

    At each stage i tested the 3G and no joy.

    Can you think of anything else to try?
    Me thinking of giving up soon and sending back to seller? A lot of effort to sort something that should have been working when i bought! lol

    :)
  19. OutOfPhase

    OutOfPhase Premium Member Guide

    I can't think of anything else. I would try and return it. Sorry I wish we could have fixed it.
    MBProductionz likes this.
  20. MBProductionz

    MBProductionz Member

    OutofPhase, thank you very much for your time and advice.
    You have been exceptionally helpful and quick with your responses.

    Will be returning the device, or at least attempting to... possible paypal disbute!!

    Thanks Again!

    :)
  21. yeehaw77

    yeehaw77 Member

    Hey OutofPhase, how do I know if the moto drivers are still installed?
  22. OutOfPhase

    OutOfPhase Premium Member Guide

    When you plug it into your PC your xoom should show up, if not you need to load them on.
  23. yeehaw77

    yeehaw77 Member

    I'm getting a message in the command prompt " 'adb' is not recognized as an internal or external command, operable program, or batch file.
    I do not see my tablet that looks like a bunch of #.
  24. OutOfPhase

    OutOfPhase Premium Member Guide

    You don't see your tablet because adb is not running. When you unzipped the file is adb.exe there? Did you unzip the script to c:/Xoom?
  25. yeehaw77

    yeehaw77 Member

    Yes abd.exe is there, and yes I unzipped to the folder I created c:/Xoom per your instructions. Looks just like your image link.

    I went ahead and also tried to install the moto drivers, but that's not working either. When I did that the command prompt said "MotorolaDeviceManager_2.3.4 is not recognized as an internal or external command".

Share This Page