1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Samsung Galaxy S2 4G Root & Recovery


  1. Jaay Dogg

    Jaay Dogg Well-Known Member Developer

    Use Odin to install recovery.tar then flash the root zip via CWM.......

    CWM Touch Recovery 6.0.1.2 Link:

    TWRP Recovery 2.3.1.0 Link:

    Superuser, Busybox, Flashable Root zip Link:

    Odin 3.04 for Windows Link: Odin3-v3.04.zip


    Samsung Galaxy S2 4G USB Drivers:Sprint_L710_GSIII_Samsung_USB_Driver_v1_4_6_0.exe
    Not 100 % sure about these drivers, read they work for this phone as well.


    Hope this will help get this section going.

    Advertisement
  2. TheBritton

    TheBritton Resident Galaxy Cat Guide

    Awesome, man!
    Has this been tested? Not that I doubt you (I know from other threads that you are very credible and respected), just figured it wouldn't hurt to ask :)
    Jaay Dogg likes this.
  3. Jaay Dogg

    Jaay Dogg Well-Known Member Developer

    I'm not 100% sure as I don't have my Galaxy S2 yet, soon. I have rooted & put custom recovery on at least 15-20 different android devices, so I'm all most positive that these are the required files for root & recovery, I know you don't mess with Odin unless you know what your doing, killed a Samsung Galaxy with Odin about a yr.ago when I was first starting out, Learned so much since then. All these processes are reversible via Odin with the phone in download mode (yellow triangle) I'll have to extract the stock recovery once I have the phone.

    So how is the S2 ? Is it a good devices ? It's basically an Epic Touch 4G right ?
    TheBritton likes this.
  4. striker325

    striker325 Well-Known Member

    I got mine today. Its very snappy and quick. I am still trying to figure this phone out since its different from the triumph
  5. Mprfctgntlmn

    Mprfctgntlmn Member

    Will this work for the Boost version of the galaxy s II 4g?
  6. PianoHijacker

    PianoHijacker Member

    I hope you get it real soon because I need the stock VM rom for this phone. I inadvertently put a stock Sprint rom when rooting. I made a separate thread hoping someone will get or have the stock rom. Here's hoping you can get it off the phone and on the forums.
  7. mhlsilverdale

    mhlsilverdale Well-Known Member

    Jaay Dogg,

    Could you explain how TWRP Recovery 2.3.1.0 fits into this? Is it an alternative recovery to CWM or does it have to be installed in addition to CWM?

    ... The rest of this post was edited to remove a rooting discussion that PianoHijacer (below) says will not work correctly for the Virgin Mobile S2.

    >Mark
  8. TheBritton

    TheBritton Resident Galaxy Cat Guide

    It's a GREAT phone! I've been playing with it all day but it's still not activated! They tell me to enter the ##847446# but it doesn't do anything. They instructed me to do a profile update from the settings menu but apparently I need a 4G connection which I do not have one since I am in a rural area. I've had it for almost a full day and still can't get it activated LOL!
    But yes, I love this phone! very very fast! I'll probably give your root methos a try. if anyone else successfully roots the device, please post here so I won't be so nervous about doing it haha! :D
  9. TheBritton

    TheBritton Resident Galaxy Cat Guide

    Geex the lady just told me I must have a 4G connection to activate the phone! Nearest 4G is an hour away. I say "So you're telling me I need to drive an hour just to activate this thing" she says "yes sir" ... please :-/
  10. PianoHijacker

    PianoHijacker Member

    To late. I've already done the guinea pig work for that. That's why I now have a Sprint stock rom. I am rooted and everything works for the most part. But I want to get back on Virgin Mobiles stock rom. Mostly because it wants me to set up a Sprint voicemail and people now tend to sound a bit metallic.

    And to TheBritton, that is just stupid. You shouldn't have to be on 4g to just to activate it. I didn't.
    mhlsilverdale and TheBritton like this.
  11. TheBritton

    TheBritton Resident Galaxy Cat Guide

    Awesome!
  12. GregoryJ

    GregoryJ Member


    That is absurd. I would call VM back and ask to speak to the tech support team. They were the only ones to know what they were talking about.

    When I first activated and swapped my phone online, I didn't get confirmation of it going through. So, I called VM customer service and after repeated ##*847 or whatever the hell it is the rep goes on to tell me that my phone is broken and I need to return it to the store I purchased it from. I had just left Radio Shack about an hour before the phone call. I told the rep there is no way in hell he can tell if my phone is broken and I need to speak to someone else.

    I get transferred to tech support and the rep there tells me the switch already went through and I just need to give it an hour. So I went from needing to drive back to Radio Shack and return a brand new working phone to waiting an hour and all is well.

    Big difference in just 2 different rep's answers! I would def call back before you make that drive!
    TheBritton likes this.
  13. TheBritton

    TheBritton Resident Galaxy Cat Guide

    I'm on with tech support as we speak :)
  14. TheBritton

    TheBritton Resident Galaxy Cat Guide

    Jaay, how do you get the phone into download mode? I'm about to attempt root :D
  15. mhlsilverdale

    mhlsilverdale Well-Known Member

    Yeah, I think your joking, but just in case, I can field that one...

    1) Power + vol down (lower volume button) hold until screen appears

    2) Release both buttons

    You'll see a warning screen

    3) Press the vol up control to go to down loader mode.


    > Mark
  16. TheBritton

    TheBritton Resident Galaxy Cat Guide

    Okay, I figured ;)

    I've never rooted a phone with Odin so I've downloaded all the files. I'm gonna follow a YouTube video guide just to be safe..
  17. TheBritton

    TheBritton Resident Galaxy Cat Guide

    For the record, the activation problems I was experiencing today was because after I swapped the phone via Virgin Mobile's website, I needed to wait about an hour for the handset to be activated over the air. I know this isn't related to the thread but I just wanted to put that out there for what it's worth ;)
  18. TheBritton

    TheBritton Resident Galaxy Cat Guide

    I tried to flash Clockwork .tar file with Odin and it says "Failed" .. should I have used the PDA option?
    When I try to flash Clockwork recovery with Odin I get this error:
    <ID:0/004> Added!!
    <ID:0/004> Removed!!
    <ID:0/004> Added!!
    <ID:0/004> Odin v.3 engine (ID:4)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004> Firmware update start..
    <ID:0/004> &#8249;
    <ID:0/004> NAND Write Start!!
    <ID:0/004>
    <ID:0/004> Complete(Write) operation failed.
    <ID:0/004> Added!!
    <OSM> All threads completed. (succeed 0 / failed 1)

    EDIT: I think I just bricked my device. I need some help :-/ I gave up on trying to flash the recovery with Odin but now when I try to boot my phone it says "Firmware encountered an error with upgrading. Please use Kies to enter recovery" ?? What does that mean?
  19. mhlsilverdale

    mhlsilverdale Well-Known Member

    I don't have my phone yet (Friday), so I'm just going on what I'm reading on the WEB. However, your situation is frequently reported.

    What happens when you hold down the volumn UP button (first) then add the power on button (hold both buttons down) for about 5 seconds. Do you enter into a recovery mode?

    If you get in recovery do a hard reset of your device.

    From what I've read you should use the PDA option in odin.
    Some have reported trying to use odin up to 10x's before they got the update to work so keep trying.
    If you can get your device to boot, there is a odin mobile app on the Google Play Store that might be a bit more user friendly.
    TheBritton likes this.
  20. TheBritton

    TheBritton Resident Galaxy Cat Guide

    THANKS! I tried the up button but that doesn't seem to work either. Still get the firmware upgrade error. So I should still keep trying to flash that recovery with Odin?

    Here is a pic of the error I am getting: http://i72.photobucket.com/albums/i183/britandkristy/IMG_20121121_233753.jpg

    EDIT: and yeah, I've tried it well over 10 times and it's not working. If I can't fix it, guess I'm gonna have to get a replacement phone and I'm probably not gonna try this ever again :-/
  21. TheBritton

    TheBritton Resident Galaxy Cat Guide

    Virgin Mobile is sending me a replacement.

    I want to apologize for posting so much in this thread. A MOD may delete my useless ones. I went into a panic when my phone was bricked. Also, I don't mean to discourage anyone from trying this root method. May it be noted that this was the first time I have ever used Odin, but let this be a reminder to others that Odin can very easily ruin your device if you are not absolutely sure what you are doing. Personally, I will not try it again unless I feel I have gained much more knowledge on the subject. This is not some one click method like the Gingerbreak on the Triumph ;)

    Thanks for bearing with me and all my posts and I hope everyone has a wonderful holiday!
  22. mhlsilverdale

    mhlsilverdale Well-Known Member

    VM is fast at replacing phones, you should get your new one in two business days (probably Monday). So, you have a few days to try and "defib" your current phone. At worse, you'll just end up gaining some knowledge. Search Google on your error message "Firmware encountered an error with upgrading. Please use Kies to enter recovery" and see if someone can offer you a solution.

    Did you check the build number on the phone? Settings > About Phone > Build Number. The latest is F127. The prior updates FF18 and FH13 and were known to have a bug that would brick the phone during some types of flashing. Since these updates are pushed over the air to the phone, it is possible you had an earlier build that hadn't auto-updated yet. I believe F127 came out in late October.

    As a side note; when these updates occur, you will lose prior recovery and root installations and you will have to seek out the revised CMW/Rooted software for the new update. So, even if you successfully root your phone an update to F127 or a Jelly Bean push will leave you (once again) with a stock phone.

    When you install CWM on this phone it requires you flash a new kernel which is the core of the operating system. The kernel is the "brain" of the OS; It's not as simple as it was on the Triumph where we just had to replace the recovery.img file in the boot loader.

    Personally, I'm only looking for a method to root my phone that doesn't required a recovery flash of the kernel. I just want to be able to use Titanium Backup, delete the bloatware and possibly modify some scripts. Current OS should be good enough for a while.

    Get use to being on the "bleeding edge" for a while, thanks for the sacrifice; knowledge gained...

    Anyone have the build number available on their stock VM S2 phone??

    > Mark
    TheBritton likes this.
  23. PianoHijacker

    PianoHijacker Member

    The build number is FJ12. FI27 is Sprint.
  24. mhlsilverdale

    mhlsilverdale Well-Known Member

    Thanks (that's embarrassing)

    Link to the open source (Enter FJ12 in search)

    Samsung Open Source Release Center

    Hopefully with Samsung doing the Virgin Mobile mods, this phones OS will be in better shape than what Motorola dropped on us for the Triumph.

Share This Page