Samsung galaxy S2 cant be turned on!Support


  1. lazyduck

    lazyduck New Member

    My galaxy s2 was working just fine, I left it on the table and when I came back I couldn't turn it on, it's just a black screen. I've tried putting the battery in my friend's galaxy s2 and it works, so it's not the battery problem. Does anyone know how I can fix this?

    Advertisement
    :
  2. Russell Ng

    Russell Ng Well-Known Member

    What version are you using? Has it recently been updated? Sometimes after updates, there are clashing with remnants of old firmware and new. This can cause all sort of problems. The only way so far is to do a factory reset and wipe the old cache clean.

    Other causes reported is to do with certain apps and also wifi. Would like to have a little more details so people can try to zoom down the problem for you. Things like version, wifi on, etc...

    Cheers
  3. lazyduck

    lazyduck New Member


    I am not sure what version it was, I think it was version 2.3.6. Yes, I've updated it recently. How do I do a factory reset it? No, my wifi wasn't turned on and I wasn't using any app before it crashed.
  4. Russell Ng

    Russell Ng Well-Known Member

    No guarantee that this would solve your problems, but the chances are high if its to do with software issues and not hardware. On startup, instead of pressing the power button only, press power+home+vol up button at the same time.

    You will go into a menu section where you navigate using vol buttons and home button. You will have option to wipe cache, factory reset etc. Please take note that all apps and settings will be reverted back to original. So you should back up contacts, calenders and everything you can before doing this. You will maintain your firmware update though.

    Cheers
  5. lazyduck

    lazyduck New Member

    I've tried to press those buttons but it still didn't work because it can't even startup. It's like the phone is dead and wouldn't startup at all.
  6. Russell Ng

    Russell Ng Well-Known Member

    Guess you have to sent it back for a replacement
  7. heartburnron

    heartburnron Well-Known Member

    Do you have an exteranl SD memory card? If so, try taking it out then turning on the phone. This worked for me when the same thing happened...
  8. ilyakogan

    ilyakogan New Member

    My phone wouldn't turn on, it was stuck on the "Galaxy SII" screen. I just solved this issue by re-installing the CWM recovery on the phone (the same one I installed in the past). You can find the instructions by googling "Root and CWM Recovery for O2 Galaxy S2 XWLP3 Ice Cream Sandwich Firmware" or something silimar.
Loading...

Share This Page