[SOLVED] rooting IDER A10 box


Last Updated:

  1. walteroa

    walteroa Well-Known Member

    Does anyone have info about how to root this hell box? :mad:

    /// SOLVED /// please find the solution below on this post (rooting tools included).. :D

    Advertisement
    wolfgangpauli likes this.
  2. ruzzolone

    ruzzolone New Member

    Model A9 is there an app called z4root, for model A10 no app do the rooting( Android 2.3 )
  3. walteroa

    walteroa Well-Known Member

    cool! let me try in a couple of minutes and let u know!!!

    Thaaaaaaaaaaaannnnnnnnkkkk youuuuuu !:D
    wolfgangpauli likes this.
  4. walteroa

    walteroa Well-Known Member

    i have an A9 with 2.3 :confused:

    Attached Files:

  5. walteroa

    walteroa Well-Known Member

    quick results...
    after run the app... rotating circle say below.. "attempting to apply root" and got stuck there.. did I brick the box? :eek:
    wolfgangpauli likes this.
  6. walteroa

    walteroa Well-Known Member

    not bricked at all, but still unrooted and Z4root cannot run anymore. :confused::mad:

    HEEEEEELP !
    wolfgangpauli likes this.
  7. walteroa

    walteroa Well-Known Member

    No way to root ider A10.

    I've been chat for a while thru skype with ider support, requesting for root access.
    After 3 hour giving the explanations why should i have to have root, they ask their developers (fortunately online) and the answer was textually:

    "the product does not support root" and " the software doesnt support this function"

    So, as a conclusion:
    if you bought this box.. no root possible.

    You can think you have a brick? maybe yes. but you can deal with it...

    anyway; great support for the overseas agent: Mrs. Snow Yin thru skype.
    wolfgangpauli likes this.
  8. bthoven

    bthoven Well-Known Member

    Hi walteroa,

    I have the same box. Tried Gingerbreak (designed for some Android 2.3 devices) at no avail.

    I believe it can be rooted in the future, just wait :)
    walteroa and wolfgangpauli like this.
  9. walteroa

    walteroa Well-Known Member

    any news on this?
    wolfgangpauli likes this.
  10. wolfgangpauli

    wolfgangpauli Member

    Maybe. The ider A-10, Sumvision Cyclone Android Media Centre and my no-name box from AsiaPads seem different brands of one and the same box.
    I 'll try to flash a modified FW in order to get it "rooted".Will let u know the results soon.
    leodfs, bthoven and walteroa like this.
  11. walteroa

    walteroa Well-Known Member

    cool man!
    so anxious... i cant wait ;)

    many txs!!!! :)
  12. bthoven

    bthoven Well-Known Member

    Please let us know your result. Interesting.

    Wolfgangpauli, may you show the photo of the box?
    walteroa likes this.
  13. wolfgangpauli

    wolfgangpauli Member

    Ladies (if any) and Gentlemen,
    for the moment I am not allowed to post links nor photos here due to some restrictions that I understand quite well. As soon as this changes I will post here all the information that I have on this box. Mine is disassemled and I am very interested already what my investigation on the 2 (?) UARTS will show. So keep on reading...
    Cheers,
    wolfgang pauli
    walteroa likes this.
  14. wolfgangpauli

    wolfgangpauli Member

    In advance I can give you the "phone info" of my box. It resembles very much to what walteroa posted already (walteroa, are you spanish or where did you buy your box?)

    Model number: MBX DVBT reference board (c03ref)
    Android-Version: 2.3.4
    Kernel-Version: 2.6.34 (rwf@rwf-virtual-machine #6)
    Build-Number: GB.MBX.20111125
    walteroa likes this.
  15. wolfgangpauli

    wolfgangpauli Member

    walteroa likes this.
  16. wolfgangpauli

    wolfgangpauli Member

    The sumvision seems to be the same thing as I mentioned yesterday, but I was not yet ableto post links nor photos:

    News Sumvision Cyclone Android Media Centre Firmware Installation | Disk Depot

    Here you can also get the firmware files, but I warn to no install these, Finally I ended up that I cannot return to recovery mode...;-(
    So you know why I have to dig a bit deeper in oder to get control over the machine.

    Cheers,
    wolfgangpauli
    walteroa likes this.
  17. walteroa

    walteroa Well-Known Member

    I bought in China, but I'm living in Latin America.. Argentina Precisely...
    Anyway, I can change the lenguage and take a new picture if neccesary!!

    comming back to chinese clone boxes, the only difference seems to be the compilation number or version (the one that I have, cames from Ider itself, refer to details in this post ..)

    so, now its your turn to try and let us know about experiences!!! ;)
    VARG614 likes this.
  18. walteroa

    walteroa Well-Known Member

    The instructions is almost the same that I've got directly from ider.

    Also Ider haven't update some screenshots (A9 instead of A10), but for sure its supposed to be the same...

    so.. let us know if finally bricked or alive again!!! Good luck :D
  19. wolfgangpauli

    wolfgangpauli Member

    Hola Walteroa,
    no es necesario cambiar el idioma. Manejo el castellano bastante bien ;-)

    Here is a foto of my opened box. You can see the (suspected) UART (?) connector next to the external SATA port (top of the image). For the moment no further results. Keep you updated.

    http://web.student.tuwien.ac.at/~e8926866/box1.jpg

    Maybe we get valueable information here about rooting similar boxes (bought from DX china)
    Firmware upgrade? [Update: Download Link here] ? DealExtreme Forum

    best regards,
    wolfgang_pauli
    leodfs and walteroa like this.
  20. walteroa

    walteroa Well-Known Member

    Do u want me to take a picture of my box too?
    Pls let me know..

    Btw: the hardware rev seems to be the same.. but im not a programmer neither expert, so i prefer to wait your results :thumbup:
  21. walteroa

    walteroa Well-Known Member

    hi wolfgang...
    any news about your results?
    txs in advance :D
  22. wolfgangpauli

    wolfgangpauli Member

    Hola Walter!

    De hecho tengo buenas noticias. - I have good news, indeed.

    With the encouraging hints of a colleague (credits to Henrik H.) of mine I found out that the 6pin connector in my picture posted above is indeed an UART (serial device) that spits out masses of valuable information about the boot process.
    This is probably the clue for debugging and - hopefully - also for rooting. Though I am not able to give an instruction yet on how to root this device it may give others a hint how to manipulate it or get valuable debug info about the boot process or for unbricking the device ...

    Hasta pronto,
    wolfgang
    walteroa likes this.
  23. walteroa

    walteroa Well-Known Member

    cool!
    im not an expert, but seems to be a very good advance on it.
    keep going.. sooner or later.. we will have our ider A10 rooted too :D

    congrats for the advances!!!!!!!
  24. wolfgangpauli

    wolfgangpauli Member

    The last 3 weeks have revealed some further secrets of this box.

    1) The bootloader is a customised (i.e., not all commands work) version of
    U-Boot 2010.06(dvbc_8726m1_v1@trunk) (Jan 09 2012 - 15:02:36)

    2) The 6pin connector on the right-hand side of the SATA connector is an UART. Connecting an USB-to-UART bridge one can listen and talk to the machine (i.e. debugging console and uboot command line)

    3) The keyboard setting is a bit strange, but systematic with respect to the ASCII table. In order to execute uboot commands I send ASCII character sequences to the device using the PERL programming language.

    4) The debugging console actually showed me that the recovery mode of my box does not work any more.
    ### ERROR ### Please RESET the board ### is the last line that I get out of the box after starting by pressing the recovery button

    5) Nevertheless, it is possible to boot into recovery mode. I set up a linux box as tftp-Server and provide the uImage_recovery file via this box (it is necessary to set the corresponding parameters in order to match one's network configuration). Uboot command 'tftpboot' allows booting via a tftp-server on the network.

    6) As soon as a display is connected via HDMI the debugging console / uboot command line stop working

    7) At the moment I can only imagine the following ways of 'rooting' the box:

    * find a suitable android 2.3.4 exploit
    * find a way to get 'su' and 'superuser.apk' integrated into the ROM
    that passes by the signature check of android recovery <3>
    * get a manipulated android recovery <3> that does not check the or try
    android recovery <2> (i do not know if this is possible)

    8) ASAP I'll write up all the results and steps that I went through as a basis for further experiments with the aim of finally getting it 'rooted'.
    leodfs, walteroa and bthoven like this.
  25. wolfgangpauli

    wolfgangpauli Member

    WARNING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    DO NOT APPLY THE BELOW MENTIONED METHOD FOR ROOTING! I AM FACING STRANGE BOOT BEHAVIOUR THE DAY AFTER. I DO NOT YET KNOW WHY. THE MACHINE HANGS AT THE "A9"-SCREEN
    I HAVE TO INVESTIGATE FURTHER WHAT COULD BE THE REASON (WLAN, HDMI, USB...)
    wolfgang_pauli
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


    Dear Enthusiasts,

    I am happy to announce to have successfully rooted the box.[​IMG]

    Thanks to yareg with a minimum of effort.

    I downloaded this file
    http://dl.dropbox.com/u/4546860/update.root.yareg.march.2012.zip
    following this thread
    Firmware upgrade? [Update: Download Link here] ? DealExtreme Forum

    I did not unzip the file but renamed it to update.zip. I put it on a USB stick (fat 16 formatted).
    Booted into recovery mode und applied the update (this adds superuser privileges to your already existing Android 2.3.4 system)

    That's all!

    Please be warned, this worked for me but may not work for you. I may not be held reliable for any damages of your box!!!!!!!!!!

    Best regards,
    wolfgang_pauli

    PS: Comments and reports of successful "rooting" highly appreciated!
    hubshi, bthoven and walteroa like this.

Share This Page