strato root problem


  1. matthew9170

    matthew9170 Member

    Sorry if this is in the wrong section, but i have a problem when I try to root my strato. I try to install a different kernel like knightcrusader's and I am almost certain it didnt work. I have CWM-recovery installed correctly I think via the odin method and now after I installed CWM odin no longer sees my strato. I try to install the SU binary and cwm says it installed but the superuser app says that su is not installed. I installed the superuser app via cwm so i know that that part works.
    Any help would be appreciated, thanks
    -Matt

    Advertisement
    :
  2. acejavelin

    acejavelin Well-Known Member

    It sounds like you didn't mount /system in CWM Recovery before installing Superuser.ZIP... Just try it again and this time before you install it, go in CWM to mounts and storage and make sure /system is mounted (it will say 'unmount' if it is correctly mounted), then go back and install Superuser.Zip again. Should take care of the problem. Also, not being seen by ODIN is usually because USB debugging is off, try turning it on again (when the kernel changes it turns off sometimes). ODIN shouldn't really be needed after CWM is installed anyway.

    There is lots of good stuff for the Stratosphere on Rootzwiki, kernels, themes, ROM's, etc... I would look there too if this doesn't fix your issue.
  3. matthew9170

    matthew9170 Member

    I just tried it again and I mounted the system partition but it is still not working. I installed root checker and it says root is not on and when i try to update the su-binary via superuser app it keeps failing at asking for root, what am I to do about this. Also I tried to install the knightcrusader kernel through cwm it says it installed but super user is saying busybox is not installed and keeps failing at asking for root. Any help would be great thanks.
  4. AntimonyER

    AntimonyER AF Addict VIP Member

    Hey, I moved this to the All Things Root section. Thanks for understanding. :)
    acejavelin likes this.
  5. matthew9170

    matthew9170 Member

    I thought it was in the wrong section, thanks for fixing that. So does anyone have any thing that may help me?
  6. acejavelin

    acejavelin Well-Known Member

    I am not sure why it isn't working. If you have ClockworkMod Recovery installed and the Superuser-3.0.7-efghi-signed.zip from androidsu.com/superuser page in the root of your SD card, all you need to do in CWM Recovery is mount /system (so that it says "unmount /system") then install that Superuser file I just listed. That is all that is needed.

    Note that there are some older rooting guides that had special builds of Superuser.Zip, they are outdated and cannot be used with the CWM method described above, make sure to use the official one from androidsu.com

    If you continue to have problems I would check this thread, and ask for assistance there: [How-To][Guide]Rooting the Stratosphere - Simplified - Stratosphere - RootzWiki

    The rootzwiki Stratosphere section is much more active and has current development of kernels for the Strat too, you will probably get more responses there.
  7. dwitherell

    dwitherell Well-Known Member

    Out of curiosity - in Superuser if you go into Prefences and scroll to near the bottom what version of Superuser does it list? And (more importantly) what version of the su binary? I'm not sure what could be causing it, but it may just be a permissions issue.

    Once the root stuff is figured out, you should be able to use an app like Busybox Installer to get busybox up and running.
  8. matthew9170

    matthew9170 Member

    Superuser that is currently installed is 3.0.7 and when i try to update the Su binary via superuser it says legacy for the installed binary and when i try to update it it fails at asking for root. I dont think its a superuser app but the su binary.
  9. matthew9170

    matthew9170 Member

    Thanks for that download, that one worked. Now to uninstall all the verizon bloat.
  10. acejavelin

    acejavelin Well-Known Member

    matthew9170 and dwitherell like this.
  11. matthew9170

    matthew9170 Member

    Okay, I am trying the tweeked kernel now it seems nice, can I change the boot animation with this at all?
  12. acejavelin

    acejavelin Well-Known Member

    I believe so but never tried it, the rhcp kernel supports that... I think there is a thread on Rootzwiki about it.
Loading...

Share This Page