1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Unable to Scan for NetworksSupport


  1. seanasdf

    seanasdf New Member

    I'm having a strange issue with Wi-Fi on my Samsung Moment (post CL14 update). I don't remember having this issue prior to the update, but I can't say for sure that it was something that started immediately after receiving the update.

    Whenever I turn on Wi-Fi, it says "Scanning" for about 5 seconds, then an "Unable to Scan for Networks" window pops up. Sometimes it scans just once, other times it scans 2 or 3 times, but eventually it automatically turns off the wireless.

    At first, I thought the problem was caused by a wi-fi toggle widget, so I tried factory resetting the phone to remove all of my downloaded apps, but I had no luck.

    My suspicion is that this is a hardware issue, but I'd love to hear if anyone has any ideas, or has experienced something similar.

    Advertisement
    :
  2. Covert_Death

    Covert_Death Well-Known Member

    sounds like a hardware issue, similar issue happened with my laptop once, it knew wifi was on the system but just kept scanning until the error came up. i had a bad wifi-n card. not saying this has to be the case but it does sound like it
  3. unsmart3d

    unsmart3d Member

    I am having the same problem today. Tried restarting the phone. Now taking the battery out and waiting a few minutes.

    Wifi turns on for about 15 seconds then turns itself off.

    :eek:

    P.S. I do *not* want to do a factory reset again.
  4. chibucks

    chibucks Well-Known Member

    What does it say when it turns on?
  5. unsmart3d

    unsmart3d Member

    Went to check and it turned on just fine now. Go figure.

    Didn't work 15 minutes ago after I put the battery back in and turned it on. Will have to monitor this issue closely.
  6. djisia87

    djisia87 Member

    having same issue.....
  7. kingcreole

    kingcreole New Member

    having same problem.
    'unable to scan for networks'... and turns wi-fi off.
    it then says 'unable to stop wi-fi'....
  8. simulator

    simulator Well-Known Member

    I had this issue on the captivate. Resolved after a factory reset. Blech.
  9. JuStViNcE

    JuStViNcE New Member

    I'm having the same issue with Wi-Fi on my Samsung Moment (post CL14 update). I can say for sure that my WiFi work flawless on CL14, then updated to 2.1, then immediately after receiving the update I have no WiFi.

    Whenever I turn on WiFi, it says "Scanning", then "Unable to Scan for Networks" window pops up. Sometimes it scans just once, other times it scans 2 or 3 times, but eventually it automatically turns off the wireless.

    Another side note is... I have two Samsung Moment, and mine updated to 2.1 fine, but the other phone had the issue after the 2.1 update

    Open for suggestions!
  10. bpmajors

    bpmajors New Member

    I am having same problem on Samsung Captivate AFTER I did the factory reset yesterday. I turn on scanner, and 10 seconds later it turns itself off.
  11. metagroove

    metagroove New Member

    Yeah i have the same problem too, my samsung moment is unable to scan for networks, im almost shure that is a hardware issue =(. when i see the phone
  12. kahale

    kahale Well-Known Member

    all i can say is either factory reset or re flash with sprint update tool. some apps can glitch android too, so be-careful what you install.
  13. rhinodad

    rhinodad Active Member

    I had the same problem a couple weeks ago and it turned out that the wifi radio was bad. Got Sprint to replace it.
  14. rghv65c

    rghv65c New Member

    The solution is to root the phone and then get to the corupt files and remove them. the phone will recreate the files and then the wifi will work. the unable to scan issue will be gone.

    I have posted an article on my site with complete how to instructions.

    here is the URL:
    Samsung Galaxy S WiFi Issue Fix | BK Integration does IT easy

    here are the steps.

    1. First root the phone:to do this download the "GTS" (Galaxy S Tweaker) app from the android market place. Open the app and then run step one to install the the root access. the phone will restart.

    2. After the restart download the android terminal app the name of the app is "Terminal Emulator"

    3. Open the terminal app and then enter these commands.
    - su (you will be prompted to give root access)
    - cd /
    - cd data
    - cd wifi
    - ls (you should see a file named "bcm_supp.conf"
    - mv bcm_supp.conf bcm_supp.conf.bak

    4. press the home key
    5. power off the phone
    6. power on the phone
    7. enjoy your wifi again...

    I hope that this helps, check out my site for further information.
    automagrt and jvanexan like this.
  15. bpderby

    bpderby New Member

    Thanks a ton. Solved the problem!
  16. skeerthy

    skeerthy Member

    **** SOLUTION - WITHOUT ROOTING *****

    I searched many forms to solve the "Unable to scan network" issue. All explained how to do it after rooting and I did not want to root my phone.

    Yesterday, while playing with the phone and SDK, I could repair it by deleting "bcm_supp.conf" file. This is what I did:

    1. Install the SDK -> Android SDK | Android Developers

    (make sure the <SDK>/tools path is added to the windows path variable. My Computer -> Properties -> Advanced -> Environment Variables -> System variable -> add the SDK path at the end of Path variable )

    2. On your phone, please enable (tick mark) "USB debugging" under "Settings" -> "Applications" -> "Development"

    3. Connect your phone using USB to PC/Laptop. Close phone manager application if it comes up on the PC.

    4. Run "ddms.bat" from <SDK>/tools directory. The DDMS application will come up and it should readily connect to your phone. (in the main screen, under Name, you should find the phone ID and SW ver. no.)

    5. Go to menu Device -> File Explorer. New window will come up.

    6. Here go to data -> wifi directory. You will see a file bcm_supp.conf.

    7. Though it is not possible to read this file, you should be able to delete it. (at least I could delete it). You can delete the file by selecting it and then pressing red "-" on top left of the window.

    8. Now close the DDMS and disconnect the USB. Enable WiFi and scan for networks. The bcm_supp.conf file will get created and you should be able to find the networks.

    Please note:
    1. Do this on your own risk.
    2. All your previous WiFi settings are gone as you delete the file.
    3. If you don't know how to install SDK, just google, you will find many forms explaining.
  17. steveorg

    steveorg New Member

    1 & 2 were no problem. I was able to confirm that I have access to the root directory through a file explorer app. I can even see /data (not the same as /sdcard/data), but the directory appears empty.

    My problem starts with the su command in Terminal Emulator. The response is "su: not found".

    Just in case this is relevant - I have a Captivate. Are there additional security barriers put in by AT&T? Any suggestions? Thanks.

    Update: I used a different method to root the phone. Now the su command works and I was able to go straight from 4 to 7 without steps 5 and 6. Thanks for giving me my wifi back!
  18. jvanexan

    jvanexan New Member

    Thank you very much...you saved me a ton of headache and a ton of money in non-wifi usage. worked as advertised. (Now if we could only figure out what causes the corruption in the first place...)
  19. automagrt

    automagrt Well-Known Member

    I HATE THIS PHONE! There is no excuse for all the problems it has. I tried the steps above but when I run DDMS I get the error "Failed to get the adb version: Cannot run program "adb": CreateProcess error=2, The system cannot find the file specified." I have tried installing the SDK on both a Windowx 7 64-bit and XP 32-bit machine. I get the same error on both machines. What could be wrong? I have to get WiFi working but do not want to factory reset my phone. I spent 4 hours getting Google calendar syncing correctly between all my devices and now the WiFi won't work anymore.
  20. momentoid

    momentoid Well-Known Member

    @automagrt Have you tried power-off/on the phone? :)
  21. automagrt

    automagrt Well-Known Member

    Yup. One of the first things I tried. I've done it many times since.
  22. automagrt

    automagrt Well-Known Member

    There is an error in this. The Path variable should point to "platform-tools" and not "tools". That's where adb is located. Unfortunately when I click on the + sign next to the data folder it doesn't show me anything. I'm assuming it has to be rooted to see the contents. Guess I'm going to have to end up factory resetting if after all.
  23. momentoid

    momentoid Well-Known Member

    Hope factory resetting works. Let us know.
  24. SirCheese

    SirCheese Well-Known Member

    One of mine is unable to locate any networks as well, hard reset of the phone made 0 difference.
  25. automagrt

    automagrt Well-Known Member

    Well I ended up rooting it because I did not want to go through the pain of factory resetting. I deleted the bcm_supp.conf file, restarted and it works fine now.
Loading...

Share This Page